Update to 6.0 final

This commit is contained in:
Martin Blapp 2002-05-22 12:42:36 +00:00
parent aa708b8149
commit b50512060d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=59694
12 changed files with 162 additions and 213 deletions

View file

@ -8,32 +8,28 @@
PORTNAME= staroffice
PORTVERSION= 6.0
CATEGORIES= editors linux
MASTER_SITES= ${MASTER_SITE_LOCAL} \
ftp://ftp.teleport.ch/FreeBSD/patches/
MASTER_SITE_SUBDIR= obrien
DISTNAME= so-6_0-beta-bin-linux-en.bin
DISTFILES= so60dat-20011016.tar.bz2
EXTRACT_SUFX=
EXTRACT_ONLY= so60dat-20011016.tar.bz2
MASTER_SITES=
DISTNAME= so-6_0-ga-bin-linux-en.bin
DISTFILES= so-6_0-ga-bin-linux-en.bin
.if defined(WITH_ADABAS)
DISTFILES+= soa-6_0-ga-bin-linux-en.bin
.endif
MAINTAINER= mbr@FreeBSD.org
FETCH_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1.0:${PORTSDIR}/emulators/linux_base-7
BUILD_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1.0:${PORTSDIR}/emulators/linux_base-7
BROKEN= "SUN beta program for 6.0 has been closed. Distfile is not available anymore"
USE_BZIP2= yes
ONLY_FOR_ARCHS= i386
NO_CDROM= 'Must be downloaded direct from Sun via www interface'
IS_INTERACTIVE= yes
NO_BUILD= yes
SOVERSION= ${PORTNAME}${PORTVERSION}
KDEHOME= .kde
WRKSRC= ${WRKDIR}/${SOVERSION}
TMPDIR= ${WRKDIR}/tmp
LD_PATH= ${TMPDIR}:${WRKSRC}:${LINUXBASE}/lib:${LINUXBASE}/usr/lib
INSTDB.INS= ${PREFIX}/${SOVERSION}/program/instdb.ins
OPENCONFIG= ${PREFIX}/${SOVERSION}/share/config/registry/cache/instance/org/openoffice
ADABAS_DIST= soa-6_0-ga-bin-linux-en.bin
.include <bsd.port.pre.mk>
@ -45,7 +41,8 @@ pre-fetch:
@${ECHO}
@${ECHO} Check if linprocfs is running: YES
.else
@${ECHO} -----------------------------------------------------------
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} Staroffice setup needs a running linprocfs, which is not
@${ECHO} activated on your system. Please read the linprocfs\(5\)
@ -53,10 +50,25 @@ pre-fetch:
@${ECHO}
@${ECHO} linproc /compat/linux/proc linprocfs rw 0 0
@${ECHO}
@${ECHO} -----------------------------------------------------------
@${FALSE}
.endif
.if ${OSVERSION} < 410000
.if !exists(${LINUXBASE}/etc/mtab)
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} The file ${LINUXBASE}/etc/mtab is missing.
@${ECHO} Staroffice needs this file else some functions
@${ECHO} are not working. You can create it with
@${ECHO}
@${ECHO} touch ${LINUXBASE}/etc/mtab
@${ECHO}
@${FALSE}
.else
@${ECHO} Check if ${LINUXBASE}/etc/mtab exists: YES
.endif
.if ${OSVERSION} < 450000
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} OS-VERSION ${OSVERSION}
@${ECHO}
@ -64,19 +76,28 @@ pre-fetch:
@${ECHO} /usr/src/sys/i386/linux/linux_sysvec.c
@${ECHO} \(revision 1.55.2.1 or higher\)
@${ECHO}
@${ECHO} Please upgrade to FreeBSD 4.1
@${ECHO} Please upgrade to FreeBSD 4.5
@${ECHO}
@${FALSE}
.endif
.if ${SIZE} < 400000
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} There is only ${SIZE}K free disk space in
@${ECHO} ${WRKDIRPREFIX}. To unpack Staroffice needs
@${ECHO} at least 400000K free diskspace.
@${FALSE}
.endif
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE="Please manually download ${DISTNAME}${EXTRACT_SUFX} from http://www.sun.com/staroffice. Put ${DISTNAME}${EXTRACT_SUFX} into the directory ${DISTDIR} and run make again."
.if !defined(WITH_ADABAS)
@${ECHO}
@${ECHO} If you like to install staroffice with ADABAS database support,
@${ECHO} cancel this installation now and start make again with
@${ECHO} WITH_ADABAS=YES.
@${ECHO}
.endif
.if !exists(${DISTDIR}/${DISTNAME})
IGNORE="Please manually download ${DISTNAME} from http://www.sun.com/staroffice. Put ${DISTNAME} into the directory ${DISTDIR} and run make again."
.endif
do-extract:
@ -94,14 +115,10 @@ do-extract:
@cd ${WRKSRC}
@SAL_IGNOREXERRORS=1 ${WRKSRC}/${DISTNAME} -extract ${WRKSRC}
@${RM} ${WRKSRC}/${DISTNAME}
@cd ../../
@for file in ${EXTRACT_ONLY}; do \
if ! (cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${_DISTDIR}/$$file ${EXTRACT_AFTER_ARGS}) ; \
then \
exit 1; \
fi \
done
.if defined(WITH_ADABAS)
@${CP} ${_DISTDIR}/${ADABAS_DIST} ${WRKSRC}
@${CHMOD} 755 ${WRKSRC}/${ADABAS_DIST}
.endif
.endif
post-configure:
@ -126,7 +143,7 @@ do-install:
.endif
@${CAT} ${PKGMESSAGE}
@-SAL_IGNOREXERRORS=1 PATH="/bin:${PATH}" LD_LIBRARY_PATH=${LD_PATH} \
TEMP=${TMPDIR} ${LINUXBASE}/bin/sh -c '${WRKSRC}/setup -net'
TEMP=${TMPDIR} ${LINUXBASE}/bin/sh -c '${WRKSRC}/setup /net'
@if [ -f ${PREFIX}/${SOVERSION}/program/setup ]; then \
${ECHO} ; \
${ECHO} Ignore the error-message. StarOffice6.0 has been installed ; \
@ -139,29 +156,16 @@ do-install:
${ECHO} ; \
${FALSE} ; \
fi
@${MKDIR} -p ${PREFIX}/${SOVERSION}/share/config/registry/cache/instance/org/openoffice
@${MKDIR} ${OPENCONFIG}/Office
@${MKDIR} ${OPENCONFIG}/ucb
.for f in Calc.dat Chart.dat Common.dat DataAccess.dat Draw.dat Impress.dat \
Java.dat Labels.dat Linguistic.dat Math.dat SFX.dat TypeDetection.dat \
Views.dat Writer.dat WriterWeb.dat
@${INSTALL_DATA} ${WRKDIR}/Office/${f} ${OPENCONFIG}/Office
.endfor
.for f in Configuration.dat Hierarchy.dat Store.dat
@${INSTALL_DATA} ${WRKDIR}/ucb/${f} ${OPENCONFIG}/ucb
.endfor
@${INSTALL_DATA} ${WRKDIR}/Inet.dat ${OPENCONFIG}
.for f in Setup.dat UserProfile.dat
@${INSTALL_DATA} ${WRKDIR}/${f} ${OPENCONFIG}
.endfor
.endif
.if defined(WITH_ADABAS)
@-SAL_IGNOREXERRORS=1 PATH="/bin:${PATH}" LD_LIBRARY_PATH=${LD_PATH} \
TEMP=${TMPDIR} ${LINUXBASE}/bin/sh -c '${WRKSRC}/${ADABAS_DIST}'
.endif
post-install:
@${MV} ${INSTDB.INS} ${INSTDB.INS}.orig
@${SED} -e 's%DefaultDestPath = "${PREFIX}/staroffice%DefaultDestPath = "staroffice%' \
${INSTDB.INS}.orig > ${INSTDB.INS}
@${INSTALL_SCRIPT} ${PREFIX}/${SOVERSION}/program/soffice \
${PREFIX}/${SOVERSION}/program/spadmin
.if !exists(${LINUXBASE}/usr/X11R6/lib/libXrender.so)
@${LN} -fs ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1.0 ${PREFIX}/${SOVERSION}/program/libXrender.so
.endif

View file

@ -1,3 +1,2 @@
MD5 (so-6_0-beta-bin-linux-de.bin) = a4331218bbc377dc0d645c7a19d0ec0b
MD5 (so-6_0-beta-bin-linux-en.bin) = fd6ff8f5c8b828a285c023db3fa8c232
MD5 (so60dat-20011016.tar.bz2) = 8220d096d7fff608cbe092bc65cbd05a
MD5 (soa-6_0-ga-bin-linux-en.bin) = 7f7003401e8533e7795faa0fd112111c
MD5 (so-6_0-ga-bin-linux-en.bin) = 97cba97cb348d071bea7e8fc08079151

View file

@ -1,9 +0,0 @@
--- setup.ins Tue Aug 22 23:31:42 2000
+++ setup.ins Tue Aug 22 23:33:35 2000
@@ -1,5 +1,5 @@
Installation gid_Installation
- DefaultDestPath = "office52";
+ DefaultDestPath = "/usr/local/office52";
ScriptVersion = 100;
Bitmap = "so52.bmp";
DefaultLanguage = "01";

View file

@ -1,26 +1,15 @@
StarOffice 6.0 Personal Install How-To
Written by: Darren Wiebe <dkwiebe@hagenhomes.com>
and Martin Blapp <mb@imp.ch>
------------------------------------------------------------------
Note that this a a BETA RELEASE of Staroffice6.0
Written by: Martin Blapp <mb@imp.ch>
------------------------------------------------------------------
BUGS:
We have found a workaround for the install-user segfaults.
The installation does not create serveral .dat files, which
leads to segfaults and startup problems.
WARNING:
If you have already Staroffice5.2 installed and your work
directory is a symlink to somewhere else and you do a upgrade,
all your files in this directory will be lost ! Please make
a backup of these files or the entire $HOME/office52 folder.
If a user installation fails, just restart it. It will
work the second time. Remove then your $HOME/staroffice6.0
directory and the line beginning with "StarOffice 6.0" in
your $HOME/.sversionrc and restart the installation.
------------------------------------------------------------------

View file

@ -8,32 +8,28 @@
PORTNAME= staroffice
PORTVERSION= 6.0
CATEGORIES= editors linux
MASTER_SITES= ${MASTER_SITE_LOCAL} \
ftp://ftp.teleport.ch/FreeBSD/patches/
MASTER_SITE_SUBDIR= obrien
DISTNAME= so-6_0-beta-bin-linux-en.bin
DISTFILES= so60dat-20011016.tar.bz2
EXTRACT_SUFX=
EXTRACT_ONLY= so60dat-20011016.tar.bz2
MASTER_SITES=
DISTNAME= so-6_0-ga-bin-linux-en.bin
DISTFILES= so-6_0-ga-bin-linux-en.bin
.if defined(WITH_ADABAS)
DISTFILES+= soa-6_0-ga-bin-linux-en.bin
.endif
MAINTAINER= mbr@FreeBSD.org
FETCH_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1.0:${PORTSDIR}/emulators/linux_base-7
BUILD_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1.0:${PORTSDIR}/emulators/linux_base-7
BROKEN= "SUN beta program for 6.0 has been closed. Distfile is not available anymore"
USE_BZIP2= yes
ONLY_FOR_ARCHS= i386
NO_CDROM= 'Must be downloaded direct from Sun via www interface'
IS_INTERACTIVE= yes
NO_BUILD= yes
SOVERSION= ${PORTNAME}${PORTVERSION}
KDEHOME= .kde
WRKSRC= ${WRKDIR}/${SOVERSION}
TMPDIR= ${WRKDIR}/tmp
LD_PATH= ${TMPDIR}:${WRKSRC}:${LINUXBASE}/lib:${LINUXBASE}/usr/lib
INSTDB.INS= ${PREFIX}/${SOVERSION}/program/instdb.ins
OPENCONFIG= ${PREFIX}/${SOVERSION}/share/config/registry/cache/instance/org/openoffice
ADABAS_DIST= soa-6_0-ga-bin-linux-en.bin
.include <bsd.port.pre.mk>
@ -45,7 +41,8 @@ pre-fetch:
@${ECHO}
@${ECHO} Check if linprocfs is running: YES
.else
@${ECHO} -----------------------------------------------------------
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} Staroffice setup needs a running linprocfs, which is not
@${ECHO} activated on your system. Please read the linprocfs\(5\)
@ -53,10 +50,25 @@ pre-fetch:
@${ECHO}
@${ECHO} linproc /compat/linux/proc linprocfs rw 0 0
@${ECHO}
@${ECHO} -----------------------------------------------------------
@${FALSE}
.endif
.if ${OSVERSION} < 410000
.if !exists(${LINUXBASE}/etc/mtab)
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} The file ${LINUXBASE}/etc/mtab is missing.
@${ECHO} Staroffice needs this file else some functions
@${ECHO} are not working. You can create it with
@${ECHO}
@${ECHO} touch ${LINUXBASE}/etc/mtab
@${ECHO}
@${FALSE}
.else
@${ECHO} Check if ${LINUXBASE}/etc/mtab exists: YES
.endif
.if ${OSVERSION} < 450000
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} OS-VERSION ${OSVERSION}
@${ECHO}
@ -64,19 +76,28 @@ pre-fetch:
@${ECHO} /usr/src/sys/i386/linux/linux_sysvec.c
@${ECHO} \(revision 1.55.2.1 or higher\)
@${ECHO}
@${ECHO} Please upgrade to FreeBSD 4.1
@${ECHO} Please upgrade to FreeBSD 4.5
@${ECHO}
@${FALSE}
.endif
.if ${SIZE} < 400000
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} There is only ${SIZE}K free disk space in
@${ECHO} ${WRKDIRPREFIX}. To unpack Staroffice needs
@${ECHO} at least 400000K free diskspace.
@${FALSE}
.endif
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE="Please manually download ${DISTNAME}${EXTRACT_SUFX} from http://www.sun.com/staroffice. Put ${DISTNAME}${EXTRACT_SUFX} into the directory ${DISTDIR} and run make again."
.if !defined(WITH_ADABAS)
@${ECHO}
@${ECHO} If you like to install staroffice with ADABAS database support,
@${ECHO} cancel this installation now and start make again with
@${ECHO} WITH_ADABAS=YES.
@${ECHO}
.endif
.if !exists(${DISTDIR}/${DISTNAME})
IGNORE="Please manually download ${DISTNAME} from http://www.sun.com/staroffice. Put ${DISTNAME} into the directory ${DISTDIR} and run make again."
.endif
do-extract:
@ -94,14 +115,10 @@ do-extract:
@cd ${WRKSRC}
@SAL_IGNOREXERRORS=1 ${WRKSRC}/${DISTNAME} -extract ${WRKSRC}
@${RM} ${WRKSRC}/${DISTNAME}
@cd ../../
@for file in ${EXTRACT_ONLY}; do \
if ! (cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${_DISTDIR}/$$file ${EXTRACT_AFTER_ARGS}) ; \
then \
exit 1; \
fi \
done
.if defined(WITH_ADABAS)
@${CP} ${_DISTDIR}/${ADABAS_DIST} ${WRKSRC}
@${CHMOD} 755 ${WRKSRC}/${ADABAS_DIST}
.endif
.endif
post-configure:
@ -126,7 +143,7 @@ do-install:
.endif
@${CAT} ${PKGMESSAGE}
@-SAL_IGNOREXERRORS=1 PATH="/bin:${PATH}" LD_LIBRARY_PATH=${LD_PATH} \
TEMP=${TMPDIR} ${LINUXBASE}/bin/sh -c '${WRKSRC}/setup -net'
TEMP=${TMPDIR} ${LINUXBASE}/bin/sh -c '${WRKSRC}/setup /net'
@if [ -f ${PREFIX}/${SOVERSION}/program/setup ]; then \
${ECHO} ; \
${ECHO} Ignore the error-message. StarOffice6.0 has been installed ; \
@ -139,29 +156,16 @@ do-install:
${ECHO} ; \
${FALSE} ; \
fi
@${MKDIR} -p ${PREFIX}/${SOVERSION}/share/config/registry/cache/instance/org/openoffice
@${MKDIR} ${OPENCONFIG}/Office
@${MKDIR} ${OPENCONFIG}/ucb
.for f in Calc.dat Chart.dat Common.dat DataAccess.dat Draw.dat Impress.dat \
Java.dat Labels.dat Linguistic.dat Math.dat SFX.dat TypeDetection.dat \
Views.dat Writer.dat WriterWeb.dat
@${INSTALL_DATA} ${WRKDIR}/Office/${f} ${OPENCONFIG}/Office
.endfor
.for f in Configuration.dat Hierarchy.dat Store.dat
@${INSTALL_DATA} ${WRKDIR}/ucb/${f} ${OPENCONFIG}/ucb
.endfor
@${INSTALL_DATA} ${WRKDIR}/Inet.dat ${OPENCONFIG}
.for f in Setup.dat UserProfile.dat
@${INSTALL_DATA} ${WRKDIR}/${f} ${OPENCONFIG}
.endfor
.endif
.if defined(WITH_ADABAS)
@-SAL_IGNOREXERRORS=1 PATH="/bin:${PATH}" LD_LIBRARY_PATH=${LD_PATH} \
TEMP=${TMPDIR} ${LINUXBASE}/bin/sh -c '${WRKSRC}/${ADABAS_DIST}'
.endif
post-install:
@${MV} ${INSTDB.INS} ${INSTDB.INS}.orig
@${SED} -e 's%DefaultDestPath = "${PREFIX}/staroffice%DefaultDestPath = "staroffice%' \
${INSTDB.INS}.orig > ${INSTDB.INS}
@${INSTALL_SCRIPT} ${PREFIX}/${SOVERSION}/program/soffice \
${PREFIX}/${SOVERSION}/program/spadmin
.if !exists(${LINUXBASE}/usr/X11R6/lib/libXrender.so)
@${LN} -fs ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1.0 ${PREFIX}/${SOVERSION}/program/libXrender.so
.endif

View file

@ -1,3 +1,2 @@
MD5 (so-6_0-beta-bin-linux-de.bin) = a4331218bbc377dc0d645c7a19d0ec0b
MD5 (so-6_0-beta-bin-linux-en.bin) = fd6ff8f5c8b828a285c023db3fa8c232
MD5 (so60dat-20011016.tar.bz2) = 8220d096d7fff608cbe092bc65cbd05a
MD5 (soa-6_0-ga-bin-linux-en.bin) = 7f7003401e8533e7795faa0fd112111c
MD5 (so-6_0-ga-bin-linux-en.bin) = 97cba97cb348d071bea7e8fc08079151

View file

@ -1,9 +0,0 @@
--- setup.ins Tue Aug 22 23:31:42 2000
+++ setup.ins Tue Aug 22 23:33:35 2000
@@ -1,5 +1,5 @@
Installation gid_Installation
- DefaultDestPath = "office52";
+ DefaultDestPath = "/usr/local/office52";
ScriptVersion = 100;
Bitmap = "so52.bmp";
DefaultLanguage = "01";

View file

@ -1,26 +1,15 @@
StarOffice 6.0 Personal Install How-To
Written by: Darren Wiebe <dkwiebe@hagenhomes.com>
and Martin Blapp <mb@imp.ch>
------------------------------------------------------------------
Note that this a a BETA RELEASE of Staroffice6.0
Written by: Martin Blapp <mb@imp.ch>
------------------------------------------------------------------
BUGS:
We have found a workaround for the install-user segfaults.
The installation does not create serveral .dat files, which
leads to segfaults and startup problems.
WARNING:
If you have already Staroffice5.2 installed and your work
directory is a symlink to somewhere else and you do a upgrade,
all your files in this directory will be lost ! Please make
a backup of these files or the entire $HOME/office52 folder.
If a user installation fails, just restart it. It will
work the second time. Remove then your $HOME/staroffice6.0
directory and the line beginning with "StarOffice 6.0" in
your $HOME/.sversionrc and restart the installation.
------------------------------------------------------------------

View file

@ -8,32 +8,28 @@
PORTNAME= staroffice
PORTVERSION= 6.0
CATEGORIES= editors linux
MASTER_SITES= ${MASTER_SITE_LOCAL} \
ftp://ftp.teleport.ch/FreeBSD/patches/
MASTER_SITE_SUBDIR= obrien
DISTNAME= so-6_0-beta-bin-linux-en.bin
DISTFILES= so60dat-20011016.tar.bz2
EXTRACT_SUFX=
EXTRACT_ONLY= so60dat-20011016.tar.bz2
MASTER_SITES=
DISTNAME= so-6_0-ga-bin-linux-en.bin
DISTFILES= so-6_0-ga-bin-linux-en.bin
.if defined(WITH_ADABAS)
DISTFILES+= soa-6_0-ga-bin-linux-en.bin
.endif
MAINTAINER= mbr@FreeBSD.org
FETCH_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1.0:${PORTSDIR}/emulators/linux_base-7
BUILD_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1.0:${PORTSDIR}/emulators/linux_base-7
BROKEN= "SUN beta program for 6.0 has been closed. Distfile is not available anymore"
USE_BZIP2= yes
ONLY_FOR_ARCHS= i386
NO_CDROM= 'Must be downloaded direct from Sun via www interface'
IS_INTERACTIVE= yes
NO_BUILD= yes
SOVERSION= ${PORTNAME}${PORTVERSION}
KDEHOME= .kde
WRKSRC= ${WRKDIR}/${SOVERSION}
TMPDIR= ${WRKDIR}/tmp
LD_PATH= ${TMPDIR}:${WRKSRC}:${LINUXBASE}/lib:${LINUXBASE}/usr/lib
INSTDB.INS= ${PREFIX}/${SOVERSION}/program/instdb.ins
OPENCONFIG= ${PREFIX}/${SOVERSION}/share/config/registry/cache/instance/org/openoffice
ADABAS_DIST= soa-6_0-ga-bin-linux-en.bin
.include <bsd.port.pre.mk>
@ -45,7 +41,8 @@ pre-fetch:
@${ECHO}
@${ECHO} Check if linprocfs is running: YES
.else
@${ECHO} -----------------------------------------------------------
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} Staroffice setup needs a running linprocfs, which is not
@${ECHO} activated on your system. Please read the linprocfs\(5\)
@ -53,10 +50,25 @@ pre-fetch:
@${ECHO}
@${ECHO} linproc /compat/linux/proc linprocfs rw 0 0
@${ECHO}
@${ECHO} -----------------------------------------------------------
@${FALSE}
.endif
.if ${OSVERSION} < 410000
.if !exists(${LINUXBASE}/etc/mtab)
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} The file ${LINUXBASE}/etc/mtab is missing.
@${ECHO} Staroffice needs this file else some functions
@${ECHO} are not working. You can create it with
@${ECHO}
@${ECHO} touch ${LINUXBASE}/etc/mtab
@${ECHO}
@${FALSE}
.else
@${ECHO} Check if ${LINUXBASE}/etc/mtab exists: YES
.endif
.if ${OSVERSION} < 450000
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} OS-VERSION ${OSVERSION}
@${ECHO}
@ -64,19 +76,28 @@ pre-fetch:
@${ECHO} /usr/src/sys/i386/linux/linux_sysvec.c
@${ECHO} \(revision 1.55.2.1 or higher\)
@${ECHO}
@${ECHO} Please upgrade to FreeBSD 4.1
@${ECHO} Please upgrade to FreeBSD 4.5
@${ECHO}
@${FALSE}
.endif
.if ${SIZE} < 400000
@${ECHO}
@${ECHO} ERROR:
@${ECHO}
@${ECHO} There is only ${SIZE}K free disk space in
@${ECHO} ${WRKDIRPREFIX}. To unpack Staroffice needs
@${ECHO} at least 400000K free diskspace.
@${FALSE}
.endif
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE="Please manually download ${DISTNAME}${EXTRACT_SUFX} from http://www.sun.com/staroffice. Put ${DISTNAME}${EXTRACT_SUFX} into the directory ${DISTDIR} and run make again."
.if !defined(WITH_ADABAS)
@${ECHO}
@${ECHO} If you like to install staroffice with ADABAS database support,
@${ECHO} cancel this installation now and start make again with
@${ECHO} WITH_ADABAS=YES.
@${ECHO}
.endif
.if !exists(${DISTDIR}/${DISTNAME})
IGNORE="Please manually download ${DISTNAME} from http://www.sun.com/staroffice. Put ${DISTNAME} into the directory ${DISTDIR} and run make again."
.endif
do-extract:
@ -94,14 +115,10 @@ do-extract:
@cd ${WRKSRC}
@SAL_IGNOREXERRORS=1 ${WRKSRC}/${DISTNAME} -extract ${WRKSRC}
@${RM} ${WRKSRC}/${DISTNAME}
@cd ../../
@for file in ${EXTRACT_ONLY}; do \
if ! (cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${_DISTDIR}/$$file ${EXTRACT_AFTER_ARGS}) ; \
then \
exit 1; \
fi \
done
.if defined(WITH_ADABAS)
@${CP} ${_DISTDIR}/${ADABAS_DIST} ${WRKSRC}
@${CHMOD} 755 ${WRKSRC}/${ADABAS_DIST}
.endif
.endif
post-configure:
@ -126,7 +143,7 @@ do-install:
.endif
@${CAT} ${PKGMESSAGE}
@-SAL_IGNOREXERRORS=1 PATH="/bin:${PATH}" LD_LIBRARY_PATH=${LD_PATH} \
TEMP=${TMPDIR} ${LINUXBASE}/bin/sh -c '${WRKSRC}/setup -net'
TEMP=${TMPDIR} ${LINUXBASE}/bin/sh -c '${WRKSRC}/setup /net'
@if [ -f ${PREFIX}/${SOVERSION}/program/setup ]; then \
${ECHO} ; \
${ECHO} Ignore the error-message. StarOffice6.0 has been installed ; \
@ -139,29 +156,16 @@ do-install:
${ECHO} ; \
${FALSE} ; \
fi
@${MKDIR} -p ${PREFIX}/${SOVERSION}/share/config/registry/cache/instance/org/openoffice
@${MKDIR} ${OPENCONFIG}/Office
@${MKDIR} ${OPENCONFIG}/ucb
.for f in Calc.dat Chart.dat Common.dat DataAccess.dat Draw.dat Impress.dat \
Java.dat Labels.dat Linguistic.dat Math.dat SFX.dat TypeDetection.dat \
Views.dat Writer.dat WriterWeb.dat
@${INSTALL_DATA} ${WRKDIR}/Office/${f} ${OPENCONFIG}/Office
.endfor
.for f in Configuration.dat Hierarchy.dat Store.dat
@${INSTALL_DATA} ${WRKDIR}/ucb/${f} ${OPENCONFIG}/ucb
.endfor
@${INSTALL_DATA} ${WRKDIR}/Inet.dat ${OPENCONFIG}
.for f in Setup.dat UserProfile.dat
@${INSTALL_DATA} ${WRKDIR}/${f} ${OPENCONFIG}
.endfor
.endif
.if defined(WITH_ADABAS)
@-SAL_IGNOREXERRORS=1 PATH="/bin:${PATH}" LD_LIBRARY_PATH=${LD_PATH} \
TEMP=${TMPDIR} ${LINUXBASE}/bin/sh -c '${WRKSRC}/${ADABAS_DIST}'
.endif
post-install:
@${MV} ${INSTDB.INS} ${INSTDB.INS}.orig
@${SED} -e 's%DefaultDestPath = "${PREFIX}/staroffice%DefaultDestPath = "staroffice%' \
${INSTDB.INS}.orig > ${INSTDB.INS}
@${INSTALL_SCRIPT} ${PREFIX}/${SOVERSION}/program/soffice \
${PREFIX}/${SOVERSION}/program/spadmin
.if !exists(${LINUXBASE}/usr/X11R6/lib/libXrender.so)
@${LN} -fs ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1.0 ${PREFIX}/${SOVERSION}/program/libXrender.so
.endif

View file

@ -1,3 +1,2 @@
MD5 (so-6_0-beta-bin-linux-de.bin) = a4331218bbc377dc0d645c7a19d0ec0b
MD5 (so-6_0-beta-bin-linux-en.bin) = fd6ff8f5c8b828a285c023db3fa8c232
MD5 (so60dat-20011016.tar.bz2) = 8220d096d7fff608cbe092bc65cbd05a
MD5 (soa-6_0-ga-bin-linux-en.bin) = 7f7003401e8533e7795faa0fd112111c
MD5 (so-6_0-ga-bin-linux-en.bin) = 97cba97cb348d071bea7e8fc08079151

View file

@ -1,9 +0,0 @@
--- setup.ins Tue Aug 22 23:31:42 2000
+++ setup.ins Tue Aug 22 23:33:35 2000
@@ -1,5 +1,5 @@
Installation gid_Installation
- DefaultDestPath = "office52";
+ DefaultDestPath = "/usr/local/office52";
ScriptVersion = 100;
Bitmap = "so52.bmp";
DefaultLanguage = "01";

View file

@ -1,26 +1,15 @@
StarOffice 6.0 Personal Install How-To
Written by: Darren Wiebe <dkwiebe@hagenhomes.com>
and Martin Blapp <mb@imp.ch>
------------------------------------------------------------------
Note that this a a BETA RELEASE of Staroffice6.0
Written by: Martin Blapp <mb@imp.ch>
------------------------------------------------------------------
BUGS:
We have found a workaround for the install-user segfaults.
The installation does not create serveral .dat files, which
leads to segfaults and startup problems.
WARNING:
If you have already Staroffice5.2 installed and your work
directory is a symlink to somewhere else and you do a upgrade,
all your files in this directory will be lost ! Please make
a backup of these files or the entire $HOME/office52 folder.
If a user installation fails, just restart it. It will
work the second time. Remove then your $HOME/staroffice6.0
directory and the line beginning with "StarOffice 6.0" in
your $HOME/.sversionrc and restart the installation.
------------------------------------------------------------------