- Update to 0.10.0

This commit is contained in:
Pav Lucistnik 2007-03-21 21:33:47 +00:00
parent e6a477494c
commit b50832fc33
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=187941
4 changed files with 51 additions and 37 deletions

View file

@ -6,11 +6,10 @@
#
PORTNAME= gthumb
PORTVERSION= 2.8.1
PORTVERSION= 2.10.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.8
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.10
DIST_SUBDIR= gnome2
MAINTAINER= pav@FreeBSD.org
@ -20,8 +19,10 @@ LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif
USE_BZIP2= yes
USE_XLIB= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libgnomeprintui
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libgnomeprintui gnomedocutils
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
@ -33,7 +34,9 @@ GCONF_SCHEMAS= gthumb.schemas
MAN1= gthumb.1
OPTIONS= GPHOTO2 "Support loading photos from digital cameras" On \
IPTCDATA "Support for IPTC metadata" Off
IPTCDATA "Support for IPTC metadata" Off \
OPENRAW "Support for camera RAW files" Off \
GTKUNIQUE "Use GtkUnique library" Off
.include <bsd.port.pre.mk>
@ -51,4 +54,19 @@ CONFIGURE_ARGS+=--enable-iptcdata
CONFIGURE_ARGS+=--disable-iptcdata
.endif
.if defined(WITH_OPENRAW)
LIB_DEPENDS+= openrawgnome.1:${PORTSDIR}/graphics/libopenraw
CONFIGURE_ARGS+=--enable-libopenraw
.else
CONFIGURE_ARGS+=--disable-libopenraw
.endif
.if defined(WITH_GTKUNIQUE)
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/gtkunique-1.0.pc:${PORTSDIR}/x11-toolkits/gtkunique
RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/gtkunique-1.0.pc:${PORTSDIR}/x11-toolkits/gtkunique
CONFIGURE_ARGS+=--enable-gtkunique
.else
CONFIGURE_ARGS+=--disable-gtkunique
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (gnome2/gthumb-2.8.1.tar.bz2) = 680743ea3282c63343b4f1fcf9348079
SHA256 (gnome2/gthumb-2.8.1.tar.bz2) = 495f81a2a2c1b7c0a8f878a8b69001e95413e79be2aa12c5e8e71f368863ba12
SIZE (gnome2/gthumb-2.8.1.tar.bz2) = 1832821
MD5 (gnome2/gthumb-2.10.0.tar.bz2) = a3e785778c262c193f750d4b17e0edfd
SHA256 (gnome2/gthumb-2.10.0.tar.bz2) = 2d918abaa46e026d1467ac2c5c5971e6638b7f9888d295c62e995f6a4ed37940
SIZE (gnome2/gthumb-2.10.0.tar.bz2) = 2091819

View file

@ -1,10 +0,0 @@
--- src/rotation-utils.h.orig Sat Dec 24 14:08:28 2005
+++ src/rotation-utils.h Sun Dec 3 16:39:14 2006
@@ -54,6 +54,7 @@
void update_orientation_field (const char *filename,
RotationData *rot_data);
+void reset_orientation_field (const char *path);
gboolean swap_fields (ExifContent *content,
ExifTag tag1,
ExifTag tag2);

View file

@ -1,7 +1,4 @@
bin/gthumb
lib/gthumb/libgthumb.a
lib/gthumb/libgthumb.la
lib/gthumb/libgthumb.so
lib/gthumb/modules/libduplicates.a
lib/gthumb/modules/libduplicates.la
lib/gthumb/modules/libduplicates.so
@ -20,15 +17,21 @@ lib/gthumb/modules/libsearch.so
lib/gthumb/modules/libwebexporter.a
lib/gthumb/modules/libwebexporter.la
lib/gthumb/modules/libwebexporter.so
libdata/bonobo/servers/GNOME_GThumb.server
libdata/bonobo/servers/GNOME_GThumb_CatalogView.server
libdata/bonobo/servers/GNOME_GThumb_Viewer.server
libexec/gthumb-catalog-view
libexec/gthumb-image-viewer
share/gnome/application-registry/gthumb.applications
lib/libgthumb.a
lib/libgthumb.la
lib/libgthumb.so
share/gnome/applications/gthumb.desktop
share/gnome/gnome-2.0/ui/GNOME_GThumb_CatalogView.xml
share/gnome/gnome-2.0/ui/GNOME_GThumb_Viewer.xml
share/gnome/gthumb/albumthemes/BestFit/back.png
share/gnome/gthumb/albumthemes/BestFit/BestFit.css
share/gnome/gthumb/albumthemes/BestFit/BestFit.js
share/gnome/gthumb/albumthemes/BestFit/image.gthtml
share/gnome/gthumb/albumthemes/BestFit/index.gthtml
share/gnome/gthumb/albumthemes/BestFit/index.js
share/gnome/gthumb/albumthemes/BestFit/lib.js
share/gnome/gthumb/albumthemes/BestFit/next.png
share/gnome/gthumb/albumthemes/BestFit/preview.png
share/gnome/gthumb/albumthemes/BestFit/prev.png
share/gnome/gthumb/albumthemes/BestFit/thumbnail.gthtml
share/gnome/gthumb/albumthemes/Classic/1.gif
share/gnome/gthumb/albumthemes/Classic/back.png
share/gnome/gthumb/albumthemes/Classic/background.gif
@ -97,24 +100,24 @@ share/gnome/gthumb/glade/gthumb_edit.glade
share/gnome/gthumb/glade/gthumb_png_exporter.glade
share/gnome/gthumb/glade/gthumb_preferences.glade
share/gnome/gthumb/glade/gthumb_print.glade
share/gnome/gthumb/glade/gthumb_redeye.glade
share/gnome/gthumb/glade/gthumb_search.glade
share/gnome/gthumb/glade/gthumb_tools.glade
share/gnome/gthumb/glade/gthumb_web_exporter.glade
share/gnome/gthumb/glade/volume-mute.png
share/gnome/gthumb/icons/black-white.png
share/gnome/gthumb/icons/flip.png
share/gnome/gthumb/icons/flip.xpm
share/gnome/gthumb/icons/mirror.png
share/gnome/gthumb/icons/mirror.xpm
share/gnome/gthumb/icons/rotate.png
share/gnome/gthumb/icons/rotate.xpm
share/gnome/help/gthumb/C/figures/comment.png
share/gnome/help/gthumb/C/figures/main-win.png
share/gnome/help/gthumb/C/figures/nav-button.png
share/gnome/help/gthumb/C/figures/preferences.png
share/gnome/help/gthumb/C/gthumb.xml
share/gnome/help/gthumb/C/legal.xml
share/gnome/help/gthumb/sv/figures/comment.png
share/gnome/help/gthumb/sv/figures/main-win.png
share/gnome/help/gthumb/sv/figures/nav-button.png
share/gnome/help/gthumb/sv/figures/preferences.png
share/gnome/help/gthumb/sv/gthumb.xml
share/gnome/omf/gthumb/gthumb-C.omf
share/gnome/omf/gthumb/gthumb-sv.omf
share/icons/hicolor/48x48/apps/gthumb.png
share/locale/am/LC_MESSAGES/gthumb.mo
share/locale/ar/LC_MESSAGES/gthumb.mo
@ -132,6 +135,7 @@ share/locale/en_GB/LC_MESSAGES/gthumb.mo
share/locale/es/LC_MESSAGES/gthumb.mo
share/locale/et/LC_MESSAGES/gthumb.mo
share/locale/eu/LC_MESSAGES/gthumb.mo
share/locale/fa/LC_MESSAGES/gthumb.mo
share/locale/fi/LC_MESSAGES/gthumb.mo
share/locale/fr/LC_MESSAGES/gthumb.mo
share/locale/ga/LC_MESSAGES/gthumb.mo
@ -173,16 +177,18 @@ share/locale/zh_CN/LC_MESSAGES/gthumb.mo
share/locale/zh_HK/LC_MESSAGES/gthumb.mo
share/locale/zh_TW/LC_MESSAGES/gthumb.mo
@dirrm share/gnome/omf/gthumb
@dirrm share/gnome/help/gthumb/sv/figures
@dirrm share/gnome/help/gthumb/sv
@dirrm share/gnome/help/gthumb/C/figures
@dirrm share/gnome/help/gthumb/C
@dirrm share/gnome/help/gthumb
@dirrm share/gnome/gthumb/icons
@dirrm share/gnome/gthumb/glade
@dirrm share/gnome/gthumb/albumthemes/Wiki
@dirrm share/gnome/gthumb/albumthemes/NeatRound
@dirrm share/gnome/gthumb/albumthemes/Flicker
@dirrm share/gnome/gthumb/albumthemes/ClassicClips
@dirrm share/gnome/gthumb/albumthemes/Classic
@dirrm share/gnome/gthumb/albumthemes/BestFit
@dirrm share/gnome/gthumb/albumthemes
@dirrm share/gnome/gthumb
@dirrm lib/gthumb/modules