Add libphish 0.1.0, a cross-platform library to interact with the Open

Phishing Database.

PR:		ports/95922
Submitted by:	Rashid N. Achilov <shelton@granch.ru>
Approved by:	tobez
This commit is contained in:
Aaron Dalton 2006-06-05 21:30:34 +00:00
parent f0dcdd522f
commit b50c4a004f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=164526
7 changed files with 120 additions and 0 deletions

View file

@ -527,6 +527,7 @@
SUBDIR += libpci
SUBDIR += libpdel
SUBDIR += libpeak
SUBDIR += libphish
SUBDIR += libpperl
SUBDIR += libredblack
SUBDIR += libshbuf

34
devel/libphish/Makefile Normal file
View file

@ -0,0 +1,34 @@
# New ports collection makefile for: libphish
# Date created: 17 Apr 2006
# Whom: Rashid N. Achilov <shelton@granch.ru>
#
# $FreeBSD$
#
PORTNAME= libphish
PORTVERSION= 0.1.0
CATEGORIES= devel
MASTER_SITES= http://download.berlios.de/opdb/ \
http://download2.berlios.de/opdb/ \
MAINTAINER= shelton@granch.ru
COMMENT= A cross-platform library to interact with the Open Phishing Database
BUILD_DEPENDS= xmlwf:${PORTSDIR}/textproc/expat2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
USE_GCC= 3.2+
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS= -I${LOCALBASE}/include -DFreeBSD
LDFLAGS= -L${LOCALBASE}/lib
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${INSTALL_DATA} `${LS}` ${DOCSDIR}
.endif
.include <bsd.port.mk>

3
devel/libphish/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (libphish-0.1.0.tar.bz2) = d6d81794e4147297917065d4465b233f
SHA256 (libphish-0.1.0.tar.bz2) = a369769c73fde9bd908159f9b638580a50ef7c30850b4de9d476a3c4d2e76811
SIZE (libphish-0.1.0.tar.bz2) = 246336

View file

@ -0,0 +1,10 @@
--- src/phish_opdb_server.c.orig Sun Mar 19 11:40:55 2006
+++ src/phish_opdb_server.c Mon Jun 5 13:33:51 2006
@@ -21,6 +21,7 @@
#define close closesocket
#include <winsock2.h>
#else
+#include <sys/types.h>
#include <sys/socket.h>
#include <unistd.h>
#endif

View file

@ -0,0 +1,20 @@
--- src/phish_util_net.c.orig Mon Mar 20 09:54:25 2006
+++ src/phish_util_net.c Mon Jun 5 13:40:14 2006
@@ -30,6 +30,8 @@
+#include <sys/types.h>
+#include <sys/socket.h>
#include <netdb.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#endif
#include "phish.h"
@@ -72,7 +74,7 @@
h->ent = NULL;
h->buf = NULL;
-#ifdef WIN32
+#if defined(WIN32) || defined(FreeBSD)
h->ent = gethostbyname(name);

15
devel/libphish/pkg-descr Normal file
View file

@ -0,0 +1,15 @@
The Open Phishing Database project is an effort to create and
maintain and open database of phishing sites, in addition to
providing browser extensions which utilise this database in
order to provide users with a safer browsing experience.
libphish is a cross-platform library to interact with the Open
Phishing Database, in order to provide a consistent API which
browsers and other programs can use to verify the safety and
risk level of URLs.
Another part of OPDB is a Konqueror Anti-Phishing toolbar
(see www/karpion port) and FirePhish - a Firefox Anti-Phishing
toolbar.
WWW: http://opdb.berlios.de/

37
devel/libphish/pkg-plist Normal file
View file

@ -0,0 +1,37 @@
lib/libphish.so.1
lib/libphish.a
lib/libphish.la
include/phish.h
bin/libphish-config
@unexec rm -f %D/lib/libphish.so
%%PORTDOCS%%%%DOCSDIR%%/Doxyfile
%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/files.html
%%PORTDOCS%%%%DOCSDIR%%/functions.html
%%PORTDOCS%%%%DOCSDIR%%/functions_vars.html
%%PORTDOCS%%%%DOCSDIR%%/globals.html
%%PORTDOCS%%%%DOCSDIR%%/globals_enum.html
%%PORTDOCS%%%%DOCSDIR%%/globals_eval.html
%%PORTDOCS%%%%DOCSDIR%%/globals_func.html
%%PORTDOCS%%%%DOCSDIR%%/globals_type.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/main.html
%%PORTDOCS%%%%DOCSDIR%%/phish_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/phish_8h.html
%%PORTDOCS%%%%DOCSDIR%%/structphish__url__data__t.html
%%PORTDOCS%%%%DOCSDIR%%/tree.html
%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2blank.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2doc.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2folderclosed.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2folderopen.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2vertline.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2lastnode.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2link.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2mlastnode.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2mnode.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2node.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2plastnode.png
%%PORTDOCS%%%%DOCSDIR%%/ftv2pnode.png
%%PORTDOCS%%@dirrm %%DOCSDIR%%