- New port: devel/icontheme
D library for dealing with icon themes in freedesktop environments WWW: https://github.com/FreeSlave/icontheme
This commit is contained in:
parent
1d98cee9f7
commit
b52edae1df
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=472477
6 changed files with 61 additions and 0 deletions
|
@ -1209,6 +1209,7 @@
|
|||
SUBDIR += ice
|
||||
SUBDIR += icestorm
|
||||
SUBDIR += icmake
|
||||
SUBDIR += icontheme
|
||||
SUBDIR += icu
|
||||
SUBDIR += icu-le-hb
|
||||
SUBDIR += icu-lx
|
||||
|
|
35
devel/icontheme/Makefile
Normal file
35
devel/icontheme/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= icontheme
|
||||
PORTVERSION= 1.2.1
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= devel
|
||||
|
||||
MAINTAINER= acm@FreeBSD.org
|
||||
COMMENT= Icon Theme Specification implementation in D programming language
|
||||
|
||||
LICENSE= BSL
|
||||
|
||||
BUILD_DEPENDS= ldmd2:lang/ldc \
|
||||
dub:devel/dub \
|
||||
${LOCALBASE}/lib/d/libisfreedesktop.a:devel/isfreedesktop \
|
||||
${LOCALBASE}/lib/d/libinilike.a:devel/inilike \
|
||||
${LOCALBASE}/lib/d/libxdgpaths.a:devel/xdgpaths
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= FreeSlave
|
||||
|
||||
DUB_CMD= ${LOCALBASE}/bin/dub build --build=release
|
||||
D_INCLUDE_DIR= ${PREFIX}/include/d
|
||||
D_LIB_DIR= ${PREFIX}/lib/d
|
||||
|
||||
do-build:
|
||||
@cd ${WRKSRC} && ${DUB_CMD}
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${STAGEDIR}${D_INCLUDE_DIR}
|
||||
@${MKDIR} ${STAGEDIR}${D_LIB_DIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/lib/libicontheme.a ${STAGEDIR}${D_LIB_DIR}
|
||||
cd ${WRKSRC}/source && ${COPYTREE_SHARE} . ${STAGEDIR}${D_INCLUDE_DIR} "-name *\.d"
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/icontheme/distinfo
Normal file
3
devel/icontheme/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1513182539
|
||||
SHA256 (FreeSlave-icontheme-v1.2.1_GH0.tar.gz) = 3db256b4f276a981c4405e9b2ccaaf2ad4bfabc5a01ed58e55025414f5a0fef4
|
||||
SIZE (FreeSlave-icontheme-v1.2.1_GH0.tar.gz) = 43473
|
13
devel/icontheme/files/patch-dub.json
Normal file
13
devel/icontheme/files/patch-dub.json
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- dub.json.orig 2017-12-13 11:29:42.399563000 -0500
|
||||
+++ dub.json 2017-12-13 11:29:52.805384000 -0500
|
||||
@@ -4,10 +4,6 @@
|
||||
"license" : "BSL-1.0",
|
||||
"copyright": "Copyright © 2015-2016, Roman Chistokhodov",
|
||||
"authors": ["Roman Chistokhodov"],
|
||||
- "dependencies": {
|
||||
- "inilike": "~>1.1.0",
|
||||
- "xdgpaths": "~>0.2.4"
|
||||
- },
|
||||
"targetName" : "icontheme",
|
||||
"targetPath" : "lib",
|
||||
"targetType" : "library",
|
3
devel/icontheme/pkg-descr
Normal file
3
devel/icontheme/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
D library for dealing with icon themes in freedesktop environments
|
||||
|
||||
WWW: https://github.com/FreeSlave/icontheme
|
6
devel/icontheme/pkg-plist
Normal file
6
devel/icontheme/pkg-plist
Normal file
|
@ -0,0 +1,6 @@
|
|||
include/d/icontheme/cache.d
|
||||
include/d/icontheme/file.d
|
||||
include/d/icontheme/lookup.d
|
||||
include/d/icontheme/package.d
|
||||
include/d/icontheme/paths.d
|
||||
lib/d/libicontheme.a
|
Loading…
Reference in a new issue