New port: math/vtk9: Visualization toolkit (9.0.0.rc3)
This commit is contained in:
parent
8f086dc62a
commit
b53c49f584
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=533090
6 changed files with 8 additions and 71 deletions
|
@ -933,6 +933,7 @@
|
|||
SUBDIR += vowpal_wabbit
|
||||
SUBDIR += vtk6
|
||||
SUBDIR += vtk8
|
||||
SUBDIR += vtk9
|
||||
SUBDIR += wavelib
|
||||
SUBDIR += wcalc
|
||||
SUBDIR += wfmath
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= vtk
|
||||
DISTVERSION= 8.2.0
|
||||
DISTVERSION= 9.0.0.rc3
|
||||
CATEGORIES= math graphics
|
||||
MASTER_SITES= http://www.vtk.org/files/release/${VTK_SHORT_VER}/
|
||||
PKGNAMESUFFIX= 8
|
||||
DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
|
||||
PKGNAMESUFFIX= 9
|
||||
DISTNAME= ${PORTNAME:tu}-${DISTVERSION}
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Visualization toolkit
|
||||
|
@ -32,7 +32,7 @@ CMAKE_ARGS+= -DVTK_INSTALL_LIBRARY_DIR=lib/vtk-${VTK_SHORT_VER} \
|
|||
-DVTK_INSTALL_QT_DIR=/${QT_LIBDIR_REL}/plugins/designer \
|
||||
-DSTAGEDIR=${STAGEDIR}
|
||||
|
||||
VTK_SHORT_VER= ${PORTVERSION:R}
|
||||
VTK_SHORT_VER= ${PORTVERSION:R:R}
|
||||
|
||||
DOCSDIR= ${PREFIX}/share/doc/vtk-${VTK_SHORT_VER}
|
||||
DATADIR= ${PREFIX}/share/vtk-${VTK_SHORT_VER}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1587775906
|
||||
SHA256 (VTK-8.2.0.tar.gz) = 34c3dc775261be5e45a8049155f7228b6bd668106c72a3c435d95730d17d57bb
|
||||
SIZE (VTK-8.2.0.tar.gz) = 35511819
|
||||
TIMESTAMP = 1587940245
|
||||
SHA256 (VTK-9.0.0.rc3.tar.gz) = 3a3fc0b15bd1e2416092293f1dd6b21161c0fd2b4af59a85fb5b5333b617e7a9
|
||||
SIZE (VTK-9.0.0.rc3.tar.gz) = 33522475
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
--- GUISupport/Qt/CMakeLists.txt.orig 2019-01-30 17:15:13 UTC
|
||||
+++ GUISupport/Qt/CMakeLists.txt
|
||||
@@ -128,21 +128,21 @@ if(VTK_BUILD_QT_DESIGNER_PLUGIN AND add_qvtkwidget)
|
||||
find_package(Qt5 COMPONENTS ${qt_component} REQUIRED QUIET)
|
||||
add_definitions(${Qt5${qt_component}_DEFINITIONS})
|
||||
include_directories(${Qt5${qt_component}_INCLUDE_DIRS})
|
||||
- qt5_wrap_cpp(PluginMocSrcs ${PluginMocHeaders} TARGET QVTKWidgetPlugin)
|
||||
+ qt5_wrap_cpp(PluginMocSrcs ${PluginMocHeaders} TARGET QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION})
|
||||
set(QT_LIBRARIES Qt5::${qt_component})
|
||||
|
||||
# add QVTK plugin from sources
|
||||
# stand-alone as it doesn't depend on QVTK library
|
||||
- add_library(QVTKWidgetPlugin
|
||||
+ add_library(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION}
|
||||
SHARED
|
||||
${PluginLibSrcs}
|
||||
${PluginMocSrcs}
|
||||
)
|
||||
|
||||
- set_target_properties(QVTKWidgetPlugin PROPERTIES COMPILE_DEFINITIONS QT_NO_DEBUG)
|
||||
+ set_target_properties(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION} PROPERTIES COMPILE_DEFINITIONS QT_NO_DEBUG)
|
||||
|
||||
# link with Qt libs
|
||||
- vtk_module_link_libraries(QVTKWidgetPlugin ${QT_LIBRARIES})
|
||||
+ vtk_module_link_libraries(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION} ${QT_LIBRARIES})
|
||||
|
||||
# install rules
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- GUISupport/Qt/PluginInstall.cmake.in.orig 2017-11-21 08:23:50 UTC
|
||||
+++ GUISupport/Qt/PluginInstall.cmake.in
|
||||
@@ -10,7 +10,7 @@ if (WIN32)
|
||||
set(BUILDTYPE_SUFFIX @CMAKE_RELEASE_POSTFIX@)
|
||||
endif ()
|
||||
endif ()
|
||||
-set(VTK_INSTALL_QT_PLUGIN_FILE "@CMAKE_SHARED_LIBRARY_PREFIX@QVTKWidgetPlugin${BUILDTYPE_SUFFIX}@CMAKE_SHARED_LIBRARY_SUFFIX@")
|
||||
+set(VTK_INSTALL_QT_PLUGIN_FILE "@CMAKE_SHARED_LIBRARY_PREFIX@QVTKWidgetPlugin-@VTK_MAJOR_VERSION@.@VTK_MINOR_VERSION@${BUILDTYPE_SUFFIX}@CMAKE_SHARED_LIBRARY_SUFFIX@")
|
||||
set(VTK_CONFIGURATIONS "@CMAKE_CONFIGURATION_TYPES@")
|
||||
|
||||
if(VTK_CONFIGURATIONS)
|
|
@ -1,25 +0,0 @@
|
|||
--- ThirdParty/verdict/vtkverdict/CMakeLists.txt.orig 2019-01-30 17:15:13 UTC
|
||||
+++ ThirdParty/verdict/vtkverdict/CMakeLists.txt
|
||||
@@ -128,14 +128,14 @@ endif ()
|
||||
# Installation stuff
|
||||
#
|
||||
IF(NOT verdict_INSTALL_NO_DEVELOPMENT)
|
||||
- install(FILES
|
||||
- README
|
||||
- Verdict.htm
|
||||
- Verdict.doc
|
||||
- verdict_test.cpp
|
||||
- DESTINATION ${verdict_INSTALL_DOC_DIR}/verdict/${verdict_VERSION}/
|
||||
- COMPONENT Development
|
||||
- )
|
||||
+# install(FILES
|
||||
+# README
|
||||
+# Verdict.htm
|
||||
+# Verdict.doc
|
||||
+# verdict_test.cpp
|
||||
+# DESTINATION ${verdict_INSTALL_DOC_DIR}/verdict/${verdict_VERSION}/
|
||||
+# COMPONENT Development
|
||||
+# )
|
||||
|
||||
install(
|
||||
FILES ${verdict_BINARY_DIR}/verdict.h
|
Loading…
Reference in a new issue