Add bmp-flac 20040316, FLAC input plugin for

beep-media-player.

Obtained from:	ports/audio/xmms-flac
This commit is contained in:
Norikatsu Shigemura 2005-05-21 16:26:18 +00:00
parent 544ed3cd99
commit b544694e68
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=135770
7 changed files with 109 additions and 0 deletions

View file

@ -47,6 +47,7 @@
SUBDIR += bladeenc
SUBDIR += blop
SUBDIR += bmp-faad
SUBDIR += bmp-flac
SUBDIR += bmp-htmlplaylist
SUBDIR += bmp-scrobbler
SUBDIR += bmp-songchange

41
audio/bmp-flac/Makefile Normal file
View file

@ -0,0 +1,41 @@
# New ports collection makefile for: bmp-flac
# Date created: 2005-05-22
# Whom: nork@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= flac
PORTVERSION= 20040316
CATEGORIES= audio
MASTER_SITES= http://ccm.sherry.jp/tmp/
PKGNAMEPREFIX= bmp-
DISTNAME= ${PORTNAME}-CVS-${PORTVERSION}-with-bmp-plugin
MAINTAINER= nork@FreeBSD.org
COMMENT= FLAC input plugin for beep-media-player
LIB_DEPENDS= beep.2:${PORTSDIR}/multimedia/beep-media-player \
FLAC.7:${PORTSDIR}/audio/flac
PLIST_FILES= lib/bmp/Input/libbmp-flac.so
USE_BZIP2= yes
USE_X_PREFIX= yes
##GNU_CONFIGURE= yes
USE_INC_LIBTOOL_VER=15
CONFIGURE_ARGS= --with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}" \
--with-xmms-prefix="${X11BASE}"
MAKEFILE= ${FILESDIR}/Makefile
# "obj" is magic to our make(1)
post-configure:
@${RM} -rf ${WRKSRC}/obj
# XXX
post-install:
@${RM} ${PREFIX}/lib/bmp/Input/libbmp-flac.la
.include <bsd.port.mk>

2
audio/bmp-flac/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (flac-CVS-20040316-with-bmp-plugin.tar.bz2) = 9812842caa461e126194ed0ad1d2c7b2
SIZE (flac-CVS-20040316-with-bmp-plugin.tar.bz2) = 945236

View file

@ -0,0 +1,8 @@
$FreeBSD$
SUBDIRS= src/share src/plugin_common src/plugin_bmp
all install:
@for d in ${SUBDIRS}; do \
(cd $$d; ${MAKE} $@); \
done

View file

@ -0,0 +1,22 @@
--- configure.orig Mon Apr 12 20:29:48 2004
+++ configure Sun May 22 00:46:57 2005
@@ -19040,6 +19040,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -21137,9 +21138,9 @@
if test x$debug = xtrue; then
OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -g -O0 -DDEBUG"
else
- OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -O2 -DNDEBUG"
+ OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -DNDEBUG"
if test x$GCC = xyes; then
- OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -O3 -fomit-frame-pointer -funroll-loops -finline-functions -Wall -W -Winline -DFLaC__INLINE=__inline__"
+ OUR_CFLAGS_HEAD="$OUR_CFLAGS_HEAD -Wall -W -Winline -DFLaC__INLINE=__inline__"
fi
fi
CFLAGS="$OUR_CFLAGS_HEAD $CFLAGS"

View file

@ -0,0 +1,31 @@
--- src/plugin_bmp/Makefile.in.orig Mon Apr 12 21:36:08 2004
+++ src/plugin_bmp/Makefile.in Sun May 22 00:57:39 2005
@@ -77,8 +77,7 @@
$(top_builddir)/src/share/grabbag/libgrabbag.la \
$(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
$(top_builddir)/src/share/replaygain_synthesis/libreplaygain_synthesis.la \
- $(top_builddir)/src/share/utf8/libutf8.la \
- $(top_builddir)/src/libFLAC/libFLAC.la
+ $(top_builddir)/src/share/utf8/libutf8.la
am__libbmp_flac_la_SOURCES_DIST = charset.c configure.c plugin.c \
wrap_id3.c fileinfo.c
am__objects_1 = charset.lo configure.lo plugin.lo wrap_id3.lo \
@@ -266,7 +265,7 @@
wrap_id3.h
INCLUDES = -I$(top_srcdir)/src
-bmpinputplugindir = $(HOME)/.bmp/Plugins
+bmpinputplugindir = ${PREFIX}/lib/bmp/Input
bmpinputplugin_LTLIBRARIES = libbmp-flac.la
plugin_sources = charset.c configure.c plugin.c wrap_id3.c fileinfo.c
@FLaC__HAS_ID3LIB_FALSE@libbmp_flac_la_SOURCES = $(plugin_sources)
@@ -286,8 +285,7 @@
$(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
$(top_builddir)/src/share/replaygain_synthesis/libreplaygain_synthesis.la \
$(top_builddir)/src/share/utf8/libutf8.la \
- $(top_builddir)/src/libFLAC/libFLAC.la \
- -L$(top_builddir)/src/libFLAC/.libs \
+ -lFLAC \
@BMP_LIBS@ \
@ID3LIB_LIBS@

4
audio/bmp-flac/pkg-descr Normal file
View file

@ -0,0 +1,4 @@
bmp-flac is FLAC input plugin for beep-media-player, it's
based on xmms-flac but lots of things were changed.
WWW: http://ccm.sherry.jp/cgi-bin/libroverde/libroverde.cgi/read/2004/4/12