math/dgl: Fix build

Some headers or paths of the project require C++17, but the top-level
CMakeLists.txt was setting C++14.
This commit is contained in:
Yuri Victorovich 2023-12-06 10:12:03 -08:00
parent 27add386de
commit b5ab8514ee
2 changed files with 12 additions and 3 deletions

View File

@ -13,7 +13,7 @@ BUILD_DEPENDS= ${BACKEND_DEPENDS} \
bash:shells/bash \
gmake:devel/gmake
USES= cmake:testing compiler:c++14-lang localbase:ldflags python:build shebangfix
USES= cmake:testing compiler:c++17-lang localbase:ldflags python:build shebangfix
USE_LDCONFIG= yes
USE_GITHUB= yes

View File

@ -1,6 +1,15 @@
--- CMakeLists.txt.orig 2023-05-09 05:00:36 UTC
--- CMakeLists.txt.orig 2023-06-23 05:00:04 UTC
+++ CMakeLists.txt
@@ -197,7 +197,7 @@ if(NOT MSVC)
@@ -87,7 +87,7 @@ else(MSVC)
# tensorpipe's dependencies require C++14
check_cxx_compiler_flag("-std=c++14" SUPPORT_CXX14)
set(CMAKE_C_FLAGS "-O2 -Wall -fPIC ${CMAKE_C_FLAGS}")
- set(CMAKE_CXX_FLAGS "-O2 -Wall -fPIC -std=c++14 ${CMAKE_CXX_FLAGS}")
+ set(CMAKE_CXX_FLAGS "-O2 -Wall -fPIC -std=c++17 ${CMAKE_CXX_FLAGS}")
if(NOT APPLE)
set(CMAKE_SHARED_LINKER_FLAGS "-Wl,--warn-common ${CMAKE_SHARED_LINKER_FLAGS}")
endif(NOT APPLE)
@@ -200,7 +200,7 @@ if(NOT MSVC)
include_directories(${GKLIB_PATH})
include_directories("third_party/METIS/include/")
add_subdirectory("third_party/METIS/libmetis/")