Update to 0.25.1.
PR: ports/70807 Submitted by: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
This commit is contained in:
parent
4e9351bc12
commit
b5c357cf97
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=117182
7 changed files with 55 additions and 46 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= straw
|
||||
PORTVERSION= 0.23
|
||||
PORTVERSION= 0.25.1
|
||||
CATEGORIES= net gnome
|
||||
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -14,7 +14,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A GNOME 2 desktop weblog aggregator written in Python
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_REINPLACE= yes
|
||||
|
@ -22,7 +21,8 @@ USE_GNOME= libglade2 pygnome2
|
|||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS= yes
|
||||
PYDISTUTILS_INSTALLARGS= -c -O1 --prefix=${PREFIX} \
|
||||
--install-lib=${PREFIX}/share/gnome
|
||||
--install-lib=${PREFIX}/share/gnome \
|
||||
--with-desktop-file-dir=share/gnome/applications
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -38,10 +38,6 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb
|
|||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%PYTHON_SITELIBDIR%%|${PYTHON_SITELIBDIR}|g' \
|
||||
${WRKSRC}/src/straw
|
||||
@${REINPLACE_CMD} -e 's|share/applications|share/gnome/applications|g' \
|
||||
${WRKSRC}/tools/straw_distutils.py
|
||||
@${REINPLACE_CMD} -e 's|Internet|Network|g' \
|
||||
${WRKSRC}/straw.desktop.in
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (straw-0.23.tar.bz2) = 8dbdb3bbb7a20554a069bca11712d8c3
|
||||
SIZE (straw-0.23.tar.bz2) = 158777
|
||||
MD5 (straw-0.25.1.tar.gz) = 058a58e945e37cc264c562f5ca4ff781
|
||||
SIZE (straw-0.25.1.tar.gz) = 238215
|
||||
|
|
|
@ -1,24 +1,25 @@
|
|||
--- setup.py.orig Mon Apr 26 12:17:31 2004
|
||||
+++ setup.py Thu May 20 13:41:56 2004
|
||||
@@ -97,8 +97,8 @@
|
||||
--- setup.py.orig Thu Jul 15 15:15:58 2004
|
||||
+++ setup.py Mon Aug 16 22:15:09 2004
|
||||
@@ -108,8 +108,8 @@
|
||||
'''Build list of data files to be installed'''
|
||||
images = glob.glob('images/*.png')
|
||||
files = [
|
||||
- ('share/pixmaps', ['images/straw.png']),
|
||||
- ('share/straw', images + ['data/default_subscriptions.opml', 'glade/straw.glade'])]
|
||||
- ('share/straw', images + ['data/default_subscriptions.opml', 'data/straw.css', 'glade/straw.glade'])]
|
||||
+ ('share/gnome/pixmaps', ['images/straw.png']),
|
||||
+ ('share/gnome/straw', images + ['data/default_subscriptions.opml', 'glade/straw.glade'])]
|
||||
+ ('share/gnome/straw', images + ['data/default_subscriptions.opml', 'data/straw.css', 'glade/straw.glade'])]
|
||||
return files
|
||||
|
||||
long_desc = '''\
|
||||
@@ -121,9 +121,8 @@
|
||||
config_files = [('gconf/schemas',['data/straw.schemas'],
|
||||
'with-gconf-schema-file-dir')],
|
||||
@@ -137,10 +137,9 @@
|
||||
#config_files = [('gconf/schemas',['data/straw.schemas'],
|
||||
# 'with-gconf-schema-file-dir')],
|
||||
scripts = ['src/straw'],
|
||||
- modules_check = modules_check,
|
||||
packages = ['straw'],
|
||||
package_dir = {'straw' : 'src/lib'},
|
||||
- msg_sources = translation_files(),
|
||||
+ msg_sources = ['glade/strings.c'] + glob.glob('src/lib/*.py'),
|
||||
desktop_file = ['straw.desktop.in'])
|
||||
|
||||
desktop_file = ['straw.desktop.in'],
|
||||
ext_modules = [TemplateExtension(name='trayicon',
|
||||
pkc_name='pygtk-2.0 gtk+-2.0',
|
||||
|
|
11
net/straw/files/patch-src::lib::Config.py
Normal file
11
net/straw/files/patch-src::lib::Config.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/lib/Config.py.orig Tue Aug 24 02:19:12 2004
|
||||
+++ src/lib/Config.py Tue Aug 24 02:20:06 2004
|
||||
@@ -369,6 +369,8 @@
|
||||
last_poll = property(get_last_poll, set_last_poll, doc="Last polled")
|
||||
|
||||
def get_number_of_items_stored(self):
|
||||
+ if self._items_stored == 0:
|
||||
+ return 30
|
||||
return self._items_stored
|
||||
|
||||
def set_number_of_items_stored(self, num=30):
|
|
@ -1,14 +1,14 @@
|
|||
--- src/lib/LookupManager.py.orig Thu Nov 13 23:37:03 2003
|
||||
+++ src/lib/LookupManager.py Thu Nov 13 23:38:28 2003
|
||||
@@ -6,9 +6,9 @@
|
||||
from error import log
|
||||
--- src/lib/LookupManager.py.orig Thu Jul 15 15:15:58 2004
|
||||
+++ src/lib/LookupManager.py Mon Aug 16 22:20:25 2004
|
||||
@@ -5,9 +5,9 @@
|
||||
import Config
|
||||
try:
|
||||
import adns, ADNS
|
||||
- _have_adns = True
|
||||
+ _have_adns = False
|
||||
except ImportError:
|
||||
- log("No ADNS library found, using synchronous name lookups.")
|
||||
+ #log("No ADNS library found, using synchronous name lookups.")
|
||||
- error.log("No ADNS library found, using synchronous name lookups.")
|
||||
+# error.log("No ADNS library found, using synchronous name lookups.")
|
||||
_have_adns = False
|
||||
|
||||
MAX_TIMES = 3
|
||||
|
|
|
@ -1,15 +1,6 @@
|
|||
--- src/lib/Main.py.orig Mon Apr 26 12:17:31 2004
|
||||
+++ src/lib/Main.py Sun May 2 15:30:14 2004
|
||||
@@ -417,7 +417,7 @@
|
||||
gtk.main()
|
||||
|
||||
def quit(self):
|
||||
- gtk.mainquit()
|
||||
+ gtk.main_quit()
|
||||
self._itemstore.stop()
|
||||
return
|
||||
|
||||
@@ -480,7 +480,7 @@
|
||||
--- src/lib/utils.py.orig Thu Jul 15 15:15:58 2004
|
||||
+++ src/lib/utils.py Mon Aug 16 22:26:08 2004
|
||||
@@ -162,7 +162,7 @@
|
||||
return os.environ["STRAW_DATA"]
|
||||
h, t = os.path.split(os.path.split(os.path.abspath(sys.argv[0]))[0])
|
||||
if t == 'bin':
|
|
@ -1,7 +1,4 @@
|
|||
bin/straw
|
||||
@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/straw.schemas > /dev/null || /usr/bin/true
|
||||
etc/gconf/schemas/straw.schemas
|
||||
@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/straw.schemas > /dev/null || /usr/bin/true
|
||||
share/gnome/applications/straw.desktop
|
||||
share/gnome/pixmaps/straw.png
|
||||
share/gnome/straw/Config.py
|
||||
|
@ -43,12 +40,18 @@ share/gnome/straw/ItemStore.pyo
|
|||
share/gnome/straw/LookupManager.py
|
||||
share/gnome/straw/LookupManager.pyc
|
||||
share/gnome/straw/LookupManager.pyo
|
||||
share/gnome/straw/MVP.py
|
||||
share/gnome/straw/MVP.pyc
|
||||
share/gnome/straw/MVP.pyo
|
||||
share/gnome/straw/Main.py
|
||||
share/gnome/straw/Main.pyc
|
||||
share/gnome/straw/Main.pyo
|
||||
share/gnome/straw/MainWindow.py
|
||||
share/gnome/straw/MainWindow.pyc
|
||||
share/gnome/straw/MainWindow.pyo
|
||||
share/gnome/straw/MainloopManager.py
|
||||
share/gnome/straw/MainloopManager.pyc
|
||||
share/gnome/straw/MainloopManager.pyo
|
||||
share/gnome/straw/MessageManager.py
|
||||
share/gnome/straw/MessageManager.pyc
|
||||
share/gnome/straw/MessageManager.pyo
|
||||
|
@ -76,9 +79,6 @@ share/gnome/straw/PreferencesDialog.pyo
|
|||
share/gnome/straw/QueueDict.py
|
||||
share/gnome/straw/QueueDict.pyc
|
||||
share/gnome/straw/QueueDict.pyo
|
||||
share/gnome/straw/StrawURLOpener.py
|
||||
share/gnome/straw/StrawURLOpener.pyc
|
||||
share/gnome/straw/StrawURLOpener.pyo
|
||||
share/gnome/straw/SubscribeDialog.py
|
||||
share/gnome/straw/SubscribeDialog.pyc
|
||||
share/gnome/straw/SubscribeDialog.pyo
|
||||
|
@ -88,9 +88,15 @@ share/gnome/straw/SummaryItem.pyo
|
|||
share/gnome/straw/SummaryParser.py
|
||||
share/gnome/straw/SummaryParser.pyc
|
||||
share/gnome/straw/SummaryParser.pyo
|
||||
share/gnome/straw/Tray.py
|
||||
share/gnome/straw/Tray.pyc
|
||||
share/gnome/straw/Tray.pyo
|
||||
share/gnome/straw/URLFetch.py
|
||||
share/gnome/straw/URLFetch.pyc
|
||||
share/gnome/straw/URLFetch.pyo
|
||||
share/gnome/straw/ValueMonitor.py
|
||||
share/gnome/straw/ValueMonitor.pyc
|
||||
share/gnome/straw/ValueMonitor.pyo
|
||||
share/gnome/straw/__init__.py
|
||||
share/gnome/straw/__init__.pyc
|
||||
share/gnome/straw/__init__.pyo
|
||||
|
@ -101,6 +107,9 @@ share/gnome/straw/default_subscriptions.opml
|
|||
share/gnome/straw/error.py
|
||||
share/gnome/straw/error.pyc
|
||||
share/gnome/straw/error.pyo
|
||||
share/gnome/straw/feedfinder.py
|
||||
share/gnome/straw/feedfinder.pyc
|
||||
share/gnome/straw/feedfinder.pyo
|
||||
share/gnome/straw/feedparser.py
|
||||
share/gnome/straw/feedparser.pyc
|
||||
share/gnome/straw/feedparser.pyo
|
||||
|
@ -117,9 +126,8 @@ share/gnome/straw/image-broken.png
|
|||
share/gnome/straw/image-waiting.png
|
||||
share/gnome/straw/offline.png
|
||||
share/gnome/straw/online.png
|
||||
share/gnome/straw/rssfinder.py
|
||||
share/gnome/straw/rssfinder.pyc
|
||||
share/gnome/straw/rssfinder.pyo
|
||||
share/gnome/straw/pytrayicon.so
|
||||
share/gnome/straw/straw.css
|
||||
share/gnome/straw/straw.glade
|
||||
share/gnome/straw/straw.png
|
||||
share/gnome/straw/utils.py
|
||||
|
@ -127,12 +135,14 @@ share/gnome/straw/utils.pyc
|
|||
share/gnome/straw/utils.pyo
|
||||
share/locale/cs/LC_MESSAGES/straw.mo
|
||||
share/locale/de/LC_MESSAGES/straw.mo
|
||||
share/locale/en_CA/LC_MESSAGES/straw.mo
|
||||
share/locale/en_GB/LC_MESSAGES/straw.mo
|
||||
share/locale/es/LC_MESSAGES/straw.mo
|
||||
share/locale/fi/LC_MESSAGES/straw.mo
|
||||
share/locale/fr/LC_MESSAGES/straw.mo
|
||||
share/locale/nl/LC_MESSAGES/straw.mo
|
||||
share/locale/no/LC_MESSAGES/straw.mo
|
||||
share/locale/pt/LC_MESSAGES/straw.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/straw.mo
|
||||
share/locale/ru/LC_MESSAGES/straw.mo
|
||||
share/locale/sr/LC_MESSAGES/straw.mo
|
||||
|
|
Loading…
Reference in a new issue