simplify, per Mark Sapiro's suggestion

This commit is contained in:
Matthias Andree 2013-10-23 21:00:45 +00:00
parent 3568307321
commit b5ca2a054c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=331425

View file

@ -1,12 +1,11 @@
--- ./Makefile.in.orig 2013-10-17 06:11:34.000000000 +0200
+++ ./Makefile.in 2013-10-18 19:18:05.000000000 +0200
@@ -124,7 +124,8 @@
@@ -124,7 +124,7 @@
do \
(cd $$d; $(MAKE) DESTDIR=$(DESTDIR) install); \
done
- $(PYTHON) -c 'from compileall import *; compile_dir("$(DESTDIR)$(prefix)/Mailman")'
+ (cd "$(DESTDIR)$(prefix)" \
+ && $(PYTHON) -c 'from compileall import *; compile_dir("Mailman", ddir="$(prefix)/Mailman")')
+ $(PYTHON) -c 'from compileall import *; compile_dir("$(DESTDIR)$(prefix)/Mailman", ddir="$(prefix)/Mailman")'
# Only run bin/update if we aren't installing in DESTDIR, as this
# means there are probably no lists to deal with, and it wouldn't