o Respect CFLAGS.

o Add a message telling users to take out -O from their CFLAGS and
  recompile/reinstall samba if they encounter problems.

PR:		ports/45691
Approved by:	dwcjr (MAINTAINER)
This commit is contained in:
Clive Lin 2003-01-01 21:07:58 +00:00
parent 972d11930f
commit b5fc60620a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72111
3 changed files with 21 additions and 0 deletions

View file

@ -263,5 +263,6 @@ post-install:
done
@${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/swat/README ${DOCSDIR}/README.swat
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View file

@ -0,0 +1,11 @@
--- source/configure.in.orig Thu Nov 7 17:52:42 2002
+++ source/configure.in Thu Nov 7 17:53:09 2002
@@ -168,7 +168,7 @@
AC_SUBST(LIBSMBCLIENT)
# compile with optimization and without debugging by default
-CFLAGS="-O ${CFLAGS}"
+CFLAGS="${CFLAGS}"
AC_ARG_ENABLE(debug,
[ --enable-debug Turn on compiler debugging information (default=no)],

9
net/samba/pkg-message Normal file
View file

@ -0,0 +1,9 @@
=======================================================================
WARNING: In FreeBSD, it's known that compiling samba with any kind of
optimization flags might cause problems under certain circumstance.
If you caught any show stopper, please try taking optimization flag(s)
out of your CFLAGS and recompile/reinstall samba.
=======================================================================