LZMA Utils have been replaced by XZ Utils (archivers/xz)

Feature safe:	yes
This commit is contained in:
Christian Weisgerber 2009-09-21 19:07:37 +00:00
parent 02bedc3a76
commit b6104fe7cb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=241887
9 changed files with 0 additions and 161 deletions

View file

@ -1,38 +0,0 @@
# New ports collection makefile for: lzmautils-devel
# Date created: 09 Dec 2008
# Whom: David Naylor <dragonsa@highveldmail.co.za>
#
# $FreeBSD$
#
PORTNAME= lzmautils
DISTVERSION= 4.999.8
PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= http://tukaani.org/xz/ \
http://freebsd.unixfreunde.de/sources/
PKGNAMESUFFIX= -devel
DISTNAME= xz-${DISTVERSION}beta
MAINTAINER= dragonsa@highveldmail.co.za
COMMENT= LZMA compression and decompression tools
CONFLICTS= lzma-[0-9]* lzmautils-4.[0-3]* lzmautils-[0-3]* lzmalib-[0-9]*
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack
CONFIGURE_ARGS+= --disable-static --disable-nls # No translations apparent
.if defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --disable-threads
.endif
MAN1= lzdiff.1 lzgrep.1 lzmore.1
MLINKS= lzdiff.1 lzcmp.1 \
lzgrep.1 lzegrep.1 \
lzgrep.1 lzfgrep.1 \
lzmore.1 lzless.1
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (xz-4.999.8beta.tar.gz) = f00967331a487e88d51207fe17c56f52
SHA256 (xz-4.999.8beta.tar.gz) = 059da5a9fe51c28b38f67e5b8063a451c516f37fbb268177fd1081b70dd97f53
SIZE (xz-4.999.8beta.tar.gz) = 879382

View file

@ -1,17 +0,0 @@
--- src/xz/hardware.c~ 2009-08-18 08:15:18.000000000 +0200
+++ src/xz/hardware.c 2009-08-18 08:17:50.000000000 +0200
@@ -42,12 +42,12 @@
static void
hardware_cores(void)
{
-#if defined(HAVE_NUM_PROCESSORS_SYSCONF)
+#if defined(HAVE_NCPU_SYSCONF)
const long cpus = sysconf(_SC_NPROCESSORS_ONLN);
if (cpus > 0)
opt_threads = (size_t)(cpus);
-#elif defined(HAVE_NUM_PROCESSORS_SYSCTL)
+#elif defined(HAVE_NCPU_SYSCTL)
int name[2] = { CTL_HW, HW_NCPU };
int cpus;
size_t cpus_size = sizeof(cpus);

View file

@ -1,6 +0,0 @@
LZMA Utils is an attempt to provide LZMA compression to POSIX-like
systems. The idea is to have a gzip-like command line tool and
zlib-like library, which would make it easy to adapt the new
compression technology to existing applications.
WWW: http://tukaani.org/lzma/

View file

@ -1,35 +0,0 @@
bin/lzcat
bin/lzcmp
bin/lzdiff
bin/lzegrep
bin/lzfgrep
bin/lzgrep
bin/lzless
bin/lzma
bin/lzmadec
bin/lzmore
bin/unlzma
bin/unxz
bin/xz
bin/xzcat
bin/xzdec
include/lzma.h
include/lzma/base.h
include/lzma/bcj.h
include/lzma/block.h
include/lzma/check.h
include/lzma/container.h
include/lzma/delta.h
include/lzma/filter.h
include/lzma/index.h
include/lzma/index_hash.h
include/lzma/lzma.h
include/lzma/stream_flags.h
include/lzma/subblock.h
include/lzma/version.h
include/lzma/vli.h
lib/liblzma.la
lib/liblzma.so
lib/liblzma.so.0
libdata/pkgconfig/liblzma.pc
@dirrm include/lzma

View file

@ -1,35 +0,0 @@
# New ports collection makefile for: lzmautils
# Date created: 2008-04-19
# Whom: naddy
#
# $FreeBSD$
#
PORTNAME= lzmautils
PORTVERSION= 4.32.7
CATEGORIES= archivers
MASTER_SITES= http://tukaani.org/lzma/
DISTNAME= lzma-${PORTVERSION}
MAINTAINER= naddy@FreeBSD.org
COMMENT= LZMA compression and decompression tools
CONFLICTS= lzma-[0-9]*
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
MAN1= lzdiff.1 lzgrep.1 lzma.1 lzmadec.1 lzmainfo.1 lzmore.1
MLINKS= lzma.1 unlzma.1 \
lzma.1 lzcat.1 \
lzdiff.1 lzcmp.1 \
lzgrep.1 lzegrep.1 \
lzgrep.1 lzfgrep.1 \
lzmore.1 lzless.1
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (lzma-4.32.7.tar.gz) = 2a748b77a2f8c3cbc322dbd0b4c9d06a
SHA256 (lzma-4.32.7.tar.gz) = 9f337a8c51e5ded198d1032f5087ba3fe438f2a54e9df419e513a151775b032c
SIZE (lzma-4.32.7.tar.gz) = 479270

View file

@ -1,6 +0,0 @@
LZMA Utils is an attempt to provide LZMA compression to POSIX-like
systems. The idea is to have a gzip-like command line tool and
zlib-like library, which would make it easy to adapt the new
compression technology to existing applications.
WWW: http://tukaani.org/lzma/

View file

@ -1,18 +0,0 @@
@comment $FreeBSD$
bin/lzcat
bin/lzcmp
bin/lzdiff
bin/lzegrep
bin/lzfgrep
bin/lzgrep
bin/lzless
bin/lzma
bin/lzmadec
bin/lzmainfo
bin/lzmore
bin/unlzma
include/lzmadec.h
lib/liblzmadec.a
lib/liblzmadec.la
lib/liblzmadec.so
lib/liblzmadec.so.0