Update to 3.10
Upstream have included our local patches. ChangeLog: https://raw.githubusercontent.com/hashcat/hashcat/v3.10/docs/changes.txt PR: 211998 Submitted by: lifanov@mail.lifanov.com (maintainer)
This commit is contained in:
parent
3d0121fe72
commit
b629e5f604
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=420475
8 changed files with 7 additions and 170 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= hashcat
|
||||
PORTVERSION= 3.00
|
||||
PORTVERSION= 3.10
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= security
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1468849069
|
||||
SHA256 (hashcat-hashcat-v3.00_GH0.tar.gz) = 0283791b91db9dd7ee7431d8975c63419c73232945b76eedcefbe12becfa19c4
|
||||
SIZE (hashcat-hashcat-v3.00_GH0.tar.gz) = 4068649
|
||||
TIMESTAMP = 1471617716
|
||||
SHA256 (hashcat-hashcat-v3.10_GH0.tar.gz) = 8de4f4ae8baa10dbe9139d670cc26dcd49e0e7e343bcbcadbe912cc52fb8255f
|
||||
SIZE (hashcat-hashcat-v3.10_GH0.tar.gz) = 4077706
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
--- include/common.h.orig 2016-06-28 09:47:32 UTC
|
||||
+++ include/common.h
|
||||
@@ -51,6 +51,11 @@
|
||||
#include <mach/mach.h>
|
||||
#endif
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <termios.h>
|
||||
+#include <sys/ioctl.h>
|
||||
+#endif
|
||||
+
|
||||
typedef void *OCL_LIB;
|
||||
|
||||
#ifdef HAVE_HWMON
|
|
@ -1,13 +0,0 @@
|
|||
--- include/ext_OpenCL.h.orig 2016-06-28 09:47:32 UTC
|
||||
+++ include/ext_OpenCL.h
|
||||
@@ -27,6 +27,10 @@
|
||||
// #include <CL/cl_ext.h> // used for CL_DEVICE_TOPOLOGY_AMD but broken for dual GPU
|
||||
#endif
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <CL/cl.h>
|
||||
+#endif
|
||||
+
|
||||
#include <shared.h>
|
||||
|
||||
typedef cl_mem (CL_API_CALL *OCL_CLCREATEBUFFER) (cl_context, cl_mem_flags, size_t, void *, cl_int *);
|
|
@ -1,52 +0,0 @@
|
|||
--- src/Makefile.orig 2016-06-28 09:47:32 UTC
|
||||
+++ src/Makefile
|
||||
@@ -17,7 +17,7 @@ UNAME := $(shell unam
|
||||
# we need to strip the windows version number to be able to build hashcat on cygwin hosts
|
||||
UNAME := $(patsubst CYGWIN_NT-%,CYGWIN_NT-,$(UNAME))
|
||||
|
||||
-ifeq (,$(filter $(UNAME),Linux Darwin CYGWIN_NT-))
|
||||
+ifeq (,$(filter $(UNAME),Linux Darwin CYGWIN_NT- FreeBSD))
|
||||
$(error "! Your Operating System ($(UNAME)) is not supported by $(PROG_NAME) Makefile")
|
||||
endif
|
||||
|
||||
@@ -58,7 +58,6 @@ OPENCL_HEADERS_KHRONOS := deps/OpenCL-
|
||||
## Native compiler paths
|
||||
##
|
||||
|
||||
-CC := gcc
|
||||
FIND := find
|
||||
INSTALL := install
|
||||
RM := rm
|
||||
@@ -87,7 +86,7 @@ VERSION_TAG := $(shell test
|
||||
## Compiler flags
|
||||
##
|
||||
|
||||
-CFLAGS := -pipe -W -Wall -std=c99 -Iinclude/ -IOpenCL/ -I$(OPENCL_HEADERS_KHRONOS)/
|
||||
+CFLAGS += -Iinclude/ -IOpenCL/ -I$(OPENCL_HEADERS_KHRONOS)/
|
||||
|
||||
ifndef DEBUG
|
||||
CFLAGS += -O2
|
||||
@@ -97,6 +96,9 @@ ifeq ($(DEBUG),2)
|
||||
CFLAGS += -fsanitize=address -fno-omit-frame-pointer
|
||||
endif
|
||||
endif
|
||||
+ifeq ($(UNAME),FreeBSD)
|
||||
+SED := gsed
|
||||
+endif
|
||||
|
||||
##
|
||||
## Native compilation target
|
||||
@@ -122,6 +124,13 @@ LFLAGS_NATIVE := -lpthread -l
|
||||
CFLAGS_NATIVE += -DHAVE_HWMON
|
||||
endif # linux
|
||||
|
||||
+ifeq ($(UNAME),FreeBSD)
|
||||
+CFLAGS_NATIVE := -D_POSIX
|
||||
+CFLAGS_NATIVE += $(CFLAGS)
|
||||
+LFLAGS_NATIVE := -lpthread
|
||||
+LFLAGS_NATIVE += $(LDFLAGS)
|
||||
+endif # freebsd
|
||||
+
|
||||
##
|
||||
## Cross compilation target
|
||||
##
|
|
@ -1,20 +0,0 @@
|
|||
--- src/hashcat.c.orig 2016-06-28 09:47:32 UTC
|
||||
+++ src/hashcat.c
|
||||
@@ -6,7 +6,7 @@
|
||||
* License.....: MIT
|
||||
*/
|
||||
|
||||
-#ifdef DARWIN
|
||||
+#if defined(DARWIN) || defined(__FreeBSD__)
|
||||
#include <stdio.h>
|
||||
#endif
|
||||
|
||||
@@ -6134,7 +6134,7 @@ int main (int argc, char **argv)
|
||||
|
||||
char *exec_path = get_exec_path ();
|
||||
|
||||
- #ifdef LINUX
|
||||
+ #if defined(LINUX) || defined(__FreeBSD__)
|
||||
|
||||
char *resolved_install_folder = realpath (INSTALL_FOLDER, NULL);
|
||||
char *resolved_exec_path = realpath (exec_path, NULL);
|
|
@ -1,67 +0,0 @@
|
|||
--- src/shared.c.orig 2016-06-28 09:47:32 UTC
|
||||
+++ src/shared.c
|
||||
@@ -10,6 +10,11 @@
|
||||
#include <stdio.h>
|
||||
#endif
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <stdio.h>
|
||||
+#include <pthread_np.h>
|
||||
+#endif
|
||||
+
|
||||
#include <shared.h>
|
||||
#include <limits.h>
|
||||
|
||||
@@ -2382,7 +2387,7 @@ int tty_fix()
|
||||
}
|
||||
#endif
|
||||
|
||||
-#ifdef DARWIN
|
||||
+#if defined(DARWIN) || defined(__FreeBSD__)
|
||||
static struct termios savemodes;
|
||||
static int havemodes = 0;
|
||||
|
||||
@@ -4371,6 +4376,23 @@ char *get_exec_path ()
|
||||
|
||||
const int len = strlen (exec_path);
|
||||
|
||||
+ #elif __FreeBSD__
|
||||
+
|
||||
+ #include <sys/sysctl.h>
|
||||
+
|
||||
+ int mib[4];
|
||||
+ mib[0] = CTL_KERN;
|
||||
+ mib[1] = KERN_PROC;
|
||||
+ mib[2] = KERN_PROC_PATHNAME;
|
||||
+ mib[3] = -1;
|
||||
+
|
||||
+ char tmp[32] = { 0 };
|
||||
+
|
||||
+ size_t size = exec_path_len;
|
||||
+ sysctl(mib, 4, exec_path, &size, NULL, 0);
|
||||
+
|
||||
+ const int len = readlink (tmp, exec_path, exec_path_len - 1);
|
||||
+
|
||||
#else
|
||||
#error Your Operating System is not supported or detected
|
||||
#endif
|
||||
@@ -4523,6 +4545,9 @@ void set_cpu_affinity (char *cpu_affinit
|
||||
{
|
||||
#ifdef _WIN
|
||||
DWORD_PTR aff_mask = 0;
|
||||
+ #elif __FreeBSD__
|
||||
+ cpuset_t cpuset;
|
||||
+ CPU_ZERO (&cpuset);
|
||||
#elif _POSIX
|
||||
cpu_set_t cpuset;
|
||||
CPU_ZERO (&cpuset);
|
||||
@@ -4570,6 +4595,9 @@ void set_cpu_affinity (char *cpu_affinit
|
||||
#ifdef _WIN
|
||||
SetProcessAffinityMask (GetCurrentProcess (), aff_mask);
|
||||
SetThreadAffinityMask (GetCurrentThread (), aff_mask);
|
||||
+ #elif __FreeBSD__
|
||||
+ pthread_t thread = pthread_self ();
|
||||
+ pthread_setaffinity_np (thread, sizeof (cpuset_t), &cpuset);
|
||||
#elif _POSIX
|
||||
pthread_t thread = pthread_self ();
|
||||
pthread_setaffinity_np (thread, sizeof (cpu_set_t), &cpuset);
|
|
@ -377,6 +377,9 @@ bin/hashcat
|
|||
%%DATADIR%%/OpenCL/m13800_a0.cl
|
||||
%%DATADIR%%/OpenCL/m13800_a1.cl
|
||||
%%DATADIR%%/OpenCL/m13800_a3.cl
|
||||
%%DATADIR%%/OpenCL/m13900_a0.cl
|
||||
%%DATADIR%%/OpenCL/m13900_a1.cl
|
||||
%%DATADIR%%/OpenCL/m13900_a3.cl
|
||||
%%DATADIR%%/OpenCL/markov_be.cl
|
||||
%%DATADIR%%/OpenCL/markov_le.cl
|
||||
%%DATADIR%%/charsets/combined/Bulgarian.hcchr
|
||||
|
|
Loading…
Reference in a new issue