devel/wasm3: Fix compilation and clean up port.

Rephrase COMMENT and pkg-descr to sound less like a sales pitch
Disable -march=native as this overrides settings by the framework and fails on multiple non x86 platforms
Remove GitHub related variables that are already defined
Replace += with = for GH_TUPLE
Remove forced O3 optimization

PR:		259701
Approved by:	portmgr (build fix blanket)
Differential Revision:	https://reviews.freebsd.org/D32883
This commit is contained in:
Daniel Engberg 2021-11-14 08:30:46 +01:00 committed by Mikael Urankar
parent 6264f7593c
commit b62fdebf66
3 changed files with 23 additions and 8 deletions

View file

@ -1,11 +1,11 @@
PORTNAME= wasm3
DISTVERSIONPREFIX= v
DISTVERSION= 0.5.0
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= devel
MAINTAINER= freebsd@sysctl.cz
COMMENT= The fastest WebAssembly interpreter, and the most universal runtime
COMMENT= High performance WebAssembly interpreter
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
@ -14,10 +14,11 @@ LIB_DEPENDS= libuv.so:devel/libuv
USES= cmake:insource cpe localbase:ldflags
CPE_VENDOR= ${PORTNAME}_project
USE_GITHUB= yes
GH_ACCOUNT= wasm3
GH_PROJECT= wasm3
GH_TUPLE+= vshymanskyy:uvwasi:b063d686848:uvwasi/_deps/uvwasi-src
GH_TUPLE= vshymanskyy:uvwasi:b063d686848:uvwasi/_deps/uvwasi-src
CMAKE_OFF= BUILD_NATIVE
PLIST_FILES= bin/wasm3

View file

@ -1,14 +1,27 @@
--- CMakeLists.txt.orig 2021-06-02 10:40:14 UTC
+++ CMakeLists.txt
@@ -172,7 +172,7 @@ else()
@@ -166,18 +166,18 @@ else()
endif()
set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -ggdb -O0")
- set(CMAKE_C_FLAGS_RELEASE "-O3 -Wfatal-errors -fomit-frame-pointer -fno-stack-check -fno-stack-protector") #-fno-inline
+ set(CMAKE_C_FLAGS_RELEASE "-Wfatal-errors -fomit-frame-pointer -fno-stack-check -fno-stack-protector") #-fno-inline
if(BUILD_NATIVE)
if(APPLE AND CMAKE_C_COMPILER_ID MATCHES "Clang" AND CMAKE_HOST_SYSTEM_PROCESSOR MATCHES "arm64")
set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -mcpu=native")
else()
- set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -march=native")
+ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
+ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -mcpu=native")
endif()
endif()
set(CMAKE_EXE_LINKER_FLAGS_DEBUG "-O0")
- set(CMAKE_EXE_LINKER_FLAGS_RELEASE "-O3")
+# set(CMAKE_EXE_LINKER_FLAGS_RELEASE "-O3")
target_link_libraries(${OUT_FILE} m)
@@ -188,21 +188,10 @@ if(BUILD_WASI MATCHES "simple")
elseif(BUILD_WASI MATCHES "metawasi")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Dd_m3HasMetaWASI")

View file

@ -1,3 +1,4 @@
The fastest WebAssembly interpreter, and the most universal runtime.
High performance WebAssembly interpreter in C with low system requirements and
wide support of different architectures
WWW: https://github.com/wasm3/wasm3