Add dirmngr, a client for managing and downloading certificate

revocation lists (X.509).

PR:		51577
Submitted by:	Michael Nottebrock <michaelnottebrock@gmx.net>
This commit is contained in:
Tilman Keskinoz 2003-04-30 17:00:36 +00:00
parent fb4c110510
commit b6478e3ed3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=79925
15 changed files with 213 additions and 0 deletions

View file

@ -47,6 +47,7 @@
SUBDIR += ddos_scan
SUBDIR += didentd
SUBDIR += digest
SUBDIR += dirmngr
SUBDIR += donkey
SUBDIR += drweb
SUBDIR += drweb-postfix

46
security/dirmngr/Makefile Normal file
View file

@ -0,0 +1,46 @@
# New ports collection makefile for: dirmngr
# Date created: 06 Feb 2003
# Whom: michaelnottebrock@gmx.net
#
# $FreeBSD$
#
PORTNAME= dirmngr
PORTVERSION= 0.4.3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG} \
http://tigress.com/lofi/:lofi/
MASTER_SITE_SUBDIR= alpha/aegypten
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
common.tar.gz:lofi
MAINTAINER= michaelnottebrock@gmx.net
COMMENT= A client for managing and downloading certificate revocation lists
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2 \
gcrypt.6:${PORTSDIR}/security/libgcrypt \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
ksba.7:${PORTSDIR}/security/libksba
USE_AUTOMAKE_VER= 15
USE_LIBTOOL= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
CONFIGURE_ARGS+=--with-included-gettext=no
.include <bsd.port.pre.mk>
post-extract:
${MV} ${WRKDIR}/common ${WRKSRC}
pre-configure:
${REINPLACE_CMD} -e "s@-lpthread@${PTHREAD_LIBS}@g" \
${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4 ${WRKSRC}/configure
cd ${WRKSRC}; ./autogen.sh
.include <bsd.port.post.mk>

View file

@ -0,0 +1,2 @@
MD5 (dirmngr-0.4.3.tar.gz) = fef77ed2a1ea8d820192e8753717c95f
MD5 (common.tar.gz) = 4f5171946f83dfe64761344d7e86af05

View file

@ -0,0 +1,8 @@
--- Makefile.am.orig Thu Feb 6 17:26:01 2003
+++ Makefile.am Thu Feb 6 17:26:38 2003
@@ -21,4 +21,4 @@
EXTRA_DIST = README-alpha autogen.sh
-SUBDIRS = jnlib assuan src doc tests
+SUBDIRS = jnlib assuan common src doc tests

View file

@ -0,0 +1,27 @@
--- assuan/assuan-handler.c.orig Thu Jan 30 07:58:09 2003
+++ assuan/assuan-handler.c Thu Jan 30 07:58:27 2003
@@ -29,6 +29,24 @@
#define digitp(a) ((a) >= '0' && (a) <= '9')
+#if !HAVE_FOPENCOOKIE
+/* Provide structure for our dummy replacement function. Usually this
+ is defined in ../common/util.h but assuan should be self
+ contained. */
+/* Fixme: Remove fopencoookie :-(( */
+typedef struct
+{
+ ssize_t (*read)(void*,char*,size_t);
+ ssize_t (*write)(void*,const char*,size_t);
+ int (*seek)(void*,off_t*,int);
+ int (*close)(void*);
+} _IO_cookie_io_functions_t;
+typedef _IO_cookie_io_functions_t cookie_io_functions_t;
+FILE *fopencookie (void *cookie, const char *opentype,
+ cookie_io_functions_t funclist);
+#endif /*!HAVE_FOPENCOOKIE*/
+
+
static int
dummy_handler (ASSUAN_CONTEXT ctx, char *line)
{

View file

@ -0,0 +1,10 @@
--- assuan/assuan-socket-connect.c.orig Wed Jan 29 15:30:12 2003
+++ assuan/assuan-socket-connect.c Wed Jan 29 15:30:28 2003
@@ -23,6 +23,7 @@
#include <stddef.h>
#include <stdio.h>
#include <errno.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <sys/un.h>
#include <unistd.h>

View file

@ -0,0 +1,10 @@
--- assuan/assuan-socket-server.c.orig Wed Jan 29 15:27:13 2003
+++ assuan/assuan-socket-server.c Wed Jan 29 15:27:38 2003
@@ -22,6 +22,7 @@
#include <stdlib.h>
#include <stdio.h>
#include <errno.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <sys/un.h>
#include <unistd.h>

View file

@ -0,0 +1,10 @@
--- assuan/mkerrors.orig Thu Jan 30 07:49:26 2003
+++ assuan/mkerrors Thu Jan 30 07:50:41 2003
@@ -68,4 +68,5 @@
return s;
}
-EOF
\ No newline at end of file
+EOF
+

View file

@ -0,0 +1,10 @@
--- common/maperror.c.orig Thu Jan 30 08:00:00 2003
+++ common/maperror.c Thu Jan 30 08:00:15 2003
@@ -210,7 +210,6 @@
case GNUPG_Certificate_Expired:
rc = ASSUAN_Bad_Certificate;
break;
- case GNUPG_Bad_Certificate_Chain: rc = ASSUAN_Bad_Certificate_Chain; break;
case GNUPG_Missing_Certificate: rc = ASSUAN_Missing_Certificate; break;
case GNUPG_No_Data: rc = ASSUAN_No_Data_Available; break;
case GNUPG_Bad_Signature: rc = ASSUAN_Bad_Signature; break;

View file

@ -0,0 +1,42 @@
--- configure.ac.orig Wed Nov 20 00:54:24 2002
+++ configure.ac Thu Feb 6 17:47:12 2003
@@ -300,6 +300,17 @@
# These are needed by libjnlib - fixme: we should have a macros for them
AC_CHECK_FUNCS(memicmp stpcpy strlwr strtoul memmove stricmp strtol)
+AC_CHECK_FUNCS(getrusage setrlimit stat setlocale)
+AC_CHECK_FUNCS(flockfile funlockfile)
+
+AC_CHECK_FUNCS(sigaction sigprocmask)
+
+AC_REPLACE_FUNCS(vasprintf)
+AC_REPLACE_FUNCS(fopencookie)
+# FIXME: Print a warning when fopencookie is not available.
+AC_REPLACE_FUNCS(mkdtemp)
+AC_REPLACE_FUNCS(fseeko ftello)
+AC_REPLACE_FUNCS(isascii)
AC_CHECK_FUNCS(asprintf,,[
AC_MSG_ERROR([[
@@ -307,13 +318,6 @@
*** asprintf(3) is needed to build this package.
*** We will provide an replacement in a later release.
***]])])
-AC_CHECK_FUNCS(fopencookie,,[
- AC_MSG_ERROR([[
-***
-*** fopencookie(3) is needed to build this package.
-*** We will provide an replacement in a later release.
-***]])])
-
# We use jnlib, so tell other modules about it
AC_DEFINE(HAVE_JNLIB_LOGGING, 1,
@@ -324,6 +328,7 @@
Makefile
jnlib/Makefile
assuan/Makefile
+common/Makefile
src/Makefile
doc/Makefile
tests/Makefile

View file

@ -0,0 +1,11 @@
--- doc/dirmngr.info.orig Wed Apr 30 16:09:38 2003
+++ doc/dirmngr.info Wed Apr 30 16:10:07 2003
@@ -3,7 +3,7 @@
INFO-DIR-SECTION GNU Utilities
START-INFO-DIR-ENTRY
-* dirmngr: (gnupg). X509/LDAP certificate and revocation list client.
+* dirmngr: (dirmngr). X509/LDAP certificate and revocation list client.
END-INFO-DIR-ENTRY
This file documents the use of dirmngr.

View file

@ -0,0 +1,13 @@
--- src/Makefile.am.orig Thu Feb 6 18:00:41 2003
+++ src/Makefile.am Thu Feb 6 18:01:22 2003
@@ -32,8 +32,6 @@
dirmngr_LDFLAGS = $(LDAP_RPATH)
dirmngr_LDADD = ../jnlib/libjnlib.a ../assuan/libassuan.a \
- $(LIBGCRYPT_LIBS) $(LIBKSBA_LIBS) $(LDAP_LIBS) $(DB_LIBS)
-
-
-
+ ../common/libcommon.a $(LIBGCRYPT_LIBS) \
+ $(LIBKSBA_LIBS) $(LDAP_LIBS) $(DB_LIBS)

View file

@ -0,0 +1,11 @@
--- tests/Makefile.am.orig Thu Feb 6 18:02:43 2003
+++ tests/Makefile.am Thu Feb 6 18:02:59 2003
@@ -10,7 +10,7 @@
TESTS =
noinst_PROGRAMS = test-dirmngr
-LDADD = ../jnlib/libjnlib.a ../assuan/libassuan.a $(LIBGCRYPT_LIBS) $(LIBKSBA_LIBS)
+LDADD = ../jnlib/libjnlib.a ../assuan/libassuan.a ../common/libcommon.a $(LIBGCRYPT_LIBS) $(LIBKSBA_LIBS)

View file

@ -0,0 +1,8 @@
Dirmngr is a client for managing and downloading certificate
revocation lists (CRLs) for X509 certificates and for downloading the
certificates themselves. Dirmngr is usually invoked by gpgsm and in
general not used directly.
WWW: http://www.gnupg.org/aegypten
michaelnottebrock@gmx.net

View file

@ -0,0 +1,4 @@
bin/dirmngr
@unexec install-info --delete %D/info/dirmngr.info %D/info/dir
info/dirmngr.info
@exec install-info %D/info/dirmngr.info %D/info/dir