- Change port to properly pass 32/64bit options based on current ARCH to the
ant build process. - Remove javaservicewrapper/files/patch-build.xml, this patch should no longer be necessary due to the update above. - Strip resulting binary. - Take over maintainership, Alejandro no longer uses this port. Changes by alepulver: - Keep USE_GMAKE because Ant calls it when building the C code. - Put do-build before bsd.port.pre.mk to avoid a target redefinition warning. PR: ports/137267 Submitted by: Mike Jakubik <mikej@rogers.com>
This commit is contained in:
parent
2234ded645
commit
b6509e387b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=238682
2 changed files with 19 additions and 16 deletions
|
@ -7,33 +7,46 @@
|
|||
|
||||
PORTNAME= javaservicewrapper
|
||||
PORTVERSION= 3.3.5
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= sysutils java
|
||||
MASTER_SITES= http://wrapper.tanukisoftware.org/download/${PORTVERSION}/
|
||||
DISTNAME= wrapper_${PORTVERSION}_src
|
||||
|
||||
MAINTAINER= alepulver@FreeBSD.org
|
||||
MAINTAINER= mikej@rogers.com
|
||||
COMMENT= Application to solve problems common to many Java applications
|
||||
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_JAVA= 1.3+
|
||||
USE_ANT= yes
|
||||
|
||||
DATADIR= ${PREFIX}/lib/${PORTNAME}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|gcc|${CC} ${CFLAGS} -fPIC|' \
|
||||
${WRKSRC}/src/c/Makefile-freebsd-x86-32.gmake
|
||||
|
||||
do-build:
|
||||
@cd ${WRKSRC} && ${SETENV} ANT_HOME="${LOCALBASE}" ${SH} build32.sh
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if (${ARCH} == amd64)
|
||||
MAKE_ARGS+= -Dbits=64
|
||||
.else
|
||||
MAKE_ARGS+= -Dbits=32
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|gcc|${CC} ${CFLAGS} -fPIC|' \
|
||||
${WRKSRC}/src/c/Makefile-freebsd-x86-32.gmake \
|
||||
${WRKSRC}/src/c/Makefile-freebsd-x86-64.gmake
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${DATADIR}
|
||||
cd ${WRKSRC} && ${CP} -rp bin conf lib test ${DATADIR}
|
||||
${STRIP_CMD} ${DATADIR}/bin/wrapper
|
||||
${LN} -sf ${DATADIR}/bin/wrapper ${PREFIX}/bin/${PORTNAME}
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${CP} -r ${WRKSRC}/doc/* ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- ./build.xml.orig Tue Oct 17 11:21:20 2006
|
||||
+++ ./build.xml Thu Sep 27 19:07:48 2007
|
||||
@@ -304,7 +304,6 @@
|
||||
<echo message="**********************************************************************"/>
|
||||
<echo message="A ${bits}-bit build was requested, but this is a ${sun.arch.data.model}-bit JVM."/>
|
||||
<echo message="**********************************************************************"/>
|
||||
- <fail message="The "bits" system property does not match that of the JVM."/>
|
||||
</target>
|
||||
|
||||
<!-- =================================================================== -->
|
Loading…
Reference in a new issue