Remove expired port: Runtime is mostly broken, abandoned upstream. Use www/py-flexget instead.
PR: 160626 Submitted by: h h <aakuusta at gmail dot com> Approved by: maintainer (timeout, 3 months+)
This commit is contained in:
parent
595a785c44
commit
b6673b023f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=289802
10 changed files with 1 additions and 125 deletions
1
MOVED
1
MOVED
|
@ -3225,3 +3225,4 @@ net-im/libicq||2012-01-18|Runtime is broken. Unmaintained upstream
|
|||
devel/luajit|lang/luajit|2012-01-19|Compilers typically live in the lang category
|
||||
devel/p5-DBIx-Class-Schema-PopulateMore||2012-01-20|Removed
|
||||
textproc/qgoogletranslator||2012-01-20|Has expired: Runtime is broken because Google close free usage of API. Project closed.
|
||||
py-rssdler||2012-01-25|Runtime is mostly broken, abandoned upstream. Use www/py-flexget instead
|
||||
|
|
|
@ -1527,7 +1527,6 @@
|
|||
SUBDIR += py-requests-oauth-hook
|
||||
SUBDIR += py-restclient
|
||||
SUBDIR += py-routes
|
||||
SUBDIR += py-rssdler
|
||||
SUBDIR += py-satchmo
|
||||
SUBDIR += py-scgi
|
||||
SUBDIR += py-scrapy
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
# New ports collection makefile for: py-rssdler
|
||||
# Date created: 02 May 2010
|
||||
# Whom: Anonymous <swell.k@gmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= rssdler
|
||||
PORTVERSION= 0.4.2
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= www python
|
||||
MASTER_SITES= GOOGLE_CODE
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Automatically grab link elements of an RSS feed
|
||||
|
||||
DEPRECATED= Runtime is mostly broken, abandoned upstream. Use www/py-flexget instead
|
||||
EXPIRATION_DATE= 2012-01-25
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=4.1:${PORTSDIR}/textproc/py-feedparser
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=4.1:${PORTSDIR}/textproc/py-feedparser
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS=yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//g}
|
||||
|
||||
OPTIONS= MECHANIZE "Retrieve pages with mechanize" On
|
||||
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if !defined(WITHOUT_MECHANIZE)
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mechanize>=0.2:${PORTSDIR}/www/py-mechanize
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (rssdler-0.4.2.tar.gz) = 96e1fefd1a6a3325aee1778fcf5ca115dcfb924047024f70e1ddd869017829ce
|
||||
SIZE (rssdler-0.4.2.tar.gz) = 36612
|
|
@ -1,12 +0,0 @@
|
|||
Index: rssdler.py
|
||||
===================================================================
|
||||
--- rssdler.py (revision 169)
|
||||
+++ rssdler.py (working copy)
|
||||
@@ -2180,6 +2180,7 @@
|
||||
elif param == "--purge-saved": _action = 'purge-saved'
|
||||
elif param == "--comment-config": _action = 'comment-config'
|
||||
signal.signal(signal.SIGINT, signalHandler)
|
||||
+ signal.signal(signal.SIGTERM, signalHandler)
|
||||
sys.excepthook = setDebug #this is NOT supposed to be called!
|
||||
if _action == 'comment-config':
|
||||
print(commentConfig)
|
|
@ -1,14 +0,0 @@
|
|||
Index: rssdler.py
|
||||
===================================================================
|
||||
--- rssdler.py (revision 169)
|
||||
+++ rssdler.py (working copy)
|
||||
@@ -2085,6 +2085,9 @@
|
||||
raise
|
||||
if _runOnce:
|
||||
logging.info( u"[Complete] %s" % time.asctime() )
|
||||
+ try: codecs.open(os.path.join(getConfig()['global']['workingDir'],
|
||||
+ getConfig()['global']['daemonInfo']), 'w', 'utf-8').write('')
|
||||
+ except IOError, m: pass
|
||||
break
|
||||
logging.info( u"[Sleeping] %s" % time.asctime() )
|
||||
checkSleep( getConfig()['global']['scanMins'] * 60 )
|
|
@ -1,16 +0,0 @@
|
|||
Index: rssdler.py
|
||||
===================================================================
|
||||
--- rssdler.py (revision 169)
|
||||
+++ rssdler.py (working copy)
|
||||
@@ -363,9 +363,9 @@ def percentUnQuote( sStr, p=percentunQuoteDict, re
|
||||
replaced in order of the sequence"""
|
||||
for search in p:
|
||||
if search in reserved: continue
|
||||
- sStr = sStr.replace( search, p[search] )
|
||||
+ sStr = re.sub('(?i)' + re.escape(search), p[search], sStr)
|
||||
for search in reserved:
|
||||
- sStr = sStr.replace( search, p[search])
|
||||
+ sStr = re.sub('(?i)' + re.escape(search), p[search], sStr)
|
||||
return sStr
|
||||
|
||||
def percentQuote(sStr, urlPart=(2,), pd=percentQuoteDict):
|
|
@ -1,32 +0,0 @@
|
|||
Index: rssdler.py
|
||||
===================================================================
|
||||
--- rssdler.py (revision 169)
|
||||
+++ rssdler.py (working copy)
|
||||
@@ -79,6 +79,7 @@ percentQuoteDict = {u'!': u'%21', u' ': u'%20', u'
|
||||
u';': u'%3B', u':': u'%3A', u']': u'%5D', u'[': u'%5B', u'?': u'%3F',
|
||||
u'!':u'%7E'}
|
||||
percentunQuoteDict = dict(((j,i) for (i,j) in percentQuoteDict.items()))
|
||||
+xmlUnEscapeDict = { u'<' : u'<', u'>' : u'>', u'&' : u'&' }
|
||||
netscapeHeader= """# HTTP Cookie File
|
||||
# http://www.netscape.com/newsref/std/cookie_spec.html
|
||||
# This is a generated file! Do not edit.\n\n"""
|
||||
@@ -327,16 +328,15 @@ def unicodeC( s ):
|
||||
raise UnicodeEncodeError(u'could not encode %s to unicode' % s)
|
||||
return s
|
||||
|
||||
-def xmlUnEscape( sStr, percent=0, pd=percentunQuoteDict ):
|
||||
+def xmlUnEscape( sStr, percent=0, pd=percentunQuoteDict, xd=xmlUnEscapeDict ):
|
||||
u"""xml unescape a string, by default also checking for percent encoded
|
||||
characters. set percent=0 to ignore percent encoding.
|
||||
can specify your own percent quote dict
|
||||
(key, value) pairs are of (search, replace) ordering with percentunQuoteDict
|
||||
"""
|
||||
- sStr = sStr.replace("<", "<")
|
||||
- sStr = sStr.replace(">", ">")
|
||||
if percent: sStr = percentUnQuote( sStr, pd )
|
||||
- sStr = sStr.replace("&", "&")
|
||||
+ for search in xd:
|
||||
+ sStr = re.sub('(?i)' + re.escape(search), xd[search], sStr)
|
||||
return sStr
|
||||
|
||||
def percentIsQuoted(sStr, testCases=percentQuoteDict.values()):
|
|
@ -1,5 +0,0 @@
|
|||
A utility to automatically download enclosures and other objects
|
||||
linked to from various types of RSS feeds. Works well on podcasts,
|
||||
videocasts, and torrents.
|
||||
|
||||
WWW: http://code.google.com/p/rssdler/
|
|
@ -1,4 +0,0 @@
|
|||
bin/rssdler
|
||||
%%PYTHON_SITELIBDIR%%/rssdler.py
|
||||
%%PYTHON_SITELIBDIR%%/rssdler.pyc
|
||||
%%PYTHON_SITELIBDIR%%/rssdler.pyo
|
Loading…
Reference in a new issue