Fully support turning off sound support and make it the default on the

Alpha.
This commit is contained in:
Steve Price 1999-06-22 18:05:17 +00:00
parent 21d3259441
commit b67d334e96
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=19687
3 changed files with 42 additions and 7 deletions

View file

@ -3,7 +3,7 @@
# Date created: 27 August 1995
# Whom: asami
#
# $Id: Makefile,v 1.9 1998/09/15 11:13:13 asami Exp $
# $Id: Makefile,v 1.10 1998/09/17 00:32:37 asami Exp $
#
DISTNAME= xgalaga-2.0
@ -15,6 +15,10 @@ MAINTAINER= ports@FreeBSD.ORG
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
.if ${MACHINE_ARCH} == "alpha"
NOSOUND= yes
.endif
HAS_CONFIGURE= yes
USE_X_PREFIX= yes
# xgalaga has a very strange usage of these variables...
@ -23,8 +27,8 @@ CONFIGURE_ARGS= --prefix=${X11BASE}/lib/X11/xgalaga \
.if defined(NOSOUND)
CONFIGURE_ARGS+= --without-sound
.endif
PLIST= ${PKGDIR}/PLIST.nosound
.else
pre-configure:
@${ECHO} "*****************************************************"
@${ECHO} "* Note that you can build a version of xgalaga that *"
@ -34,5 +38,6 @@ pre-configure:
@${ECHO} "* Try it if you don't have a sound card and are *"
@${ECHO} "* getting core dumps. *"
@${ECHO} "*****************************************************"
.endif
.include <bsd.port.mk>

View file

@ -1,6 +1,6 @@
--- Makefile.in.orig Sun Apr 12 10:10:46 1998
+++ Makefile.in Thu May 28 09:41:05 1998
@@ -43,11 +43,12 @@
--- Makefile.in.orig Sun Apr 12 03:10:46 1998
+++ Makefile.in Sun Jun 20 18:59:18 1999
@@ -43,11 +43,14 @@
$(CC) $(LDFLAGS) -o $(SOUNDSRV) $(SOUNDOBJS) $(SOUNDLIBS)
install: all
@ -8,9 +8,12 @@
+ ./mkinstalldirs $(bindir)
+ ./mkinstalldirs $(prefix)
$(INSTALL) $(TARGET) $(bindir)/$(TARGET)
$(INSTALL) $(SOUNDSRV) $(prefix)/$(SOUNDSRV)
- $(INSTALL) $(SOUNDSRV) $(prefix)/$(SOUNDSRV)
- mkinstalldirs $(prefix)/sounds
- mkinstalldirs $(prefix)/levels
+ if [ "X$(SOUNDSRV)" != "X"]; then \
+ $(INSTALL) $(SOUNDSRV) $(prefix)/$(SOUNDSRV); \
+ fi
+ ./mkinstalldirs $(prefix)/sounds
+ ./mkinstalldirs $(prefix)/levels
for i in levels/*.xgl; do $(INSTALL) $$i $(prefix)/$$i ; done

View file

@ -0,0 +1,27 @@
bin/xgalaga
lib/X11/xgalaga/sounds/ddloo.raw
lib/X11/xgalaga/sounds/explode.raw
lib/X11/xgalaga/sounds/explode_big.raw
lib/X11/xgalaga/sounds/firetorp.raw
lib/X11/xgalaga/sounds/shield.raw
lib/X11/xgalaga/sounds/smart.raw
lib/X11/xgalaga/sounds/torphit.raw
lib/X11/xgalaga/sounds/warp.raw
lib/X11/xgalaga/levels/level1.xgl
lib/X11/xgalaga/levels/level2.xgl
lib/X11/xgalaga/levels/level3.xgl
lib/X11/xgalaga/levels/level4.xgl
lib/X11/xgalaga/levels/level5.xgl
lib/X11/xgalaga/levels/level6.xgl
lib/X11/xgalaga/levels/level7.xgl
lib/X11/xgalaga/levels/level8.xgl
lib/X11/xgalaga/levels/level9.xgl
lib/X11/xgalaga/levels/level10.xgl
lib/X11/xgalaga/levels/level11.xgl
lib/X11/xgalaga/levels/level12.xgl
lib/X11/xgalaga/levels/level13.xgl
lib/X11/xgalaga/levels/level14.xgl
lib/X11/xgalaga/levels/level15.xgl
@dirrm lib/X11/xgalaga/levels
@dirrm lib/X11/xgalaga/sounds
@dirrm lib/X11/xgalaga