Remove wu-ftpd+ipv6. The upstream disapear and distfile is no more available.
This commit is contained in:
parent
ef5b0fc23b
commit
b7086c4b42
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=298664
23 changed files with 0 additions and 582 deletions
|
@ -110,7 +110,6 @@
|
|||
SUBDIR += wget
|
||||
SUBDIR += wmget
|
||||
SUBDIR += wput
|
||||
SUBDIR += wu-ftpd+ipv6
|
||||
SUBDIR += wxdfast
|
||||
SUBDIR += wzdftpd
|
||||
SUBDIR += yafc
|
||||
|
|
|
@ -1,53 +0,0 @@
|
|||
# New ports collection makefile for: wu-ftpd+ipv6
|
||||
# Date created: 30 Aug 2002
|
||||
# Whom: sumikawa
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
# REMINDER: to use ftpaccess(5) you need to specify -a in command line,
|
||||
# it is changed from previous versions
|
||||
|
||||
PORTNAME= wu-ftpd+ipv6
|
||||
PORTVERSION= 2.6.2
|
||||
PORTREVISION= 8
|
||||
CATEGORIES= ftp ipv6
|
||||
MASTER_SITES= ftp://ftp.wu-ftpd.org/pub/wu-ftpd/
|
||||
DISTNAME= wu-ftpd-${PORTVERSION}
|
||||
|
||||
PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/
|
||||
PATCHFILES= wu-ftpd-262-v6-20040130.diff.gz
|
||||
PATCH_DIST_STRIP= -p1
|
||||
|
||||
MAINTAINER= sumikawa@FreeBSD.org
|
||||
COMMENT= A replacement ftp server for Un*x systems
|
||||
|
||||
CONFLICTS= wu-ftpd-[0-9]* heimdal-[0-9]*
|
||||
|
||||
USE_AUTOTOOLS= autoconf213
|
||||
CONFIGURE_ARGS= --enable-rfc931 --disable-pasvip \
|
||||
--enable-noop --disable-numericuid --enable-nlst-dirs \
|
||||
--enable-ipv6 \
|
||||
--prefix=${PREFIX} --with-etc-dir=${PREFIX}/etc
|
||||
|
||||
.if !defined(WITH_PAM)
|
||||
CONFIGURE_ARGS+= --enable-opie
|
||||
.else
|
||||
CONFIGURE_ARGS+= --enable-pam
|
||||
EXTRA_PATCHES+= ${FILESDIR}/ftpd.c-pam
|
||||
.endif
|
||||
|
||||
MAKE_ENV+= WARNINGS=-DSPT_TYPE=SPT_BUILTIN
|
||||
|
||||
MAN1= ftpcount.1 ftpwho.1
|
||||
MAN5= ftpaccess.5 ftphosts.5 ftpconversions.5 xferlog.5 \
|
||||
ftpservers.5
|
||||
MAN8= ftpd.8 ftpshut.8 ftprestart.8 privatepw.8
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 900007
|
||||
post-patch:
|
||||
${CP} ${FILESDIR}/logwtmp.c ${WRKSRC}/src
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,4 +0,0 @@
|
|||
SHA256 (wu-ftpd-2.6.2.tar.gz) = 1fc659c963410df5d1a4fa229fc5325f08a2f0136d805afa638127a0882158b8
|
||||
SIZE (wu-ftpd-2.6.2.tar.gz) = 354784
|
||||
SHA256 (wu-ftpd-262-v6-20040130.diff.gz) = c3390c90df8d3fc4f14a1448f1bfd310409501685711c852446b9dbf494406ce
|
||||
SIZE (wu-ftpd-262-v6-20040130.diff.gz) = 60745
|
|
@ -1,10 +0,0 @@
|
|||
--- src/ftpd.c.orig Fri Nov 30 01:56:11 2001
|
||||
+++ src/ftpd.c Wed May 24 16:21:21 2006
|
||||
@@ -7633,6 +7633,7 @@
|
||||
*/
|
||||
|
||||
#include <security/pam_appl.h>
|
||||
+#define PAM_ESTABLISH_CRED 0x1
|
||||
/* Static variables used to communicate between the conversation function
|
||||
* and the server_login function
|
||||
*/
|
|
@ -1,24 +0,0 @@
|
|||
#include "config.h"
|
||||
#include "proto.h"
|
||||
|
||||
#include <utmpx.h>
|
||||
|
||||
void
|
||||
wu_logwtmp(char *line, char *name, char *host, int login)
|
||||
{
|
||||
struct utmpx utx;
|
||||
|
||||
memset(&utx, 0, sizeof(utx));
|
||||
utx.ut_pid = getpid();
|
||||
snprintf(utx.ut_id, sizeof utx.ut_id, "%xftp", utx.ut_pid);
|
||||
gettimeofday(&utx.ut_tv, NULL);
|
||||
if (login) {
|
||||
utx.ut_type = USER_PROCESS;
|
||||
strncpy(utx.ut_user, name, sizeof(utx.ut_user));
|
||||
strncpy(utx.ut_host, host, sizeof(utx.ut_host));
|
||||
strncpy(utx.ut_line, line, sizeof(utx.ut_line));
|
||||
} else {
|
||||
utx.ut_type = DEAD_PROCESS;
|
||||
}
|
||||
pututxline(&utx);
|
||||
}
|
|
@ -1,116 +0,0 @@
|
|||
--- src/ftpd.c.orig Tue Apr 5 03:22:01 2005
|
||||
+++ src/ftpd.c Tue Apr 5 04:10:13 2005
|
||||
@@ -447,7 +447,6 @@
|
||||
#ifdef OPIE
|
||||
#include <opie.h>
|
||||
int pwok = 0;
|
||||
-int af_pwok = 0;
|
||||
struct opie opiestate;
|
||||
#endif
|
||||
|
||||
@@ -1219,10 +1218,6 @@
|
||||
exit(0);
|
||||
}
|
||||
|
||||
-#ifdef OPIE
|
||||
- af_pwok = opieaccessfile(remotehost);
|
||||
-#endif
|
||||
-
|
||||
#ifdef HAVE_LIBRESOLV
|
||||
/* check permitted access based on remote host DNS information */
|
||||
if (!check_reverse_dns()) {
|
||||
@@ -1662,9 +1657,9 @@
|
||||
/* Display s/key challenge where appropriate. */
|
||||
|
||||
if (pwd == NULL || skeychallenge(&skey, pwd->pw_name, sbuf))
|
||||
- sprintf(buf, "Password required for %s.", name);
|
||||
+ snprintf(buf, sizeof(buf)-1, "Password required for %s.", name);
|
||||
else
|
||||
- sprintf(buf, "%s %s for %s.", sbuf,
|
||||
+ snprintf(buf, sizeof(buf)-1, "%s %s for %s.", sbuf,
|
||||
pwok ? "allowed" : "required", name);
|
||||
return (buf);
|
||||
}
|
||||
@@ -2105,16 +2100,17 @@
|
||||
#ifdef OPIE
|
||||
{
|
||||
char prompt[OPIE_CHALLENGE_MAX + 1];
|
||||
- opiechallenge(&opiestate, name, prompt);
|
||||
|
||||
- if (askpasswd == -1) {
|
||||
- syslog(LOG_WARNING, "Invalid FTP user name %s attempted from %s", name, remotehost);
|
||||
- pwok = 0;
|
||||
+ if (opiechallenge(&opiestate, name, prompt) == 0) {
|
||||
+ pwok = (pw != NULL) &&
|
||||
+ opieaccessfile(remotehost) &&
|
||||
+ opiealways(pw->pw_dir);
|
||||
+ reply(331, "Response to %s %s for %s.",
|
||||
+ prompt, pwok ? "requested" : "required", name);
|
||||
+ } else {
|
||||
+ pwok = 1;
|
||||
+ reply(331, "Password required for %s.", name);
|
||||
}
|
||||
- else
|
||||
- pwok = af_pwok && opiealways(pw->pw_dir);
|
||||
- reply(331, "Response to %s %s for %s.",
|
||||
- prompt, pwok ? "requested" : "required", name);
|
||||
}
|
||||
#else
|
||||
reply(331, "Password required for %s.", name);
|
||||
@@ -2593,8 +2589,8 @@
|
||||
if (pw == NULL)
|
||||
salt = "xx";
|
||||
else
|
||||
-#ifndef OPIE
|
||||
salt = pw->pw_passwd;
|
||||
+#ifndef OPIE
|
||||
#ifdef SECUREOSF
|
||||
if ((pr = getprpwnam(pw->pw_name)) != NULL) {
|
||||
if (pr->uflg.fg_newcrypt)
|
||||
@@ -2627,9 +2623,15 @@
|
||||
xpasswd = crypt(passwd, salt);
|
||||
#endif /* SKEY */
|
||||
#else /* OPIE */
|
||||
- if (!opieverify(&opiestate, passwd))
|
||||
- rval = 0;
|
||||
- xpasswd = crypt(passwd, pw->pw_passwd);
|
||||
+ if (pw != NULL) {
|
||||
+ if (opieverify(&opiestate, passwd) == 0)
|
||||
+ xpasswd = pw->pw_passwd;
|
||||
+ else if (pwok)
|
||||
+ xpasswd = crypt(passwd, salt);
|
||||
+ else
|
||||
+ pw = NULL;
|
||||
+ }
|
||||
+ pwok = 0;
|
||||
#endif /* OPIE */
|
||||
#ifdef ULTRIX_AUTH
|
||||
if ((numfails = ultrix_check_pass(passwd, xpasswd)) >= 0) {
|
||||
@@ -3189,7 +3191,7 @@
|
||||
pw->pw_name, pw->pw_dir);
|
||||
goto bad;
|
||||
#else
|
||||
- if (chdir("/") < 0) {
|
||||
+ if (restricted_user || chdir("/") < 0) {
|
||||
#ifdef VERBOSE_ERROR_LOGING
|
||||
syslog(LOG_NOTICE, "FTP LOGIN FAILED (cannot chdir) for %s, %s",
|
||||
remoteident, pw->pw_name);
|
||||
@@ -7469,6 +7471,8 @@
|
||||
in++;
|
||||
if (*in == '/')
|
||||
in++;
|
||||
+ else
|
||||
+ out++;
|
||||
}
|
||||
else if ((in[0] == '.') && (in[1] == '.') && ((in[2] == '/') || (in[2] == '\0'))) {
|
||||
if (out == path) {
|
||||
@@ -7497,6 +7501,9 @@
|
||||
}
|
||||
else {
|
||||
do
|
||||
+ if ((in[0] == '*') && (in[1] == '*'))
|
||||
+ in++;
|
||||
+ else
|
||||
*out++ = *in++;
|
||||
while ((*in != '\0') && (*in != '/'));
|
||||
if (*in == '/')
|
|
@ -1,81 +0,0 @@
|
|||
--- makefiles/Makefile.fbs.orig Sun Jul 2 00:56:26 2000
|
||||
+++ makefiles/Makefile.fbs Tue Sep 4 10:34:51 2001
|
||||
@@ -24,19 +24,21 @@
|
||||
#
|
||||
|
||||
DESTDIR=
|
||||
-PREFIX= /usr/local
|
||||
+PREFIX?= /usr/local
|
||||
+
|
||||
+ETCDIR= ${DESTDIR}${PREFIX}/etc
|
||||
|
||||
BINDIR= ${DESTDIR}${PREFIX}/bin
|
||||
-BINOWN= bin
|
||||
-BINGRP= bin
|
||||
+BINOWN= root
|
||||
+BINGRP= wheel
|
||||
|
||||
SBINDIR= ${DESTDIR}${PREFIX}/libexec
|
||||
-SBINOWN= bin
|
||||
-SBINGRP= bin
|
||||
+SBINOWN= root
|
||||
+SBINGRP= wheel
|
||||
|
||||
MANDIR= ${DESTDIR}${PREFIX}/man
|
||||
-MANOWN= bin
|
||||
-MANGRP= bin
|
||||
+MANOWN= root
|
||||
+MANGRP= wheel
|
||||
|
||||
INSTALL= install
|
||||
|
||||
@@ -52,14 +54,20 @@
|
||||
@if [ ! -e ${SBINDIR} ]; then \
|
||||
${INSTALL} -o ${SBINOWN} -g ${SBINGRP} -m 755 -d ${SBINDIR} ; \
|
||||
fi
|
||||
- ${INSTALL} -c -o ${SBINOWN} -g ${SBINGRP} -m 110 bin/ftpd ${SBINDIR}/in.ftpd
|
||||
- @( cd ${SBINDIR} ; ln -s -f in.ftpd wu.ftpd ; chown ${SBINOWN}.${SBINGRP} wu.ftpd )
|
||||
- @( cd ${SBINDIR} ; ln -s -f in.ftpd in.wuftpd ; chown ${SBINOWN}.${SBINGRP} in.wuftpd )
|
||||
+ ${INSTALL} -c -o ${SBINOWN} -g ${SBINGRP} -m 110 bin/ftpd ${SBINDIR}/ftpd
|
||||
+# ${INSTALL} -c -o ${SBINOWN} -g ${SBINGRP} -m 110 bin/ftpd ${SBINDIR}/in.ftpd
|
||||
+# @( cd ${SBINDIR} ; ln -s -f in.ftpd wu.ftpd ; chown ${SBINOWN}.${SBINGRP} wu.ftpd )
|
||||
+# @( cd ${SBINDIR} ; ln -s -f in.ftpd in.wuftpd ; chown ${SBINOWN}.${SBINGRP} in.wuftpd )
|
||||
${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 111 bin/ftpshut ${BINDIR}/ftpshut
|
||||
${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 111 bin/ftprestart ${BINDIR}/ftprestart
|
||||
${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 111 bin/ftpcount ${BINDIR}/ftpcount
|
||||
${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 111 bin/ftpwho ${BINDIR}/ftpwho
|
||||
${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 111 bin/privatepw ${BINDIR}/privatepw
|
||||
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 644 doc/examples/ftpaccess ${ETCDIR}/ftpaccess.example
|
||||
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 644 doc/examples/ftpusers ${ETCDIR}/ftpusers.example
|
||||
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 644 doc/examples/ftpconversions ${ETCDIR}/ftpconversions.example
|
||||
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 644 doc/examples/ftphosts ${ETCDIR}/ftphosts.example
|
||||
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 644 doc/examples/ftpgroups ${ETCDIR}/ftpgroups.example
|
||||
@echo installing manpages.
|
||||
@if [ ! -e ${MANDIR}/man1 ]; then \
|
||||
${INSTALL} -o ${MANOWN} -g ${MANGRP} -m 755 -d ${MANDIR}/man1 ; \
|
||||
@@ -80,14 +88,14 @@
|
||||
${INSTALL} -c -o ${MANOWN} -g ${MANGRP} -m 444 doc/ftpshut.8 ${MANDIR}/man8/ftpshut.8
|
||||
${INSTALL} -c -o ${MANOWN} -g ${MANGRP} -m 444 doc/ftprestart.8 ${MANDIR}/man8/ftprestart.8
|
||||
${INSTALL} -c -o ${MANOWN} -g ${MANGRP} -m 444 util/privatepw/privatepw.8 ${MANDIR}/man8/privatepw.8
|
||||
- @echo Compressing manpages
|
||||
- gzip -f -9 ${MANDIR}/man1/ftpcount.1
|
||||
- gzip -f -9 ${MANDIR}/man1/ftpwho.1
|
||||
- gzip -f -9 ${MANDIR}/man5/ftpaccess.5
|
||||
- gzip -f -9 ${MANDIR}/man5/ftpconversions.5
|
||||
- gzip -f -9 ${MANDIR}/man5/ftphosts.5
|
||||
- gzip -f -9 ${MANDIR}/man5/xferlog.5
|
||||
- gzip -f -9 ${MANDIR}/man8/ftpd.8
|
||||
- gzip -f -9 ${MANDIR}/man8/ftpshut.8
|
||||
- gzip -f -9 ${MANDIR}/man8/ftprestart.8
|
||||
- gzip -f -9 ${MANDIR}/man8/privatepw.8
|
||||
+# @echo Compressing manpages
|
||||
+# gzip -f -9 ${MANDIR}/man1/ftpcount.1
|
||||
+# gzip -f -9 ${MANDIR}/man1/ftpwho.1
|
||||
+# gzip -f -9 ${MANDIR}/man5/ftpaccess.5
|
||||
+# gzip -f -9 ${MANDIR}/man5/ftpconversions.5
|
||||
+# gzip -f -9 ${MANDIR}/man5/ftphosts.5
|
||||
+# gzip -f -9 ${MANDIR}/man5/xferlog.5
|
||||
+# gzip -f -9 ${MANDIR}/man8/ftpd.8
|
||||
+# gzip -f -9 ${MANDIR}/man8/ftpshut.8
|
||||
+# gzip -f -9 ${MANDIR}/man8/ftprestart.8
|
||||
+# gzip -f -9 ${MANDIR}/man8/privatepw.8
|
|
@ -1,11 +0,0 @@
|
|||
--- src/Makefile.in.orig Sat Jul 1 22:04:21 2000
|
||||
+++ src/Makefile.in Sun Dec 22 21:01:41 2002
|
||||
@@ -34,7 +34,7 @@
|
||||
|
||||
CFLAGS=$(WARNINGS) @CFLAGS@
|
||||
LDFLAGS=@LDFLAGS@
|
||||
-YACC=@YACC@
|
||||
+YACC=byacc
|
||||
LIBS=@LIBS@
|
||||
|
||||
UTIL_SRC = COPYRIGHT.c vers.c
|
|
@ -1,20 +0,0 @@
|
|||
--- doc/xferlog.5.orig Thu Jan 9 22:29:03 1997
|
||||
+++ doc/xferlog.5 Mon Feb 16 23:34:15 1998
|
||||
@@ -7,7 +7,7 @@
|
||||
.B xferlog
|
||||
file contains logging information from the FTP server daemon,
|
||||
.BR ftpd (8).
|
||||
-This file usually is found in /usr/adm, but can be located anywhere by using a
|
||||
+This file usually is found in /var/log, but can be located anywhere by using a
|
||||
option to
|
||||
.BR ftpd (8).
|
||||
Each server entry is composed of a single line of the following form,
|
||||
@@ -135,7 +135,7 @@
|
||||
.SH FILES
|
||||
.PD 0
|
||||
.TP 20
|
||||
-.B /usr/adm/xferlog
|
||||
+.B /var/log/xferlog
|
||||
.SH "SEE ALSO"
|
||||
.BR ftpd(8),
|
||||
.BR ftpaccess(5)
|
|
@ -1,13 +0,0 @@
|
|||
--- src/config/config.fbs.bak Sat Jul 1 22:03:07 2000
|
||||
+++ src/config/config.fbs Sun Jul 29 23:37:56 2001
|
||||
@@ -79,10 +79,6 @@
|
||||
typedef void SIGNAL_TYPE;
|
||||
|
||||
#include "../config.h"
|
||||
-/* SKEY should always be defined on FreeBSD */
|
||||
-#ifndef SKEY
|
||||
-#define SKEY
|
||||
-#endif
|
||||
#ifdef SKEY
|
||||
#define SKEY_NAME
|
||||
#endif
|
|
@ -1,29 +0,0 @@
|
|||
--- support/strcasestr.c.orig Sat Jul 1 22:36:29 2000
|
||||
+++ support/strcasestr.c Wed Oct 10 07:18:17 2001
|
||||
@@ -24,22 +24,24 @@
|
||||
$Id: strcasestr.c,v 1.5 2000/07/01 18:36:29 wuftpd Exp $
|
||||
|
||||
****************************************************************************/
|
||||
+#include <ctype.h>
|
||||
#include <string.h>
|
||||
/*
|
||||
* Find the first occurrence of find in s.
|
||||
*/
|
||||
-char *strcasestr(register char *s, register char *find)
|
||||
+char *strcasestr(const char *s, const char *find)
|
||||
{
|
||||
register char c, sc;
|
||||
register size_t len;
|
||||
|
||||
if ((c = *find++) != 0) {
|
||||
+ c = tolower((unsigned char)c);
|
||||
len = strlen(find);
|
||||
do {
|
||||
do {
|
||||
if ((sc = *s++) == 0)
|
||||
return (NULL);
|
||||
- } while (sc != c);
|
||||
+ } while ((char)tolower((unsigned char)sc) != c);
|
||||
} while (strncasecmp(s, find, len) != 0);
|
||||
s--;
|
||||
}
|
|
@ -1,21 +0,0 @@
|
|||
--- doc/examples/ftpconversions.orig Thu Mar 4 07:39:21 1999
|
||||
+++ doc/examples/ftpconversions Tue Sep 23 17:27:47 2003
|
||||
@@ -1,9 +1,9 @@
|
||||
- :.Z: : :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
|
||||
- : : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
|
||||
- :.gz: : :/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
|
||||
- : : :.gz:/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
|
||||
- : : :.tar:/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
|
||||
- : : :.tar.Z:/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
|
||||
- : : :.tar.gz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP
|
||||
- : : :.crc:/bin/cksum %s:T_REG::CKSUM
|
||||
- : : :.md5:/bin/md5sum %s:T_REG::MD5SUM
|
||||
+ :.Z: : :/usr/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
|
||||
+ : : :.Z:/usr/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
|
||||
+ :.gz: : :/usr/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
|
||||
+ : : :.gz:/usr/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
|
||||
+ : : :.tar:/usr/bin/tar -c -f - -- %s:T_REG|T_DIR:O_TAR:TAR
|
||||
+ : : :.tar.Z:/usr/bin/tar -c -Z -f - -- %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
|
||||
+ : : :.tar.gz:/usr/bin/tar -c -z -f - -- %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP
|
||||
+ : : :.crc:/usr/bin/cksum %s:T_REG::CKSUM
|
||||
+ : : :.md5:/sbin/md5 %s:T_REG::MD5SUM
|
|
@ -1,31 +0,0 @@
|
|||
*** doc/examples/ftpusers.orig Tue Aug 8 19:30:46 1995
|
||||
--- doc/examples/ftpusers Tue Aug 8 19:33:46 1995
|
||||
***************
|
||||
*** 1,14 ****
|
||||
root
|
||||
! bin
|
||||
! boot
|
||||
daemon
|
||||
- digital
|
||||
- field
|
||||
- gateway
|
||||
- guest
|
||||
- nobody
|
||||
operator
|
||||
! ris
|
||||
! sccs
|
||||
! sys
|
||||
uucp
|
||||
--- 1,12 ----
|
||||
root
|
||||
! toor
|
||||
daemon
|
||||
operator
|
||||
! bin
|
||||
! games
|
||||
! news
|
||||
! man
|
||||
uucp
|
||||
+ xten
|
||||
+ ingres
|
||||
+ nobody
|
|
@ -1,8 +0,0 @@
|
|||
--- src/proto.h.bak Sat Jul 1 22:17:39 2000
|
||||
+++ src/proto.h Wed Oct 10 07:15:39 2001
|
||||
@@ -292,4 +292,4 @@
|
||||
/*
|
||||
** support/strcasestr.c
|
||||
*/
|
||||
-char *strcasestr(register char *s, register char *find);
|
||||
+char *strcasestr(const char *s, const char *find);
|
|
@ -1,20 +0,0 @@
|
|||
--- support/makefiles/Makefile.fbs.orig Sat Jul 1 22:22:55 2000
|
||||
+++ support/makefiles/Makefile.fbs Wed Oct 10 07:11:36 2001
|
||||
@@ -33,7 +33,14 @@
|
||||
LIBC = /usr/lib/libc.a
|
||||
IFLAGS =
|
||||
LFLAGS =
|
||||
-CFLAGS = -O ${IFLAGS} ${LFLAGS}
|
||||
+CFLAGS += ${IFLAGS} ${LFLAGS}
|
||||
|
||||
-SRCS = strcasestr.c authuser.c ftw.c
|
||||
-OBJS = strcasestr.o authuser.o ftw.o
|
||||
+SRCS = authuser.c ftw.c
|
||||
+OBJS = authuser.o ftw.o
|
||||
+
|
||||
+HAVE_STRSTR!= (nm ${LIBC} | grep -q strcasestr) || echo "NO"
|
||||
+
|
||||
+.if ${HAVE_STRSTR} == "NO"
|
||||
+SRCS += strcasestr.c
|
||||
+OBJS += strcasestr.o
|
||||
+.endif
|
|
@ -1,14 +0,0 @@
|
|||
--- src/makefiles/Makefile.fbs.orig Sat Jul 1 22:57:50 2000
|
||||
+++ src/makefiles/Makefile.fbs Sun Jul 29 23:33:47 2001
|
||||
@@ -30,9 +30,9 @@
|
||||
#CC = cc
|
||||
IFLAGS = -I.. -I../support
|
||||
LFLAGS = -L../support -s
|
||||
-CFLAGS = -O ${IFLAGS} ${LFLAGS} -DNO_CRYPT_PROTO
|
||||
+CFLAGS += ${IFLAGS} ${LFLAGS} -DNO_CRYPT_PROTO
|
||||
XOBJS =
|
||||
-LIBES = -lsupport -lutil -lskey -lmd -lcrypt
|
||||
+LIBES = -lsupport -lutil -lopie -lmd -lcrypt
|
||||
LIBC = /usr/lib/libc.a
|
||||
LINTFLAGS=
|
||||
LKERB = -lauth -lckrb -lkrb -ldes
|
|
@ -1,14 +0,0 @@
|
|||
--- src/makefiles/common.orig Sun Oct 3 21:51:35 1999
|
||||
+++ src/makefiles/common Wed Oct 20 20:35:25 1999
|
||||
@@ -48,7 +48,11 @@
|
||||
${CC} ${LFLAGS} -o $@ ${UTIL_OBJS} ftprestart.o rdservers.o ${XLIBS}
|
||||
|
||||
ftpd: ${OBJS} ${XOBJS} ../support/libsupport.a
|
||||
+.if defined(PACKAGE_BUILDING)
|
||||
${CC} ${LFLAGS} -o $@ ${OBJS} ${XOBJS} ${XLIBS}
|
||||
+.else
|
||||
+ ${CC} -static ${LFLAGS} -o $@ ${OBJS} ${XOBJS} ${XLIBS}
|
||||
+.endif
|
||||
|
||||
ckconfig: ${UTIL_OBJS} ckconfig.o rdservers.o
|
||||
${CC} ${LFLAGS} -o $@ ${UTIL_OBJS} ckconfig.o rdservers.o ${XLIBS}
|
|
@ -1,34 +0,0 @@
|
|||
--- src/glob.c.old Thu Nov 29 20:01:38 2001
|
||||
+++ src/glob.c Thu Jun 10 06:13:51 2004
|
||||
@@ -45,10 +45,12 @@
|
||||
|
||||
#include "proto.h"
|
||||
|
||||
+#define ARGSIZ (524288)
|
||||
+
|
||||
#define QUOTE 0200
|
||||
#define TRIM 0177
|
||||
#define eq(a,b) (strcmp(a, b)==0)
|
||||
-#define GAVSIZ (NCARGS/6)
|
||||
+#define GAVSIZ (ARGSIZ/6)
|
||||
#define isdir(d) ((d.st_mode & S_IFMT) == S_IFDIR)
|
||||
|
||||
static char **gargv; /* Pointer to the (stack) arglist */
|
||||
@@ -112,7 +114,7 @@
|
||||
|
||||
fixpath(v);
|
||||
if (v[0] == '\0')
|
||||
- v = "*";
|
||||
+ v = ".";
|
||||
else if ((strlen(v) > 1) && (v[strlen(v) - 1] == '/'))
|
||||
v[strlen(v) - 1] = '\0';
|
||||
|
||||
@@ -149,7 +151,7 @@
|
||||
gargv = agargv;
|
||||
sortbas = agargv;
|
||||
gargc = 0;
|
||||
- gnleft = NCARGS - 4;
|
||||
+ gnleft = ARGSIZ - 4;
|
||||
}
|
||||
|
||||
static void collect(register char *as)
|
|
@ -1,22 +0,0 @@
|
|||
--- Makefile.in.orig Tue Feb 5 23:02:47 2002
|
||||
+++ Makefile.in Tue Feb 5 22:57:32 2002
|
||||
@@ -67,7 +67,7 @@
|
||||
-@mkdir -p $(DESTDIR)/$(mandir)/man1
|
||||
-@mkdir -p $(DESTDIR)/$(mandir)/man5
|
||||
-@mkdir -p $(DESTDIR)/@ETCDIR@
|
||||
- @INSTALL_PROGRAM@ -o bin -g bin -m 755 bin/ftpd $(DESTDIR)/@sbindir@/in.ftpd
|
||||
+ @INSTALL_PROGRAM@ -o bin -g bin -m 755 bin/ftpd $(DESTDIR)/@libexecdir@/ftpd
|
||||
@INSTALL_PROGRAM@ -o bin -g bin -m 755 bin/ftpshut $(DESTDIR)/@sbindir@/ftpshut
|
||||
@INSTALL_PROGRAM@ -o bin -g bin -m 755 bin/ftpcount $(DESTDIR)/@bindir@/ftpcount
|
||||
@INSTALL_PROGRAM@ -o bin -g bin -m 755 bin/ftpwho $(DESTDIR)/@bindir@/ftpwho
|
||||
@@ -87,5 +87,8 @@
|
||||
@INSTALL_DATA@ -o bin -g bin -m 644 doc/xferlog.5 $(DESTDIR)/$(mandir)/man5/xferlog.5
|
||||
@INSTALL_DATA@ -o bin -g bin -m 644 doc/ftprestart.8 $(DESTDIR)/$(mandir)/man8/ftprestart.8
|
||||
@INSTALL_DATA@ -o bin -g bin -m 644 util/privatepw/privatepw.8 $(DESTDIR)/$(mandir)/man8/privatepw.8
|
||||
- @if test ! -f $(DESTDIR)/@ETCDIR@/ftpaccess; then echo "Since you didn't have a ftpaccess file, the sample has been"; echo "installed to $(DESTDIR)/@ETCDIR@/ftpaccess."; echo "You will probably want to edit it."; @INSTALL@ -c -o bin -g bin -m 644 doc/examples/ftpaccess $(DESTDIR)/@ETCDIR@/ftpaccess; fi
|
||||
- @if test ! -f $(DESTDIR)/@ETCDIR@/ftpconversions; then echo "Since you didn't have a ftpconversions file, the sample has been"; echo "installed to $(DESTDIR)/@ETCDIR@/ftpconversions."; echo "You will probably want to edit it."; @INSTALL@ -c -o bin -g bin -m 644 doc/examples/ftpconversions $(DESTDIR)/@ETCDIR@/ftpconversions; fi
|
||||
+ @INSTALL@ -c -o bin -g bin -m 644 doc/examples/ftpaccess $(DESTDIR)/@ETCDIR@/ftpaccess.example
|
||||
+ @INSTALL@ -c -o bin -g bin -m 644 doc/examples/ftpconversions $(DESTDIR)/@ETCDIR@/ftpconversions.example
|
||||
+ @INSTALL@ -c -o bin -g bin -m 644 doc/examples/ftpgroups $(DESTDIR)/@ETCDIR@/ftpgroups.example
|
||||
+ @INSTALL@ -c -o bin -g bin -m 644 doc/examples/ftphosts $(DESTDIR)/@ETCDIR@/ftphosts.example
|
||||
+ @INSTALL@ -c -o bin -g bin -m 644 doc/examples/ftpusers $(DESTDIR)/@ETCDIR@/ftpusers.example
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.in.orig Sat Jul 1 21:42:15 2000
|
||||
+++ configure.in Tue Feb 19 22:39:52 2002
|
||||
@@ -868,7 +870,7 @@
|
||||
fi
|
||||
if test $opie = yes; then
|
||||
AC_DEFINE(OPIE)
|
||||
- LIBS="$LIBS -lopie"
|
||||
+ LIBS="$LIBS -lopie -lmd"
|
||||
fi
|
||||
if test $newcd = yes; then
|
||||
AC_DEFINE(ALTERNATE_CD)
|
|
@ -1,11 +0,0 @@
|
|||
--- src/realpath.c.orig Mon Jul 28 16:18:15 2003
|
||||
+++ src/realpath.c Mon Jul 28 16:18:44 2003
|
||||
@@ -299,7 +299,7 @@
|
||||
rootd = 0;
|
||||
|
||||
if (*wbuf) {
|
||||
- if (strlen(resolved) + strlen(wbuf) + rootd + 1 > MAXPATHLEN) {
|
||||
+ if (strlen(resolved) + strlen(wbuf) + !rootd + 1 > MAXPATHLEN) {
|
||||
errno = ENAMETOOLONG;
|
||||
goto err1;
|
||||
}
|
|
@ -1,22 +0,0 @@
|
|||
The package is linked dynamic so that you will get the right crypt
|
||||
library. If you are serious about performance, you may want to recompile
|
||||
it by yourself (the port will link static by default).
|
||||
|
||||
wu-ftpd is a replacement ftp server for Un*x systems. Besides
|
||||
supporting the ftp protocol defined in RFC 959, it adds the following
|
||||
features: logging of transfers, logging of commands, on the fly compression
|
||||
and archiving, classification of users on type and location, per class limits,
|
||||
per directory upload permissions, restricted guest accounts, system wide
|
||||
and per directory messages, directory alias, cdpath, filename filter.
|
||||
|
||||
The configuration files are located in /usr/local/etc This package includes
|
||||
a basic working configuration. The config files are:
|
||||
|
||||
ftpaccess - controls who, what, and how many can access the server
|
||||
ftpconversions - controls the on-the-fly compression/archiving
|
||||
ftpusers - users who, for security reasons, may never use the server
|
||||
|
||||
You will also need to change /etc/inetd.conf to point to the new server
|
||||
located at /usr/local/libexec/ftpd
|
||||
|
||||
WWW: http://www.wu-ftpd.org/
|
|
@ -1,12 +0,0 @@
|
|||
bin/ftpcount
|
||||
bin/ftpwho
|
||||
sbin/ckconfig
|
||||
sbin/ftprestart
|
||||
sbin/ftpshut
|
||||
sbin/privatepw
|
||||
etc/ftpaccess.example
|
||||
etc/ftpconversions.example
|
||||
etc/ftpgroups.example
|
||||
etc/ftphosts.example
|
||||
etc/ftpusers.example
|
||||
libexec/ftpd
|
Loading…
Reference in a new issue