Add sweep - an audio editor for GNOME desktop.
This commit is contained in:
parent
3f53f13474
commit
b714ec93da
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33096
8 changed files with 102 additions and 0 deletions
|
@ -123,6 +123,7 @@
|
|||
SUBDIR += splay
|
||||
SUBDIR += splaytk
|
||||
SUBDIR += streamripper
|
||||
SUBDIR += sweep
|
||||
SUBDIR += tclmidi
|
||||
SUBDIR += teknap
|
||||
SUBDIR += timidity
|
||||
|
|
42
audio/sweep/Makefile
Normal file
42
audio/sweep/Makefile
Normal file
|
@ -0,0 +1,42 @@
|
|||
# New ports collection makefile for: sweep
|
||||
# Date created: 25 September 2000
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= sweep
|
||||
PORTVERSION= 0.0.9
|
||||
CATEGORIES= audio gnome
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= sobomax@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
|
||||
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
|
||||
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
|
||||
|
||||
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
|
||||
--datadir=${PREFIX}/share/gnome
|
||||
CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
|
||||
GTK_CONFIG="${GTK_CONFIG}" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
MAN1= sweep.1
|
||||
|
||||
pre-patch:
|
||||
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
|
||||
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
|
||||
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
|
||||
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
|
||||
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
|
||||
|
||||
.include <bsd.port.mk>
|
1
audio/sweep/distinfo
Normal file
1
audio/sweep/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (sweep-0.0.9.tar.gz) = 6d4baf157d31583b830d8bcb15cb9fe2
|
11
audio/sweep/files/patch-aa
Normal file
11
audio/sweep/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/file_ops.c 2000/09/25 09:15:46 1.1
|
||||
+++ src/file_ops.c 2000/09/25 09:15:49
|
||||
@@ -54,7 +54,7 @@
|
||||
if (!pathname) return NULL;
|
||||
|
||||
samplefile = afOpenFile(pathname, "r", NULL);
|
||||
- if (samplefile <= 0)
|
||||
+ if (samplefile == AF_NULL_FILEHANDLE)
|
||||
/* return (int) samplefile;*/
|
||||
return NULL;
|
||||
|
10
audio/sweep/files/patch-ab
Normal file
10
audio/sweep/files/patch-ab
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/driver.c 2000/09/25 09:09:58 1.1
|
||||
+++ src/driver.c 2000/09/25 09:10:23
|
||||
@@ -24,6 +24,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
#include <sys/time.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
1
audio/sweep/pkg-comment
Normal file
1
audio/sweep/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A sound editor for GNOME desktop
|
30
audio/sweep/pkg-descr
Normal file
30
audio/sweep/pkg-descr
Normal file
|
@ -0,0 +1,30 @@
|
|||
Sweep is an editor for sound samples. It operates on files of various formats
|
||||
such as .wav, .aiff and .au, and has multiple undo/redo levels and filters.
|
||||
|
||||
Sweep features:
|
||||
o Loading and saving of PCM encoded sound formats including AIFF, Sun/NeXT AU
|
||||
and WAV.
|
||||
o Multiple views of each sound: you can view different parts of the same sound
|
||||
in different windows simultaneously, with variable zooming in each view. You
|
||||
can view the entire sound at once, or zoom right down to the individual
|
||||
sample values.
|
||||
o Discontinuous selections: you can select regions of a sound with the mouse.
|
||||
By holding down the <Shift> key whilst selecting more regions, each region
|
||||
is added to the total selection. Also, selection boundaries can be moved,
|
||||
and selection regions merged, at any time.
|
||||
o Cut, copy and paste: conventional cut or copy selected regions of a sound,
|
||||
and paste into the same or other sounds.
|
||||
o Multiple undo and redo: all operations are reversible and can be re-applied.
|
||||
o Simple effects filters: normalisation (maximal amplification without
|
||||
degradation) and time reversing of selected regions.
|
||||
o Playback: playback of entire sound, or of selected regions only. Looped
|
||||
playback of entire sound or selected regions. Editing and effects are not
|
||||
disabled during playback, giving you instantaneous feedback of the result of
|
||||
each action.
|
||||
o Piano-style playback: the computer keyboard keys behave like musical keys
|
||||
for playback of instrument samples, so you can hear how the sample will
|
||||
sound when used in a sequencer or tracker.
|
||||
o Separate volume levels per view, which can be adjusted with the mouse wheel
|
||||
if available.
|
||||
|
||||
WWW: http://sweep.sourceforge.net/
|
6
audio/sweep/pkg-plist
Normal file
6
audio/sweep/pkg-plist
Normal file
|
@ -0,0 +1,6 @@
|
|||
bin/sweep
|
||||
share/gnome/apps/Multimedia/sweep.desktop
|
||||
share/gnome/pixmaps/sweep.png
|
||||
share/gnome/sweep/sweep_logo.ppm
|
||||
share/locale/fr/LC_MESSAGES/sweep.mo
|
||||
@dirrm share/gnome/sweep
|
Loading…
Reference in a new issue