- Fix build on 4.x

- Use PLIST_FILES

PR:		ports/82677
Submitted by:	Ports Fury
This commit is contained in:
Michael Johnson 2005-06-27 00:32:56 +00:00
parent 438330974d
commit b73af35551
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=138051
3 changed files with 29 additions and 78 deletions

View file

@ -7,7 +7,7 @@
PORTNAME= tomatoes
PORTVERSION= 1.5
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -17,27 +17,46 @@ DISTFILES= ${PORTNAME}-linux-src-${PORTVERSION}5${EXTRACT_SUFX} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Tomato-smashing, Q-Bert style
LIB_DEPENDS= mikmod:${PORTSDIR}/audio/libmikmod
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/tomatoes-${PORTVERSION}5
TDATA= ${WRKDIR}/tomatoes-${PORTVERSION}
USE_BZIP2= yes
USE_X_PREFIX= yes
MAKEFILE= makefile
USE_SDL= mixer image
USE_GL= yes
USE_GMAKE= yes
USE_SDL= mixer image sound
MAKEFILE= makefile
MAKE_ARGS= CC="${CXX}" \
MPKDIR="${DATADIR}/" \
MUSICDIR="${DATADIR}/music/" \
HISCOREDIR="${DATADIR}/" \
CONFIGDIR="${DATADIR}/" \
CFLAGS="${CXXFLAGS} ${SDL_CFLAGS}" \
LDFLAGS="${SDL_LDFLAGS}"
PLIST_FILES= bin/tomatoes \
%%DATADIR%%/config.cfg \
%%DATADIR%%/music/IHaveNoTomatoes.it \
%%DATADIR%%/tomatoes.mpk
PLIST_DIRS= %%DATADIR%%/music \
%%DATADIR%%
SDL_CFLAGS= `${SDL_CONFIG} --cflags` -I${X11BASE}/include
SDL_LDFLAGS= `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer \
-L${X11BASE}/lib -lGL -lGLU
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= Does not build on 4.X
.endif
.if ${ARCH} != "i386"
BROKEN= "Does not compile on !i386"
.endif
post-patch:
.for file in include/font.h
cd ${WRKSRC} && ${CP} ${file} ${file}.bak \
&& ${TR} -d '\r' < ${file}.bak > ${file}
.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${DATADIR}/music

View file

@ -1,62 +0,0 @@
--- makefile.orig Sat Nov 20 13:50:09 2004
+++ makefile Mon Feb 7 18:53:49 2005
@@ -4,7 +4,7 @@
.PHONY: all clean veryclean rebuild compress
-CC = g++
+CC ?= g++
COMPRESS = upx --best
TARGET = ./tomatoes
MARCH = pentium
@@ -14,18 +14,18 @@
# necessary. Remember to include the trailing /
# MPK directory (where 'tomatoes.mpk' is), default: ./
-MPKDIR = ./
+MPKDIR = ${PREFIX}/share/tomatoes/
# Music directory (where the music files are), default: ./music/
-MUSICDIR = ./music/
+MUSICDIR = ${PREFIX}/share/tomatoes/music/
# Hiscore directory (where the hiscores are written to), default: ./
# We need read/write access!
-HISCOREDIR = ./
+HISCOREDIR = ${PREFIX}/share/tomatoes/
# Config directory (where the 'config.cfg' is), default: ./
# We need read/write access!
-CONFIGDIR = ./
+CONFIGDIR = ${PREFIX}/share/tomatoes/
# Override directory (unused at the moment), default: ./data/
OVERRIDEDIR = ./data/
@@ -35,20 +35,20 @@
# SDL flags
-SDL_FLAGS = `sdl-config --cflags`
+SDL_FLAGS = `sdl11-config --cflags`
# Debugmode stuff
ifdef DEBUGMODE
-CFLAGS = -MMD -g3 -W -Wall -mcpu=$(MARCH) -DDEBUGMODE
-LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU
+CFLAGS += -MMD -g3 -W -Wall -mcpu=$(MARCH) -DDEBUGMODE
+LDFLAGS += `sdl11-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU
else
ifdef PROFILE
-CFLAGS = -MMD -g3 -O3 -march=$(MARCH) -Wall -pg
-LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -pg
+CFLAGS += -MMD -g3 -march=$(MARCH) -Wall -pg
+LDFLAGS += `sdl11-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -pg
else
-CFLAGS = -MMD -O3 -march=$(MARCH) -Wall $(SDL_FLAGS)
-LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -s
+CFLAGS += -MMD -march=$(MARCH) -Wall $(SDL_FLAGS) -I${X11BASE}/include
+LDFLAGS += `sdl11-config --libs` -L${X11BASE}/lib -lSDL_image -lSDL_mixer -lGL -lGLU -s -lSDL_sound
endif
endif

View file

@ -1,6 +0,0 @@
bin/tomatoes
share/tomatoes/config.cfg
share/tomatoes/music/IHaveNoTomatoes.it
share/tomatoes/tomatoes.mpk
@dirrm share/tomatoes/music
@dirrm share/tomatoes