Update to 2.10.0. Note: this release is API and ABI compatible with
2.6.x, so a repocopy to libgnomecanvasmm210 is not needed.
This commit is contained in:
parent
e57343ed7d
commit
b73f6367a7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=131002
3 changed files with 14 additions and 19 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libgnomecanvasmm
|
||||
PORTVERSION= 2.6.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.10.0
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
|
||||
|
@ -26,8 +25,8 @@ USE_X_PREFIX= yes
|
|||
USE_GMAKE= yes
|
||||
USE_GCC= 3.4
|
||||
USE_REINPLACE= yes
|
||||
USE_GNOME= gnomehack libgnomecanvas lthack
|
||||
USE_INC_LIBTOOL_VER=13
|
||||
USE_GNOME= gnomehack libgnomecanvas
|
||||
USE_INC_LIBTOOL_VER=15
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ARGS= --enable-static
|
||||
|
||||
|
@ -37,4 +36,13 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
patch-autotools:
|
||||
@(cd ${PATCH_WRKSRC}; \
|
||||
for file in ${LIBTOOLFILES}; do \
|
||||
${CP} $$file $$file.tmp; \
|
||||
${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
|
||||
$$file.tmp > $$file; \
|
||||
${RM} $$file.tmp; \
|
||||
done);
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (gnome2/libgnomecanvasmm-2.6.1.tar.bz2) = 52e6eea23dad7873485439f11d5b5a43
|
||||
SIZE (gnome2/libgnomecanvasmm-2.6.1.tar.bz2) = 306363
|
||||
MD5 (gnome2/libgnomecanvasmm-2.10.0.tar.bz2) = 09010717524f990915a6923d685ca5c1
|
||||
SIZE (gnome2/libgnomecanvasmm-2.10.0.tar.bz2) = 315570
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- libgnomecanvas/libgnomecanvasmm/item.cc.orig Wed Jul 9 17:36:39 2003
|
||||
+++ libgnomecanvas/libgnomecanvasmm/item.cc Wed Jul 9 17:44:53 2003
|
||||
@@ -44,8 +44,9 @@
|
||||
void
|
||||
Item::item_construct(Group& group)
|
||||
{
|
||||
+ va_list ap;
|
||||
gnome_canvas_item_construct(GNOME_CANVAS_ITEM(gobj()), group.gobj(),
|
||||
- 0, 0);
|
||||
+ 0, ap);
|
||||
}
|
||||
|
||||
void
|
Loading…
Reference in a new issue