Update to version 2.2_j055.
PR: 11313 Submitted by: IWASHITA Yoji <shuna@pop16.odn.ne.jp>
This commit is contained in:
parent
2aa59dc6ec
commit
b79c0889c8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=18286
6 changed files with 181 additions and 108 deletions
|
@ -1,32 +1,29 @@
|
|||
# New ports collection makefile for: ja-S-lang library
|
||||
# Version required: 1.2.2
|
||||
# Date created: 26 Jun 1998
|
||||
# Whom: Takashi Mega <mega@minz.org>
|
||||
# Version required: 1.2.2_j055
|
||||
# Date created: 22 April 1999
|
||||
# Whom: IWASHITA Yoji <shuna@pop16.odn.ne.jp>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
# $Id: Makefile,v 1.2 1998/10/16 04:30:24 jseger Exp $
|
||||
|
||||
DISTNAME= slang1.2.2
|
||||
PKGNAME= ja-libslang-1.2.2
|
||||
DISTNAME= slang1.2.2_j055
|
||||
PKGNAME= ja-libslang-1.2.2.j055
|
||||
CATEGORIES= japanese devel
|
||||
MASTER_SITES= ftp://space.mit.edu/pub/davis/slang/
|
||||
|
||||
PATCH_SITES= http://home.sprintmail.com/~kikutani/slang/
|
||||
PATCHFILES= slang1.2.2jp0.pat.gz
|
||||
PATCH_DIST_STRIP= -p1
|
||||
MASTER_SITES= http://home.sprintmail.com/~kikutani/slang/
|
||||
|
||||
MAINTAINER= mega@minz.org
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --includedir=${PREFIX}/include/slang
|
||||
ALL_TARGET= all elf
|
||||
INSTALL_TARGET= install install-elf
|
||||
WRKSRC= ${WRKDIR}/slang
|
||||
|
||||
post-install:
|
||||
${ECHO} "installing documents in ${PREFIX}/share/doc/slang"
|
||||
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
${ECHO} "===> Installing documents in ${PREFIX}/share/doc/slang"
|
||||
@mkdir -p ${PREFIX}/share/doc/slang
|
||||
${CP} -R ${WRKSRC}/doc/* ${PREFIX}/share/doc/slang
|
||||
|
||||
post-install:
|
||||
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
${CP} ${WRKSRC}/slang-j.doc ${PREFIX}/share/doc/slang
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1 @@
|
|||
MD5 (slang1.2.2.tar.gz) = f0b71a8f9c6f2ccef07eaaa4068b3d1e
|
||||
MD5 (slang1.2.2jp0.pat.gz) = e2199af1eb806a4f202f3a8b4dffd715
|
||||
MD5 (slang1.2.2_j055.tar.gz) = 0e80f4200b920d0cf07d9d03d58f76bf
|
||||
|
|
|
@ -1,11 +1,78 @@
|
|||
--- src/sltermin.c.orig Sun Jul 26 15:57:36 1998
|
||||
+++ src/sltermin.c Sun Jul 26 15:58:06 1998
|
||||
@@ -273,7 +273,7 @@
|
||||
{
|
||||
tidir = Terminfo_Dirs[i];
|
||||
if ((tidir != NULL)
|
||||
- && (sizeof (file) > strlen (tidir) + 2 + strlen (term)))
|
||||
+ && (sizeof (file) > strlen (tidir) + 3 + strlen (term)))
|
||||
{
|
||||
sprintf (file, "%s/%c/%s", tidir, *term, term);
|
||||
if (NULL != (fp = open_terminfo (file, ti)))
|
||||
*** configure.orig Mon Apr 13 12:57:32 1998
|
||||
--- configure Wed Apr 21 11:05:02 1999
|
||||
***************
|
||||
*** 1489,1519 ****
|
||||
|
||||
echo $ac_n "checking SLANG_VERSION""... $ac_c" 1>&6
|
||||
echo "configure:1492: checking SLANG_VERSION" >&5
|
||||
! slang_version=`grep "^#define *SLANG_VERSION " $srcdir/src/slang.h |
|
||||
! awk '{ print $3 }'`
|
||||
! slang_major_version=`echo $slang_version |
|
||||
! awk '{ print int($1/10000) }'`
|
||||
! slang_minor_version=`echo $slang_version $slang_major_version |
|
||||
! awk '{ print int(($1 - $2*10000)/100) }'`
|
||||
! slang_mminor_version=`echo $slang_version $slang_major_version $slang_minor_version |
|
||||
! awk '{ print ($1 - $2*10000 - $3*100) }'`
|
||||
!
|
||||
! slang_minor_version=$slang_minor_version.$slang_mminor_version
|
||||
echo "$ac_t""$slang_major_version.$slang_minor_version" 1>&6
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
! if test "$GCC" = yes; then
|
||||
! ELF_CC="gcc"
|
||||
! ELF_CFLAGS="-O2 -fno-strength-reduce -fPIC"
|
||||
! ELF_LINK="gcc -shared -Wl,-soname#"
|
||||
! ELF_LINK_CMD="\$(ELF_LINK),\$(ELFLIB_MAJOR)"
|
||||
else
|
||||
! ELF_CC="cc"
|
||||
! ELF_CFLAGS="-K pic"
|
||||
! ELF_LINK="ld -G -z text"
|
||||
ELF_LINK_CMD="\$(ELF_LINK)"
|
||||
fi
|
||||
|
||||
--- 1489,1511 ----
|
||||
|
||||
echo $ac_n "checking SLANG_VERSION""... $ac_c" 1>&6
|
||||
echo "configure:1492: checking SLANG_VERSION" >&5
|
||||
! slang_major_version=2
|
||||
! slang_minor_version=0
|
||||
echo "$ac_t""$slang_major_version.$slang_minor_version" 1>&6
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
! if [ "$PORTOBJFORMAT" = elf ]; then
|
||||
! ELF_CC="\$(CC)"
|
||||
! ELF_CFLAGS="\$(CFLAGS) -fPIC"
|
||||
! ELF_LINK="\$(CC) -shared -Wl,-soname,\$(ELFLIB_MAJOR)"
|
||||
! ELF_LINK_CMD="\$(ELF_LINK)"
|
||||
else
|
||||
! ELF_CC="\$(CC)"
|
||||
! ELF_CFLAGS="\$(CFLAGS) -fPIC"
|
||||
! ELF_LINK="ld -Bshareable -x"
|
||||
ELF_LINK_CMD="\$(ELF_LINK)"
|
||||
fi
|
||||
|
||||
***************
|
||||
*** 2033,2048 ****
|
||||
|
||||
|
||||
echo ""
|
||||
- echo "Configuration complete. You may need to edit src/Makefile."
|
||||
- echo "You are compiling SLANG with the following compiler configuration:"
|
||||
- echo " CC =" "$CC"
|
||||
- echo " CFLAGS =" "$CFLAGS"
|
||||
- echo " LDFLAGS =" "$LDFLAGS"
|
||||
- echo ""
|
||||
- echo " ELF_CC =" "$ELF_CC"
|
||||
- echo " ELF_LINK =" "$ELF_LINK"
|
||||
- echo "ELF_CFLAGS=" "$ELF_CFLAGS"
|
||||
- echo ""
|
||||
- echo "See also src/sl-feat.h for various features."
|
||||
- echo "Type 'make' to build normal library."
|
||||
- echo "On ELF systems, type 'make elf' to create ELF shared library."
|
||||
--- 2025,2027 ----
|
||||
|
|
30
japanese/libslang/files/patch-ac
Normal file
30
japanese/libslang/files/patch-ac
Normal file
|
@ -0,0 +1,30 @@
|
|||
*** autoconf/Makefile.in.orig Mon Apr 13 12:57:32 1998
|
||||
--- autoconf/Makefile.in Thu Apr 22 03:32:46 1999
|
||||
***************
|
||||
*** 10,16 ****
|
||||
cd src; $(MAKE) all
|
||||
elf:
|
||||
cd src; $(MAKE) elf
|
||||
- @echo Use make install-elf to install it.
|
||||
demos:
|
||||
cd demo; $(MAKE)
|
||||
clean:
|
||||
--- 10,15 ----
|
||||
***************
|
||||
*** 21,35 ****
|
||||
cd src; $(MAKE) install
|
||||
install-elf:
|
||||
cd src; $(MAKE) install-elf
|
||||
- @echo ""
|
||||
- @echo "Although not required, consider doing 'make install-links' to extra links"
|
||||
- @echo "You will also have to run ldconfig."
|
||||
- @echo ""
|
||||
install-links:
|
||||
cd src; $(MAKE) install-links
|
||||
- @echo ""
|
||||
- @echo "Make sure that you remember to run ldconfig to complete the installation."
|
||||
- @echo ""
|
||||
#
|
||||
distclean:
|
||||
/bin/rm -f *~ Makefile config.status config.log config.cache files.pck
|
||||
--- 20,27 ----
|
|
@ -1,63 +1,40 @@
|
|||
--- configure.orig Fri Apr 24 01:16:57 1998
|
||||
+++ configure Tue Sep 22 16:11:04 1998
|
||||
@@ -1489,35 +1489,25 @@
|
||||
|
||||
echo $ac_n "checking SLANG_VERSION""... $ac_c" 1>&6
|
||||
echo "configure:1492: checking SLANG_VERSION" >&5
|
||||
-slang_version=`grep "^#define *SLANG_VERSION " $srcdir/src/slang.h |
|
||||
- awk '{ print $3 }'`
|
||||
-slang_major_version=`echo $slang_version |
|
||||
- awk '{ print int($1/10000) }'`
|
||||
-slang_minor_version=`echo $slang_version $slang_major_version |
|
||||
- awk '{ print int(($1 - $2*10000)/100) }'`
|
||||
-slang_mminor_version=`echo $slang_version $slang_major_version $slang_minor_version |
|
||||
- awk '{ print ($1 - $2*10000 - $3*100) }'`
|
||||
-
|
||||
-slang_minor_version=$slang_minor_version.$slang_mminor_version
|
||||
+slang_major_version=1
|
||||
+slang_minor_version=3
|
||||
echo "$ac_t""$slang_major_version.$slang_minor_version" 1>&6
|
||||
|
||||
|
||||
|
||||
|
||||
|
||||
-if test "$GCC" = yes; then
|
||||
- ELF_CC="gcc"
|
||||
- ELF_CFLAGS="-O2 -fno-strength-reduce -fPIC"
|
||||
- ELF_LINK="gcc -shared -Wl,-soname#"
|
||||
- ELF_LINK_CMD="\$(ELF_LINK),\$(ELFLIB_MAJOR)"
|
||||
+if [ $PORTOBJFORMAT = elf ]; then
|
||||
+ELF_CC="\$(CC)"
|
||||
+ELF_CFLAGS="\$(CFLAGS) -fPIC"
|
||||
+ELF_LINK="\$(CC) -shared -Wl,-soname,\$(ELFLIB_MAJOR)"
|
||||
+ELF_LINK_CMD="\$(ELF_LINK)"
|
||||
else
|
||||
- ELF_CC="cc"
|
||||
- ELF_CFLAGS="-K pic"
|
||||
- ELF_LINK="ld -G -z text"
|
||||
- ELF_LINK_CMD="\$(ELF_LINK)"
|
||||
+ELF_CC="\$(CC)"
|
||||
+ELF_CFLAGS="\$(CFLAGS) -fPIC"
|
||||
+ELF_LINK="ld -Bshareable -x"
|
||||
+ELF_LINK_CMD="\$(ELF_LINK)"
|
||||
fi
|
||||
-
|
||||
-
|
||||
|
||||
|
||||
|
||||
--- src/Makefile.in Fri Apr 24 01:17:04 1998
|
||||
+++ /tmp/Makefile.in Tue Sep 22 15:45:26 1998
|
||||
@@ -68,7 +68,11 @@
|
||||
*** src/Makefile.in.orig Wed Nov 25 23:02:20 1998
|
||||
--- src/Makefile.in Thu Apr 22 03:04:38 1999
|
||||
***************
|
||||
*** 68,74 ****
|
||||
--- 68,78 ----
|
||||
|
||||
ELFLIB = lib$(THIS_LIB).so#
|
||||
ELFLIB_MAJOR = $(ELFLIB).$(ELF_MAJOR_VERSION)#
|
||||
+.if ${PORTOBJFORMAT} == elf
|
||||
+ELFLIB_MAJOR_MINOR = $(ELFLIB).$(ELF_MAJOR_VERSION)#
|
||||
+.else
|
||||
+ .if ( ${PORTOBJFORMAT} == "aout" )
|
||||
ELFLIB_MAJOR_MINOR = $(ELFLIB).$(ELF_MAJOR_VERSION).$(ELF_MINOR_VERSION)#
|
||||
+ .else
|
||||
+ ELFLIB_MAJOR_MINOR = $(ELFLIB).$(ELF_MAJOR_VERSION)#
|
||||
+ .endif
|
||||
|
||||
ELFDIR_ELF_LIB = $(ELFDIR)/$(ELFLIB_MAJOR_MINOR)#
|
||||
|
||||
***************
|
||||
*** 126,136 ****
|
||||
$(MKINSDIR) $(install_include_dir)
|
||||
$(install_lib_dir):
|
||||
$(MKINSDIR) $(install_lib_dir)
|
||||
! install-elf: install elf $(install_lib_dir) $(install_include_dir) $(ELFDIR_ELF_LIB)
|
||||
$(INSTALL_DATA) $(SRCDIR)/slang.h $(install_include_dir)
|
||||
$(INSTALL_DATA) $(SRCDIR)/slcurses.h $(install_include_dir)
|
||||
! -$(RM) $(install_lib_dir)/$(ELFLIB)
|
||||
! -$(RM) $(install_lib_dir)/$(ELFLIB_MAJOR)
|
||||
@echo installing $(ELFLIB_MAJOR_MINOR) in $(install_lib_dir)
|
||||
$(INSTALL_DATA) $(ELFDIR_ELF_LIB) $(install_lib_dir)
|
||||
@echo creating symbolic links to $(ELFLIB_MAJOR_MINOR)
|
||||
--- 130,139 ----
|
||||
$(MKINSDIR) $(install_include_dir)
|
||||
$(install_lib_dir):
|
||||
$(MKINSDIR) $(install_lib_dir)
|
||||
! install-elf: elf $(install_lib_dir) $(install_include_dir) $(ELFDIR_ELF_LIB)
|
||||
$(INSTALL_DATA) $(SRCDIR)/slang.h $(install_include_dir)
|
||||
$(INSTALL_DATA) $(SRCDIR)/slcurses.h $(install_include_dir)
|
||||
! $(INSTALL_DATA) $(SRCDIR)/slkanji.h $(install_include_dir)
|
||||
@echo installing $(ELFLIB_MAJOR_MINOR) in $(install_lib_dir)
|
||||
$(INSTALL_DATA) $(ELFDIR_ELF_LIB) $(install_lib_dir)
|
||||
@echo creating symbolic links to $(ELFLIB_MAJOR_MINOR)
|
||||
|
|
|
@ -1,11 +1,14 @@
|
|||
lib/libslang.a
|
||||
@exec ranlib %D/%F
|
||||
lib/libslang.so
|
||||
lib/libslang.so.1.3
|
||||
lib/libslang.so.2
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
include/slang.h
|
||||
include/slcurses.h
|
||||
include/slang/slang.h
|
||||
include/slang/slcurses.h
|
||||
include/slang/slkanji.h
|
||||
@dirrm include/slang
|
||||
share/doc/slang/slang-j.doc
|
||||
share/doc/slang/README
|
||||
share/doc/slang/OLD/help/README
|
||||
share/doc/slang/OLD/help/makefile.djg
|
||||
|
@ -15,24 +18,24 @@ share/doc/slang/OLD/help/slang.hlp
|
|||
share/doc/slang/OLD/help/slhelp.c
|
||||
@dirrm share/doc/slang/OLD/help
|
||||
@dirrm share/doc/slang/OLD
|
||||
share/doc/slang/text/cslang.txt
|
||||
share/doc/slang/internal/rpn.txt
|
||||
@dirrm share/doc/slang/internal
|
||||
share/doc/slang/text/cref.txt
|
||||
share/doc/slang/text/cslang.txt
|
||||
share/doc/slang/text/slang.txt
|
||||
share/doc/slang/text/slangfun.txt
|
||||
@dirrm share/doc/slang/text
|
||||
share/doc/slang/tm/slangfun.tm
|
||||
share/doc/slang/tm/tools/Makefile
|
||||
share/doc/slang/tm/tools/sl2tm.c
|
||||
share/doc/slang/tm/tools/tm2txt.c
|
||||
@dirrm share/doc/slang/tm/tools
|
||||
share/doc/slang/tm/Makefile
|
||||
share/doc/slang/tm/copyright.tm
|
||||
share/doc/slang/tm/cref.tm
|
||||
share/doc/slang/tm/cslang.tm
|
||||
share/doc/slang/tm/slang.tm
|
||||
share/doc/slang/tm/copyright.tm
|
||||
share/doc/slang/tm/preface.tm
|
||||
share/doc/slang/tm/fixtex.sl
|
||||
share/doc/slang/tm/Makefile
|
||||
share/doc/slang/tm/tools/tm2txt.c
|
||||
share/doc/slang/tm/tools/sl2tm.c
|
||||
share/doc/slang/tm/tools/Makefile
|
||||
@dirrm share/doc/slang/tm/tools
|
||||
share/doc/slang/tm/preface.tm
|
||||
share/doc/slang/tm/slang.tm
|
||||
share/doc/slang/tm/slangfun.tm
|
||||
@dirrm share/doc/slang/tm
|
||||
share/doc/slang/internal/rpn.txt
|
||||
@dirrm share/doc/slang/internal
|
||||
@dirrm share/doc/slang
|
||||
|
|
Loading…
Reference in a new issue