Ninja is yet another ircII based irc client.
PR: 11078 Submitted by: Chris Piazza <cpiazza@home.net>
This commit is contained in:
parent
0a1ccd100c
commit
b7e2daf50d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17887
7 changed files with 80 additions and 0 deletions
39
irc/ninja/Makefile
Normal file
39
irc/ninja/Makefile
Normal file
|
@ -0,0 +1,39 @@
|
||||||
|
# New ports collection makefile for: Ninja-irc
|
||||||
|
# Version required: 1.0.7
|
||||||
|
# Date created: 10 April 1999
|
||||||
|
# Whom: Chris Piazza <cpiazza@home.net>
|
||||||
|
#
|
||||||
|
# $Id$
|
||||||
|
#
|
||||||
|
|
||||||
|
DISTNAME= ninja-src
|
||||||
|
PKGNAME= ninja-1.0.7
|
||||||
|
CATEGORIES= net
|
||||||
|
MASTER_SITES= http://ninja.pimped.org/
|
||||||
|
|
||||||
|
MAINTAINER= cpiazza@home.net
|
||||||
|
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
|
||||||
|
WRKSRC= ${WRKDIR}/ninja-irc
|
||||||
|
|
||||||
|
MAN1= ninja.1
|
||||||
|
|
||||||
|
post-patch:
|
||||||
|
@${SED} -e s#__PREFIX__#$(PREFIX)#g $(WRKSRC)/include/config.h.dist > $(WRKSRC)/include/config.h.dist.new
|
||||||
|
@${MV} $(WRKSRC)/include/config.h.dist.new $(WRKSRC)/include/config.h.dist
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/source/ninja ${PREFIX}/bin
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/source/wserv ${PREFIX}/bin
|
||||||
|
${MKDIR} ${PREFIX}/share/ninja/help
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/doc/ninja.help ${PREFIX}/share/ninja/help
|
||||||
|
${INSTALL_MAN} ${WRKSRC}/doc/ninja.1 ${PREFIX}/man/man1
|
||||||
|
.if !defined(NOPORTDOCS)
|
||||||
|
${MKDIR} ${PREFIX}/share/doc/ninja
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/doc/colors.txt ${PREFIX}/share/doc/ninja
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/doc/commands.txt ${PREFIX}/share/doc/ninja
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/doc/keyinfo.txt ${PREFIX}/share/doc/ninja
|
||||||
|
.endif
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
1
irc/ninja/distinfo
Normal file
1
irc/ninja/distinfo
Normal file
|
@ -0,0 +1 @@
|
||||||
|
MD5 (ninja-src.tar.gz) = 1e578cdfe033fd26e7d30594e9e847f7
|
11
irc/ninja/files/patch-aa
Normal file
11
irc/ninja/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- include/config.h.dist.orig Sat Apr 10 23:33:33 1999
|
||||||
|
+++ include/config.h.dist Sat Apr 10 23:41:21 1999
|
||||||
|
@@ -171,7 +171,7 @@
|
||||||
|
#define DEFAULT_HACKED_IDENTD NULL
|
||||||
|
#define DEFAULT_HELP_PAGER 1
|
||||||
|
/*
|
||||||
|
-#define DEFAULT_HELP_PATH "/usr/local/lib/ninja/help:/usr/local/lib/irc/help:~/.ninja"
|
||||||
|
+#define DEFAULT_HELP_PATH "__PREFIX__/share/ninja/help:__PREFIX__/lib/irc/help:~/.ninja"
|
||||||
|
*/
|
||||||
|
#define DEFAULT_HELP_PROMPT 1
|
||||||
|
#define DEFAULT_HELP_WINDOW 0
|
11
irc/ninja/files/patch-ab
Normal file
11
irc/ninja/files/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- configure.orig Tue Apr 13 23:49:03 1999
|
||||||
|
+++ configure Tue Apr 13 23:49:19 1999
|
||||||
|
@@ -3741,7 +3741,7 @@
|
||||||
|
|
||||||
|
if test ! -n "$IRCLIB";
|
||||||
|
then
|
||||||
|
- IRCLIB=\${prefix}/lib/ninja
|
||||||
|
+ IRCLIB=\${prefix}/share/ninja
|
||||||
|
fi
|
||||||
|
|
||||||
|
if test -n "$nextstep"; then
|
1
irc/ninja/pkg-comment
Normal file
1
irc/ninja/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
||||||
|
Another ircII based irc client.
|
8
irc/ninja/pkg-descr
Normal file
8
irc/ninja/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
||||||
|
Ninja IRC is an alternative ircII based client. It includes full ANSI colour
|
||||||
|
and many other features normally found only in scripts.
|
||||||
|
|
||||||
|
Homepage:
|
||||||
|
http://ninja.pimped.org/
|
||||||
|
|
||||||
|
-Chris Piazza
|
||||||
|
cpiazza@home.net
|
9
irc/ninja/pkg-plist
Normal file
9
irc/ninja/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
||||||
|
bin/ninja
|
||||||
|
bin/wserv
|
||||||
|
share/doc/ninja/colors.txt
|
||||||
|
share/doc/ninja/commands.txt
|
||||||
|
share/doc/ninja/keyinfo.txt
|
||||||
|
share/ninja/help/ninja.help
|
||||||
|
@dirrm share/doc/ninja
|
||||||
|
@dirrm share/ninja/help
|
||||||
|
@dirrm share/ninja
|
Loading…
Reference in a new issue