Merge Linux-specific changes to BSD patches. Most importantly, this change

corrects 'os.arch' property for i386 to fix regressions.

PR:		194419
This commit is contained in:
Jung-uk Kim 2014-10-30 16:30:36 +00:00
parent 18e4ea1312
commit b81354a1df
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=371759
3 changed files with 25 additions and 3 deletions

View file

@ -1,6 +1,6 @@
# $FreeBSD$
PORTREVISION= 4
PORTREVISION= 5
PKGNAMESUFFIX= ${JDK_MAJOR_VERSION}-jre
COMMENT= Java Runtime Environment ${JDK_MAJOR_VERSION}

View file

@ -2,6 +2,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${JDK_UPDATE_VERSION}.${JDK_BUILD_NUMBER:S/^0//}
PORTREVISION?= 1
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk${JDK_MAJOR_VERSION}/promoted/b${DIST_BUILD_NUMBER}/:jdk \
https://adopt-openjdk.ci.cloudbees.com/job/jtreg/${JTREG_JENKINS_BUILD}/artifact/:jtreg \
@ -241,8 +242,6 @@ do-install:
@${ECHO} "@unexec ${LOCALBASE}/bin/unregistervm ${INSTALLDIR}/bin/java" >> ${TMPPLIST}
@${FIND} -s ${STAGEDIR}${INSTALLDIR} -not -type d | ${SORT} | \
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
@${FIND} ${STAGEDIR}${INSTALLDIR} -type d | ${SORT} -r | \
${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
@${ECHO} "@exec ${LOCALBASE}/bin/registervm '${INSTALLDIR}/bin/java # ${JAVAVMS_COMMENT}'" >> ${TMPPLIST}
.include <bsd.port.post.mk>

View file

@ -85,6 +85,29 @@
VAR_CPU=x86_64
VAR_CPU_ARCH=x86
VAR_CPU_BITS=64
@@ -291,8 +291,8 @@
# Setup OPENJDK_TARGET_CPU_OSARCH, which is used to set the os.arch Java system property
OPENJDK_TARGET_CPU_OSARCH="$OPENJDK_TARGET_CPU"
- if test "x$OPENJDK_TARGET_OS" = xlinux && test "x$OPENJDK_TARGET_CPU" = xx86; then
- # On linux only, we replace x86 with i386.
+ if test "x$OPENJDK_TARGET_OS" = xbsd -o "x$OPENJDK_TARGET_OS" = xlinux && test "x$OPENJDK_TARGET_CPU" = xx86; then
+ # On bsd and linux only, we replace x86 with i386.
OPENJDK_TARGET_CPU_OSARCH="i386"
elif test "x$OPENJDK_TARGET_OS" != xmacosx && test "x$OPENJDK_TARGET_CPU" = xx86_64; then
# On all platforms except macosx, we replace x86_64 with amd64.
@@ -336,9 +336,9 @@
if test "x$OPENJDK_TARGET_CPU_BITS" = x64; then
A_LP64="LP64:="
- # -D_LP64=1 is only set on linux and mac. Setting on windows causes diff in
+ # -D_LP64=1 is only set on bsd, linux and mac. Setting on windows causes diff in
# unpack200.exe
- if test "x$OPENJDK_TARGET_OS" = xlinux || test "x$OPENJDK_TARGET_OS" = xmacosx; then
+ if test "x$OPENJDK_TARGET_OS" = xbsd -o "x$OPENJDK_TARGET_OS" = xlinux -o "x$OPENJDK_TARGET_OS" = xmacosx; then
ADD_LP64="-D_LP64=1"
fi
fi
--- common/autoconf/toolchain.m4
+++ common/autoconf/toolchain.m4
@@ -63,7 +63,7 @@