John Horton Conway's Game of Life, taken from R5-contrib archives.
This commit is contained in:
parent
e5d5d8902c
commit
b816975af2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=1141
6 changed files with 117 additions and 0 deletions
18
games/xlife/Makefile
Normal file
18
games/xlife/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# New ports collection makefile for: xlife
|
||||
# Version required: 3.0
|
||||
# Date created: 15 March 1995
|
||||
# Whom: asami
|
||||
#
|
||||
# $Id: Makefile,v 1.1.1.1 1995/01/03 08:46:26 swallace Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xlife
|
||||
MASTER_SITES= ftp://gatekeeper.dec.com/pub/X11/R5-contrib/
|
||||
EXTRACT_SUFX= .tar.Z
|
||||
USE_IMAKE= yes
|
||||
PKGNAME= xlife-3.0
|
||||
|
||||
pre-install:
|
||||
@(cd ${WRKSRC}; make install.patterns)
|
||||
|
||||
.include <bsd.port.mk>
|
1
games/xlife/distinfo
Normal file
1
games/xlife/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (xlife.tar.Z) = b5dd23591200aab3468af2efcf6a04e3
|
85
games/xlife/files/patch-aa
Normal file
85
games/xlife/files/patch-aa
Normal file
|
@ -0,0 +1,85 @@
|
|||
--- ./data.h.org Thu Mar 21 13:47:04 1991
|
||||
+++ ./data.h Wed Mar 15 22:09:46 1995
|
||||
@@ -21,7 +21,7 @@
|
||||
*/
|
||||
|
||||
extern int sys_nerr, errno;
|
||||
-extern char *sys_errlist[];
|
||||
+/* extern char *sys_errlist[]; */
|
||||
#define SYSERR sys_errlist[(errno > sys_nerr? 0 : errno)]
|
||||
|
||||
GLOBAL Display *disp;
|
||||
--- ./cellbox.h.org Thu Mar 21 13:46:28 1991
|
||||
+++ ./cellbox.h Wed Mar 15 22:09:46 1995
|
||||
@@ -32,6 +32,8 @@
|
||||
#define MAXOFF 8192 /* max # cells we can change to off per move */
|
||||
#define BOXSIZE 8
|
||||
|
||||
+/* to avoid conflict with system function in unistd.h */
|
||||
+#define link xlife_link
|
||||
extern cellbox *link();
|
||||
extern cellbox *head;
|
||||
extern cellbox *freep;
|
||||
--- ./defs.h.org Thu Mar 21 14:21:18 1991
|
||||
+++ ./defs.h Wed Mar 15 22:09:45 1995
|
||||
@@ -29,7 +29,8 @@
|
||||
#include <X11/keysym.h>
|
||||
#include <X11/keysymdef.h>
|
||||
|
||||
-#define DIR "/afs/andrew/usr0/games/lib/xlife/"
|
||||
+/* Defined in Imakefile */
|
||||
+/* #define DIR "/afs/andrew/usr0/games/lib/xlife/" */
|
||||
#define NORMALFONT "8x13"
|
||||
#define BOLDFONT "8x13bold"
|
||||
#define FONTHEIGHT 13
|
||||
--- ./Imakefile.org Thu Mar 28 07:58:48 1991
|
||||
+++ ./Imakefile Wed Mar 15 22:13:08 1995
|
||||
@@ -2,9 +2,10 @@
|
||||
|
||||
/* #define ManSuffix n /* For sites where administrators have messed with this */
|
||||
|
||||
-PROGRAMS = xlife oldpconv collect
|
||||
+PROGRAMS = xlife lifeconv oldpconv collect
|
||||
|
||||
-XLIFEPATSDIR = /afs/andrew.cmu.edu/usr0/games/lib/xlife
|
||||
+XLIFEPATSDIR = $(LIBDIR)/xlife
|
||||
+EXTRA_DEFINES = -DDIR=\"$(XLIFEPATSDIR)\"
|
||||
|
||||
SRCS1 = \
|
||||
button.c\
|
||||
@@ -42,26 +43,21 @@
|
||||
resize.o\
|
||||
utils.o
|
||||
|
||||
-SRCS2 = \
|
||||
- lifeconv.c
|
||||
-
|
||||
-OBJS2 = \
|
||||
- lifeconv.o
|
||||
-
|
||||
-SRCS3 = \
|
||||
- collect.c
|
||||
-
|
||||
-OBJS3 = \
|
||||
- collect.o
|
||||
-
|
||||
AllTarget($(PROGRAMS))
|
||||
|
||||
ComplexProgramTarget_1(xlife, $(XLIB),)
|
||||
-ComplexProgramTarget_2(lifeconv,,)
|
||||
-ComplexProgramTarget_3(collect,,)
|
||||
+NormalProgramTarget(lifeconv,oldpconv.o,,,)
|
||||
+InstallProgram(lifeconv,$(BINDIR))
|
||||
+NormalProgramTarget(collect,collect.o,,,)
|
||||
+InstallProgram(collect,$(BINDIR))
|
||||
NormalProgramTarget(oldpconv,oldpconv.o,,,)
|
||||
+InstallProgram(oldpconv,$(BINDIR))
|
||||
|
||||
install.patterns:
|
||||
+ if [ -d $(XLIFEPATSDIR) ]; then \
|
||||
+ set +x; \
|
||||
+ else (set -x; mkdirhier $(XLIFEPATSDIR)); \
|
||||
+ fi
|
||||
@case '${MFLAGS}' in *[i]*) set +e;; esac; \
|
||||
for i in patterns//**/* ; do \
|
||||
(set -x; $(INSTALL) -c $(INSTDATFLAGS) $$i $(XLIFEPATSDIR)); \
|
1
games/xlife/pkg-comment
Normal file
1
games/xlife/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
xlife-3.0, John Horton Conway's Game of Life.
|
5
games/xlife/pkg-descr
Normal file
5
games/xlife/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
xlife is an X implementation of John Horton Conway's Game of Life.
|
||||
This is version 3.0.
|
||||
|
||||
- Satoshi
|
||||
asami@cs.berkeley.edu
|
7
games/xlife/pkg-plist
Normal file
7
games/xlife/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
@cwd /usr/X11R6
|
||||
bin/xlife
|
||||
bin/lifeconv
|
||||
bin/collect
|
||||
bin/oldpconv
|
||||
lib/X11/xlife
|
||||
man/man1/xlife.1.gz
|
Loading…
Reference in a new issue