mail/dbmail: update to 3.1.1
- Update to 3.1.1 [1] - Remove leading article from COMMENT Check share/doc/dbmail/UPGRADING for upgrading details. Changes: http://git.dbmail.eu/paul/dbmail/log/ PR: ports/180768 Submitted by: Alan Hicks <ahicks p-o.co.uk> (maintainer)
This commit is contained in:
parent
e03cd93ee2
commit
b8249de235
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=323664
8 changed files with 126 additions and 65 deletions
|
@ -2,20 +2,19 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= dbmail
|
||||
PORTVERSION= 3.0.2
|
||||
PORTREVISION= 7
|
||||
PORTVERSION= 3.1.1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.dbmail.org/download/3.0/
|
||||
MASTER_SITES= http://www.dbmail.org/download/3.1/
|
||||
|
||||
MAINTAINER= ahicks@p-o.co.uk
|
||||
COMMENT= An SQL database-based mail system (POP3 and IMAP)
|
||||
COMMENT= SQL database-based mail system (POP3 and IMAP)
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= gmime-2.4:${PORTSDIR}/mail/gmime24 \
|
||||
LIB_DEPENDS= gmime-2.6:${PORTSDIR}/mail/gmime26 \
|
||||
zdb:${PORTSDIR}/databases/libzdb \
|
||||
mhash:${PORTSDIR}/security/mhash \
|
||||
event:${PORTSDIR}/devel/libevent
|
||||
event-2:${PORTSDIR}/devel/libevent2
|
||||
|
||||
CONFLICTS= dbmail-2.*
|
||||
|
||||
|
@ -26,19 +25,20 @@ SIEVE_DESC= Build with support for Sieve mail sorting language
|
|||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
|
||||
BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
|
||||
xmlto:${PORTSDIR}/textproc/xmlto
|
||||
.endif
|
||||
|
||||
USE_AUTOTOOLS= libtool
|
||||
USE_AUTOTOOLS= libtool autoheader autoconf
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= ${PREFIX}/lib/dbmail
|
||||
USE_RC_SUBR= dbmail-pop3d dbmail-lmtpd dbmail-imapd dbmail-timsieved
|
||||
USE_OPENSSL= yes
|
||||
USES= shebangfix
|
||||
SHEBANG_FILES= man/fixsp.pl
|
||||
WITH_DEBUG= yes
|
||||
|
||||
CFLAGS+= -fPIC ${PTHREAD_CFLAGS}
|
||||
CFLAGS+= -fPIC ${PTHREAD_CFLAGS} -DDEBUG
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
|
||||
CONFIGURE_ARGS+= --with-zdb=${LOCALBASE} --sysconfdir=${LOCALBASE}/etc
|
||||
|
@ -87,7 +87,6 @@ PLIST_SUB+= LDAP="@comment "
|
|||
|
||||
.if ${PORT_OPTIONS:MTHREADS}
|
||||
EXTRA_PATCHES= ${FILESDIR}/extra-patch-acinclude.m4
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-configure
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (dbmail-3.0.2.tar.gz) = 139558f4fa3e0f460d688f6d29318366cc3f40dd570a1a29484bb580d0190c3e
|
||||
SIZE (dbmail-3.0.2.tar.gz) = 867560
|
||||
SHA256 (dbmail-3.1.1.tar.gz) = 4df9f3a8d13af3a5f41dfab480f89a9e338b025e36e42cb76dc4f34b242ac1e0
|
||||
SIZE (dbmail-3.1.1.tar.gz) = 2398581
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- acinclude.m4.orig 2012-05-30 16:42:44.000000000 +0100
|
||||
+++ acinclude.m4 2012-05-30 16:44:28.000000000 +0100
|
||||
@@ -235,7 +235,7 @@
|
||||
--- acinclude.m4.orig
|
||||
+++ acinclude.m4
|
||||
@@ -236,7 +236,7 @@ if ( test [ "x$lookforldap" != "xno" ] || test [ "x$lookforauthldap" != "xno" ]
|
||||
dnl See if we already have the paths we need in the environment.
|
||||
dnl ...but only if --with-ldap was given without a specific path.
|
||||
if ( test [ "x$lookforldap" = "xyes" ] || test [ "x$lookforauthldap" = "xyes" ] ); then
|
||||
|
@ -9,7 +9,7 @@
|
|||
if test [ "x$LDAPLIB" != "xfailed" ]; then
|
||||
break
|
||||
fi
|
||||
@@ -247,7 +247,7 @@
|
||||
@@ -248,7 +248,7 @@ if ( test [ "x$lookforldap" != "xno" ] || test [ "x$lookforauthldap" != "xno" ]
|
||||
SAVE_CFLAGS=$CFLAGS
|
||||
dnl The headers might be in a funny place, so we need to use -Ipath
|
||||
CFLAGS="$CFLAGS -L$TEST_PATH $LDAPINC"
|
||||
|
@ -18,3 +18,12 @@
|
|||
CFLAGS=$SAVE_CFLAGS
|
||||
if test [ "x$LDAPLIB" != "xfailed" ]; then
|
||||
break 2
|
||||
@@ -262,7 +262,7 @@ if ( test [ "x$lookforldap" != "xno" ] || test [ "x$lookforauthldap" != "xno" ]
|
||||
AC_MSG_ERROR([Could not find LDAP library.])
|
||||
else
|
||||
AC_DEFINE([AUTHLDAP], 1, [Define if LDAP will be used.])
|
||||
- AC_SEARCH_LIBS(ldap_initialize, ldap, AC_DEFINE([HAVE_LDAP_INITIALIZE], 1, [ldap_initialize() can be used instead of ldap_init()]))
|
||||
+ AC_SEARCH_LIBS(ldap_initialize, ldap_r, AC_DEFINE([HAVE_LDAP_INITIALIZE], 1, [ldap_initialize() can be used instead of ldap_init()]))
|
||||
AC_SUBST(LDAPLIB)
|
||||
AC_SUBST(LDAPINC)
|
||||
AUTHALIB="modules/.libs/libauth_ldap.a"
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
+++ configure.orig 2012-03-11 08:02:30.000000000 +0000
|
||||
--- configure 2012-05-31 12:47:22.000000000 +0100
|
||||
@@ -4420,7 +4420,7 @@
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
#define HAVE_LDAP_H 1
|
||||
_ACEOF
|
||||
- LDAPLIB="-lldap"
|
||||
+ LDAPLIB="-lldap_r"
|
||||
else
|
||||
LDAPLIB="failed"
|
||||
fi
|
||||
@@ -4443,7 +4443,7 @@
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
#define HAVE_LDAP_H 1
|
||||
_ACEOF
|
||||
- LDAPLIB="-L$TEST_PATH -lldap"
|
||||
+ LDAPLIB="-L$TEST_PATH -lldap_r"
|
||||
else
|
||||
LDAPLIB="failed"
|
||||
fi
|
||||
@@ -4489,7 +4489,7 @@
|
||||
return 0;
|
||||
}
|
||||
_ACEOF
|
||||
-for ac_lib in '' ldap; do
|
||||
+for ac_lib in '' ldap_r; do
|
||||
if test -z "$ac_lib"; then
|
||||
ac_res="none required"
|
||||
else
|
58
mail/dbmail/files/patch-acinclude.m4
Normal file
58
mail/dbmail/files/patch-acinclude.m4
Normal file
|
@ -0,0 +1,58 @@
|
|||
--- acinclude.m4.orig 2013-05-31 14:03:59.000000000 +0100
|
||||
+++ acinclude.m4 2013-05-31 14:45:49.000000000 +0100
|
||||
@@ -23,7 +23,7 @@
|
||||
SOCKETS: $SOCKETLIB
|
||||
MATH: $MATHLIB
|
||||
MHASH: $MHASHLIB
|
||||
- LIBEVENT: $EVENTLIB
|
||||
+ LIBEVENT: $ac_event_libs
|
||||
OPENSSL: $SSLLIB
|
||||
ZDB: $ZDBLIB
|
||||
JEMALLOC: $JEMALLOCLIB
|
||||
@@ -342,13 +342,40 @@
|
||||
fi
|
||||
])
|
||||
|
||||
-AC_DEFUN([DM_CHECK_EVENT], [
|
||||
- AC_CHECK_HEADERS([event.h], [EVENTLIB="-levent_pthreads -levent"],[EVENTLIB="failed"], [#include <event2/event.h>])
|
||||
- if test [ "x$EVENTLIB" = "xfailed" ]; then
|
||||
- AC_MSG_ERROR([Could not find EVENT library.])
|
||||
- else
|
||||
- LDFLAGS="$LDFLAGS $EVENTLIB"
|
||||
+AC_DEFUN([DM_CHECK_EVENT], [dnl
|
||||
+AC_PATH_PROG(eventconfig,pkg-config)
|
||||
+if test [ -z "$eventconfig" ]
|
||||
+then
|
||||
+ AC_MSG_ERROR([pkg-config executable not found. Make sure pkg-config is in your path])
|
||||
+else
|
||||
+ AC_MSG_CHECKING([Event headers])
|
||||
+ ac_event_cflags=`${eventconfig} --cflags libevent_pthreads`
|
||||
+ if test -z "$ac_event_cflags"
|
||||
+ then
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ AC_MSG_ERROR([Unable to locate event development files])
|
||||
+ fi
|
||||
+
|
||||
+ CFLAGS="$CFLAGS $ac_event_cflags"
|
||||
+ AC_MSG_RESULT([$ac_event_cflags])
|
||||
+ AC_MSG_CHECKING([Event libraries])
|
||||
+ ac_event_libs=`${eventconfig} --libs libevent_pthreads`
|
||||
+ if test -z "$ac_event_libs"
|
||||
+ then
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ AC_MSG_ERROR([Unable to locate event libaries])
|
||||
fi
|
||||
+ ac_event_minvers="2.0"
|
||||
+ AC_MSG_CHECKING([Event version >= $ac_event_minvers])
|
||||
+ ac_event_vers=`${eventconfig} --atleast-version=$ac_event_minvers libevent_pthreads>/dev/null && echo yes`
|
||||
+ if test -z "$ac_event_vers"
|
||||
+ then
|
||||
+ AC_MSG_ERROR([At least Event version $ac_event_minvers is required.])
|
||||
+ fi
|
||||
+
|
||||
+ LDFLAGS="$LDFLAGS $ac_event_libs"
|
||||
+ AC_MSG_RESULT([$ac_event_libs])
|
||||
+fi
|
||||
])
|
||||
|
||||
AC_DEFUN([DM_CHECK_SSL], [
|
|
@ -1,20 +1,28 @@
|
|||
--- src/clientbase.c.orig 2012-06-19 17:49:50.000000000 +0100
|
||||
+++ src/clientbase.c 2012-06-19 17:50:29.000000000 +0100
|
||||
@@ -160,7 +160,7 @@
|
||||
--- src/clientbase.c.orig 2013-07-22 20:03:36.000000000 +0100
|
||||
+++ src/clientbase.c 2013-07-23 13:14:56.000000000 +0100
|
||||
@@ -159,14 +159,14 @@
|
||||
client->tx = STDOUT_FILENO;
|
||||
} else {
|
||||
/* server-side */
|
||||
TRACE(TRACE_DEBUG,"saddr [%p] sa_family [%d] len [%d]", c->saddr, c->saddr->sa_family, c->saddr_len);
|
||||
- if ((serr = getnameinfo(c->saddr, c->saddr_len, client->dst_ip, NI_MAXHOST, client->dst_port, NI_MAXSERV,
|
||||
+ if ((serr = getnameinfo(c->saddr, c->saddr->sa_len, client->dst_ip, NI_MAXHOST, client->dst_port, NI_MAXSERV,
|
||||
NI_NUMERICHOST | NI_NUMERICSERV))) {
|
||||
TRACE(TRACE_INFO, "getnameinfo::error [%s]", gai_strerror(serr));
|
||||
}
|
||||
@@ -168,7 +168,7 @@
|
||||
|
||||
/* client-side */
|
||||
TRACE(TRACE_DEBUG,"caddr [%p] sa_family [%d] len [%d]", c->caddr, c->caddr->sa_family, c->caddr_len);
|
||||
- if ((serr = getnameinfo(c->caddr, c->caddr_len, client->src_ip, NI_MAXHOST, client->src_port, NI_MAXSERV,
|
||||
+ if ((serr = getnameinfo(c->caddr, c->caddr->sa_len, client->src_ip, NI_MAXHOST, client->src_port, NI_MAXSERV,
|
||||
NI_NUMERICHOST | NI_NUMERICSERV))) {
|
||||
TRACE(TRACE_EMERG, "getnameinfo:error [%s]", gai_strerror(serr));
|
||||
}
|
||||
if (server_conf->resolveIP) {
|
||||
- if ((serr = getnameinfo(c->caddr, c->caddr_len, client->clientname, NI_MAXHOST, NULL, 0,
|
||||
+ if ((serr = getnameinfo(c->caddr, c->caddr->sa_len, client->clientname, NI_MAXHOST, NULL, 0,
|
||||
NI_NAMEREQD))) {
|
||||
TRACE(TRACE_INFO, "getnameinfo:error [%s]", gai_strerror(serr));
|
||||
}
|
||||
@@ -177,7 +177,7 @@
|
||||
client->clientname[0] ? client->clientname : "Lookup failed");
|
||||
} else {
|
||||
|
||||
- if ((serr = getnameinfo(c->caddr, c->caddr_len, client->src_ip, NI_MAXHOST, client->src_port,
|
||||
+ if ((serr = getnameinfo(c->caddr, c->caddr->sa_len, client->src_ip, NI_MAXHOST, client->src_port,
|
||||
NI_MAXSERV, NI_NUMERICHOST | NI_NUMERICSERV))) {
|
||||
TRACE(TRACE_INFO, "getnameinfo:error [%s]", gai_strerror(serr));
|
||||
}
|
||||
|
|
|
@ -1,13 +1,30 @@
|
|||
--- src/dbmail.h.in.orig 2012-05-31 13:06:26.000000000 +0100
|
||||
+++ src/dbmail.h.in 2012-05-31 13:07:01.000000000 +0100
|
||||
@@ -150,6 +150,10 @@
|
||||
--- src/dbmail.h.in.orig
|
||||
+++ src/dbmail.h.in
|
||||
@@ -83,8 +83,14 @@
|
||||
#include <mhash.h>
|
||||
#include <sys/queue.h>
|
||||
#include <event2/event.h>
|
||||
+#include <event2/event_compat.h>
|
||||
#include <event2/thread.h>
|
||||
-#include <evhttp.h>
|
||||
+#include <event2/http.h>
|
||||
+#include <event2/http_struct.h>
|
||||
+#include <event2/http_compat.h>
|
||||
+#include <event2/buffer.h>
|
||||
+#include <event2/buffer_compat.h>
|
||||
+#include <event2/keyvalq_struct.h>
|
||||
#include <math.h>
|
||||
#include <openssl/ssl.h>
|
||||
|
||||
@@ -154,6 +160,11 @@
|
||||
#include <endian.h>
|
||||
#endif
|
||||
|
||||
+#ifdef HAVE_CONFIG_H
|
||||
+#include "config.h"
|
||||
+#endif
|
||||
+
|
||||
+
|
||||
#define GETCONFIGVALUE(key, sect, var) \
|
||||
config_get_value(key, sect, var); \
|
||||
if (strlen(var) > 0) \
|
||||
config_get_value(key, sect, var); \
|
||||
if (strlen(var) > 0) \
|
||||
|
|
|
@ -1,19 +1,15 @@
|
|||
@unexec if cmp -s %D/etc/dbmail.conf-dist %D/etc/dbmail.conf; then rm -f %D/etc/dbmail.conf; fi
|
||||
etc/dbmail.conf-dist
|
||||
@exec if [ ! -f %D/etc/dbmail.conf ] ; then cp -p %D/%F %B/dbmail.conf; fi
|
||||
%%LDAP%%lib/dbmail/libauth_ldap.a
|
||||
%%LDAP%%lib/dbmail/libauth_ldap.la
|
||||
%%LDAP%%lib/dbmail/libauth_ldap.so
|
||||
%%LDAP%%lib/dbmail/libauth_ldap.so.0
|
||||
lib/dbmail/libauth_sql.a
|
||||
lib/dbmail/libauth_sql.la
|
||||
lib/dbmail/libauth_sql.so
|
||||
lib/dbmail/libauth_sql.so.0
|
||||
lib/dbmail/libdbmail.a
|
||||
lib/dbmail/libdbmail.la
|
||||
lib/dbmail/libdbmail.so
|
||||
lib/dbmail/libdbmail.so.0
|
||||
%%SIEVE%%lib/dbmail/libsort_sieve.a
|
||||
%%SIEVE%%lib/dbmail/libsort_sieve.la
|
||||
%%SIEVE%%lib/dbmail/libsort_sieve.so
|
||||
%%SIEVE%%lib/dbmail/libsort_sieve.so.0
|
||||
|
@ -35,6 +31,7 @@ sbin/dbmail-util
|
|||
%%DATADIR%%/mysql/2_3_4-2_3_5.mysql
|
||||
%%DATADIR%%/mysql/2_3_5-2_3_6.mysql
|
||||
%%DATADIR%%/mysql/2_3_6-3_0_0.mysql
|
||||
%%DATADIR%%/mysql/3_0_2-3_1_0.mysql
|
||||
%%DATADIR%%/mysql/create_tables.mysql
|
||||
%%DATADIR%%/mysql/fix_foreign_keys.mysql
|
||||
%%DATADIR%%/mysql/migrate_from_1.x_to_2.0_innodb.mysql
|
||||
|
@ -49,6 +46,7 @@ sbin/dbmail-util
|
|||
%%DATADIR%%/postgresql/2_3_4-2_3_5.pgsql
|
||||
%%DATADIR%%/postgresql/2_3_5-2_3_6.pgsql
|
||||
%%DATADIR%%/postgresql/2_3_6-3_0_0.pgsql
|
||||
%%DATADIR%%/postgresql/3_0_2-3_1_0.psql
|
||||
%%DATADIR%%/postgresql/create_tables.pgsql
|
||||
%%DATADIR%%/postgresql/migrate_from_1.x_to_2.0.pgsql
|
||||
%%DATADIR%%/postgresql/migrate_from_2.0_to_2.2.pgsql
|
||||
|
@ -58,6 +56,7 @@ sbin/dbmail-util
|
|||
%%DATADIR%%/sqlite/2_3_4-2_3_5.sqlite
|
||||
%%DATADIR%%/sqlite/2_3_5-2_3_6.sqlite
|
||||
%%DATADIR%%/sqlite/2_3_6-3_0_0.sqlite
|
||||
%%DATADIR%%/sqlite/3_0_2-3_1_0.sqlite
|
||||
%%DATADIR%%/sqlite/create_tables.sqlite
|
||||
%%DATADIR%%/sqlite/trigger.tmpl.sql
|
||||
@dirrm %%DATADIR%%/sqlite
|
||||
|
|
Loading…
Reference in a new issue