upgrade to 0.9.5

PR:		69393
Submitted by:	maintainer
This commit is contained in:
Ying-Chieh Liao 2004-07-22 01:10:30 +00:00
parent ea07b17dc3
commit b846af5b2f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=114380
6 changed files with 37 additions and 22 deletions

View file

@ -5,8 +5,8 @@
# $FreeBSD$
PORTNAME= libcddb
PORTVERSION= 0.9.4
PORTREVISION= 1
PORTVERSION= 0.9.5
PORTREVISION= 0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -14,8 +14,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ahze@ahze.net
COMMENT= A library to access data on a CDDB server
USE_INC_LIBTOOL_VER= 13
USE_GNOME= gnometarget lthack gnomehack pkgconfig
USE_INC_LIBTOOL_VER= 15
USE_GNOME= gnometarget gnomehack pkgconfig
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>

View file

@ -1,2 +1,2 @@
MD5 (libcddb-0.9.4.tar.gz) = 366095f09e1d89d91915a2dd7c7c1478
SIZE (libcddb-0.9.4.tar.gz) = 272751
MD5 (libcddb-0.9.5.tar.gz) = 9db0b305a67ce0827966442bc0731c96
SIZE (libcddb-0.9.5.tar.gz) = 380064

View file

@ -1,11 +1,10 @@
--- include/cddb/cddb.h.orig Mon Mar 1 04:22:27 2004
+++ include/cddb/cddb.h Mon Mar 1 04:22:47 2004
@@ -26,7 +26,7 @@
extern "C" {
--- include/cddb/cddb.h.orig Wed Jul 21 15:34:48 2004
+++ include/cddb/cddb.h Wed Jul 21 15:35:03 2004
@@ -27,6 +27,7 @@
#endif
-
+#include <sys/types.h>
#include <cddb/cddb_config.h>
#include <cddb/cddb_error.h>
#include <cddb/cddb_track.h>
#include <cddb/cddb_disc.h>

View file

@ -1,10 +1,10 @@
--- include/cddb/cddb_ni.h.orig Mon Mar 1 04:28:02 2004
+++ include/cddb/cddb_ni.h Mon Mar 1 04:28:16 2004
@@ -18,6 +18,7 @@
Free Software Foundation, Inc., 59 Temple Place - Suite 330,
Boston, MA 02111-1307, USA.
*/
--- include/cddb/cddb_ni.h.orig Wed Jul 21 15:35:13 2004
+++ include/cddb/cddb_ni.h Wed Jul 21 15:35:32 2004
@@ -31,6 +31,7 @@
# include <config.h>
#endif
+#include <sys/types.h>
#ifndef CDDB_NI_H
#define CDDB_NI_H 1
#include "cddb/cddb_regex.h"
#include "cddb/cddb.h"
#include "cddb/cddb_conn_ni.h"

View file

@ -0,0 +1,15 @@
--- ltmain.sh.orig Wed Jul 21 15:43:15 2004
+++ ltmain.sh Wed Jul 21 15:43:45 2004
@@ -5608,10 +5608,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -1,6 +1,7 @@
bin/cddb_query
include/cddb/cddb.h
include/cddb/cddb_cmd.h
include/cddb/cddb_config.h
include/cddb/cddb_conn.h
include/cddb/cddb_disc.h
include/cddb/cddb_error.h