astro/py-astlib: Update to 0.11.10
Changes: https://github.com/mattyowl/astLib/releases
This commit is contained in:
parent
930a8c2987
commit
b885b41a2f
3 changed files with 12 additions and 25 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= astlib
|
||||
PORTVERSION= 0.11.9
|
||||
PORTVERSION= 0.11.10
|
||||
CATEGORIES= astro python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -15,11 +15,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
|||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=1.1:astro/py-astropy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}numpy>=0.1:math/py-numpy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=3.2,2:astro/py-astropy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}matplotlib>=3.0:math/py-matplotlib@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}numpy>=1.10,1:math/py-numpy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}scipy>=1.7:science/py-scipy@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist concurrent pep517
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1697463070
|
||||
SHA256 (astLib-0.11.9.tar.gz) = b2f9b7be58ffa96fc7876732038694d0faba026a0bf53003ccb0010c0e54feb7
|
||||
SIZE (astLib-0.11.9.tar.gz) = 9917509
|
||||
TIMESTAMP = 1698340975
|
||||
SHA256 (astLib-0.11.10.tar.gz) = c7a7edf73202e35a07d363cd60fa1ee77faef9f605f29b69e91b1654138ba72e
|
||||
SIZE (astLib-0.11.10.tar.gz) = 10022928
|
||||
|
|
|
@ -1,23 +1,11 @@
|
|||
Reference: https://github.com/mattyowl/astLib/pull/9
|
||||
https://github.com/mattyowl/astLib/commit/6844b308fb9ff1a71486dff98793bfec1ed13349
|
||||
|
||||
--- setup.py.orig 2023-10-12 15:29:16 UTC
|
||||
--- setup.py.orig 2023-10-19 08:41:05 UTC
|
||||
+++ setup.py
|
||||
@@ -36,7 +36,7 @@ class build_PyWCSTools_ext(build_ext):
|
||||
|
||||
os.chdir(sourceDir)
|
||||
cc=setuptools._distutils.ccompiler.new_compiler(setuptools._distutils.ccompiler.get_default_compiler())
|
||||
- cc.compiler_so=[sysconfig.get_config_var('CC')]+sysconfig.get_config_var('CFLAGS').split()+sysconfig.get_config_var('CFLAGSFORSHARED').split()
|
||||
+ cc.compiler_so=sysconfig.get_config_var('CC').split()+sysconfig.get_config_var('CFLAGS').split()+sysconfig.get_config_var('CFLAGSFORSHARED').split()
|
||||
|
||||
# Suppress warnings from compiling WCSTools wcssubs-3.9.5
|
||||
if "-Wstrict-prototypes" in cc.compiler_so:
|
||||
@@ -55,7 +55,7 @@ class build_PyWCSTools_ext(build_ext):
|
||||
|
||||
build_ext.build_extensions(self)
|
||||
|
||||
-setup(name='astLib',
|
||||
+setup(name='astlib',
|
||||
version='0.11.9',
|
||||
url='https://astlib.readthedocs.io',
|
||||
author='Matt Hilton & Steven Boada',
|
||||
version='0.11.10',
|
||||
packages=['astLib', 'PyWCSTools'],
|
||||
package_data={'astLib': ['data/*']},
|
||||
|
|
Loading…
Reference in a new issue