devel/stack: Add aarch64 support.
Approved by: arrowd Differential Revision: https://reviews.freebsd.org/D32221
This commit is contained in:
parent
c57db8f4de
commit
b8b32707f3
3 changed files with 31 additions and 0 deletions
|
@ -189,6 +189,12 @@ USE_CABAL= Glob-0.10.1_1 \
|
||||||
|
|
||||||
.include <bsd.port.pre.mk>
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
|
.if ${ARCH} == aarch64
|
||||||
|
# Keep it in sync with LLVM_VERSION in lang/ghc
|
||||||
|
LLVM_VERSION= 10
|
||||||
|
RUN_DEPENDS+= llc${LLVM_VERSION}:devel/llvm${LLVM_VERSION}
|
||||||
|
.endif
|
||||||
|
|
||||||
.if ${OSVERSION} >= 1300078 && ${ARCH} != powerpc64
|
.if ${OSVERSION} >= 1300078 && ${ARCH} != powerpc64
|
||||||
LIB_DEPENDS+= libncursesw.so.8:misc/compat12x
|
LIB_DEPENDS+= libncursesw.so.8:misc/compat12x
|
||||||
.endif
|
.endif
|
||||||
|
|
|
@ -0,0 +1,13 @@
|
||||||
|
https://github.com/haskell-crypto/cryptonite/issues/350
|
||||||
|
|
||||||
|
--- _cabal_deps/cryptonite-0.29/cbits/decaf/include/word.h.orig 2019-09-08 00:46:48 UTC
|
||||||
|
+++ _cabal_deps/cryptonite-0.29/cbits/decaf/include/word.h
|
||||||
|
@@ -238,7 +238,7 @@ malloc_vector(size_t size) {
|
||||||
|
/* PERF: vectorize vs unroll */
|
||||||
|
#ifdef __clang__
|
||||||
|
#if 100*__clang_major__ + __clang_minor__ > 305
|
||||||
|
-#define UNROLL _Pragma("clang loop unroll(full)")
|
||||||
|
+//#define UNROLL _Pragma("clang loop unroll(full)")
|
||||||
|
#endif
|
||||||
|
#endif
|
||||||
|
|
12
devel/stack/files/patch-src_Stack_Setup.hs
Normal file
12
devel/stack/files/patch-src_Stack_Setup.hs
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
https://github.com/commercialhaskell/stack/pull/5622
|
||||||
|
|
||||||
|
--- src/Stack/Setup.hs.orig 2021-07-19 21:35:32 UTC
|
||||||
|
+++ src/Stack/Setup.hs
|
||||||
|
@@ -1266,6 +1266,7 @@ getOSKey platform =
|
||||||
|
Platform Arm Cabal.Linux -> return "linux-armv7"
|
||||||
|
Platform AArch64 Cabal.Linux -> return "linux-aarch64"
|
||||||
|
Platform Sparc Cabal.Linux -> return "linux-sparc"
|
||||||
|
+ Platform AArch64 Cabal.FreeBSD -> return "freebsd-aarch64"
|
||||||
|
Platform arch os -> throwM $ UnsupportedSetupCombo os arch
|
||||||
|
|
||||||
|
downloadOrUseLocal
|
Loading…
Reference in a new issue