- Update to 0.3.17
* Switch to JSON API to work around XMLRPC API update Approved by: eadler, itetcu (mentors, implicit)
This commit is contained in:
parent
8a79a9dcc0
commit
b8bb8f7ce9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=298345
6 changed files with 18 additions and 56 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= pithos
|
||||
PORTVERSION= 0.3.14
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.3.17
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= DEBIAN
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
|
||||
|
@ -35,7 +34,7 @@ PYDISTUTILS_PKGNAME= ${PORTNAME}
|
|||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e "s,../data/,${DATADIR}/," ${WRKSRC}/pithos/pithosconfig.py
|
||||
${REINPLACE_CMD} -e "s,Icon=pithos,${DATADIR}/media/icon.png," ${WRKSRC}/pithos.desktop.in
|
||||
${REINPLACE_CMD} -e "s,Icon=pithos,${DATADIR}/media/icon.png," ${WRKSRC}/pithos.desktop
|
||||
|
||||
post-install:
|
||||
@${INSTALL} -o ${BINOWN} -g ${BINGRP} -m 555 \
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (pithos_0.3.14.orig.tar.gz) = 94bddb70259712d5605de461e7d2cf816d5b0b65ffedf35cee71b2d1f7041bc5
|
||||
SIZE (pithos_0.3.14.orig.tar.gz) = 141370
|
||||
SHA256 (pithos_0.3.17.orig.tar.gz) = ef6ee1545fa60b065b0043d79fe89fd1c1b70fe4ae944055d2c7b9d890cf1bde
|
||||
SIZE (pithos_0.3.17.orig.tar.gz) = 141332
|
||||
|
|
|
@ -1,8 +0,0 @@
|
|||
--- ./bin/pithos.orig 2011-12-14 16:33:47.000000000 -0800
|
||||
+++ ./bin/pithos 2012-04-16 10:58:58.472393323 -0700
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/env python
|
||||
# -*- coding: utf-8; tab-width: 4; indent-tabs-mode: nil; -*-
|
||||
### BEGIN LICENSE
|
||||
# Copyright (C) 2010 Kevin Mehall <km@kevinmehall.net>
|
|
@ -1,31 +0,0 @@
|
|||
--- pithos/pandora/pandora.py.orig 2011-12-14 16:33:47.000000000 -0800
|
||||
+++ pithos/pandora/pandora.py 2012-04-27 13:41:25.000000000 -0700
|
||||
@@ -22,7 +22,7 @@
|
||||
from pithos.pandora.xmlrpc import *
|
||||
from pithos.pandora.blowfish import Blowfish
|
||||
|
||||
-PROTOCOL_VERSION = "33"
|
||||
+PROTOCOL_VERSION = "34"
|
||||
RPC_URL = "www.pandora.com/radio/xmlrpc/v"+PROTOCOL_VERSION+"?"
|
||||
USER_AGENT = "Mozilla/5.0 (X11; U; Linux i586; de; rv:5.0) Gecko/20100101 Firefox/5.0 (compatible; Pithos/0.3)"
|
||||
HTTP_TIMEOUT = 30
|
||||
@@ -161,12 +161,16 @@
|
||||
def connect(self, user, password):
|
||||
self.rid = "%07iP"%(int(time.time()) % 10000000)
|
||||
self.listenerId = self.authToken = None
|
||||
+
|
||||
+ logging.info("Attempting to connect...");
|
||||
+ timeurl = urllib2.urlopen("http://ridetheclown.com/s2/synctime.php");
|
||||
+ pandora_time=int(timeurl.read(),10);
|
||||
+ logging.info("Synctime is %s", pandora_time)
|
||||
|
||||
- pandora_time = self.xmlrpc_call('misc.sync', [], [], secure=True, includeTime=False)
|
||||
- pandora_time = int(re.sub(r"\D", "", pandora_decrypt(pandora_time)))
|
||||
self.time_offset = pandora_time - time.time()
|
||||
|
||||
- user = self.xmlrpc_call('listener.authenticateListener', [user, password], [], secure=True)
|
||||
+ user = self.xmlrpc_call('listener.authenticateListener', ["",user, password,"html5tuner","","","HTML5",True], [], secure=True)
|
||||
+
|
||||
|
||||
self.webAuthToken = user['webAuthToken']
|
||||
self.listenerId = user['listenerId']
|
|
@ -1,6 +1,6 @@
|
|||
--- ./setup.py.orig 2011-12-14 16:33:47.000000000 -0800
|
||||
+++ ./setup.py 2012-04-16 10:58:58.477390915 -0700
|
||||
@@ -17,67 +17,19 @@
|
||||
--- setup.py 2012-05-03 13:47:11.000000000 -0700
|
||||
+++ setup.py 2012-06-01 11:40:31.000000000 -0700
|
||||
@@ -17,74 +17,19 @@
|
||||
|
||||
###################### DO NOT TOUCH THIS (HEAD TO THE SECOND PART) ######################
|
||||
|
||||
|
@ -54,6 +54,13 @@
|
|||
- DistUtilsExtra.auto.install_auto.run(self)
|
||||
- update_data_path(self.prefix, previous_value)
|
||||
-
|
||||
-from distutils.cmd import Command
|
||||
-class OverrideI18NCommand(Command):
|
||||
- def initialize_options(self): pass
|
||||
- def finalize_options(self): pass
|
||||
- def run(self):
|
||||
- self.distribution.data_files.append(('share/applications', ['pithos.desktop']))
|
||||
-
|
||||
-from DistUtilsExtra.command.build_extra import build_extra
|
||||
-from DistUtilsExtra.command.build_icons import build_icons
|
||||
-
|
||||
|
@ -63,18 +70,16 @@
|
|||
name='pithos',
|
||||
- version='0.3',
|
||||
- ext_modules=[],
|
||||
- license='GPL-3',
|
||||
+ version='0.3.14',
|
||||
+ description='Pandora.com client for the GNOME desktop',
|
||||
+ version='0.3.17',
|
||||
license='GPL-3',
|
||||
author='Kevin Mehall',
|
||||
author_email='km@kevinmehall.net',
|
||||
- description='Pandora.com client for the GNOME desktop',
|
||||
description='Pandora.com client for the GNOME desktop',
|
||||
- #long_description='Here a longer description',
|
||||
url='https://launchpad.net/pithos',
|
||||
- cmdclass={'install': InstallAndUpdateDataDirectory, 'build_icons':build_icons, 'build':build_extra}
|
||||
- cmdclass={'install': InstallAndUpdateDataDirectory, 'build_icons':build_icons, 'build':build_extra, 'build_i18n':OverrideI18NCommand}
|
||||
- )
|
||||
-
|
||||
+ license='GPL-3',
|
||||
+ packages=['pithos', 'pithos.pandora', 'pithos.plugins'],
|
||||
+ package_dir = {'pithos':'pithos'}
|
||||
+)
|
||||
|
|
|
@ -14,19 +14,16 @@ bin/pithos
|
|||
%%PYTHON_SITELIBDIR%%/pithos/pandora/fake.py
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora.py
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora_keys.py
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/xmlrpc.py
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/blowfish.pyc
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/fake.pyc
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora.pyc
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora_keys.pyc
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/xmlrpc.pyc
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/blowfish.pyo
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/fake.pyo
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora.pyo
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora_keys.pyo
|
||||
%%PYTHON_SITELIBDIR%%/pithos/pandora/xmlrpc.pyo
|
||||
%%PYTHON_SITELIBDIR%%/pithos/plugins/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/pithos/plugins/mediakeys.py
|
||||
%%PYTHON_SITELIBDIR%%/pithos/plugins/notification_icon.py
|
||||
|
|
Loading…
Reference in a new issue