- Add LICENSE
- Switch to options helpers - Fix build with clang 6.0
This commit is contained in:
parent
e810193229
commit
b8dbe5eaa1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=469959
2 changed files with 19 additions and 3 deletions
|
@ -12,10 +12,13 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION:C/\.//}-linux
|
|||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Sequel to Transball and Transball 2 THRUST-type games
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${BUILD_WRKSRC}/LICENSE
|
||||
|
||||
LIB_DEPENDS= libSGE.so:devel/sdl_sge
|
||||
|
||||
USES= gmake dos2unix zip
|
||||
DOS2UNIX_FILES= sources/main.cpp
|
||||
DOS2UNIX_FILES= sources/main.cpp sources/auxiliar.cpp
|
||||
USE_SDL= sdl image mixer sound
|
||||
|
||||
BUILD_WRKSRC= ${WRKSRC}/sources
|
||||
|
@ -37,8 +40,10 @@ post-patch:
|
|||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
|
||||
cd ${WRKSRC} && ${COPYTREE_SHARE} 'graphics sound maps demos' ${STAGEDIR}${DATADIR}/
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
@cd ${WRKSRC} && ${COPYTREE_SHARE} 'graphics sound maps demos' ${STAGEDIR}${DATADIR}/
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
games/stransball2/files/patch-sources_auxiliar.cpp
Normal file
11
games/stransball2/files/patch-sources_auxiliar.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- sources/auxiliar.cpp.orig 2018-05-14 19:20:42 UTC
|
||||
+++ sources/auxiliar.cpp
|
||||
@@ -48,7 +48,7 @@ SDL_Surface *load_maskedimage(char *imag
|
||||
mask=IMG_Load(name);
|
||||
|
||||
if (tmp==0 ||
|
||||
- mask==0) return false;
|
||||
+ mask==0) return NULL;
|
||||
|
||||
res=SDL_DisplayFormatAlpha(tmp);
|
||||
|
Loading…
Reference in a new issue