- Update to version 4.0.1

- Clarify license, update WWW homepage
- MASTER_SITE change:

MASTER_SITE has been changed to fossies.org because I have contacted
with jpgraph.net and ask if they can provide to me direct download link
instead of some php script url, but they wont.

- Convert to USES=php
- Use COPYTREE_SHARE in place of CP to make sure proper permissions
  on files are set and simplify things a bit
- Split install target to option helpers ones

PR:		211772 (based on)
Submitted by:	Eero Hanninen
This commit is contained in:
Pawel Pekala 2016-08-15 18:07:23 +00:00
parent 81b2786a94
commit b9455dd280
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=420259
4 changed files with 28 additions and 49 deletions

View file

@ -2,27 +2,26 @@
# $FreeBSD$
PORTNAME= jpgraph
PORTVERSION= 3.0.7
PORTREVISION= 1
PORTVERSION= 4.0.1
CATEGORIES= graphics
MASTER_SITES= http://hem.bredband.net/jpgraph2/
PKGNAMESUFFIX= 2
MASTER_SITES= http://fossies.org/linux/www/
MAINTAINER= ports@FreeBSD.org
COMMENT= Draw both "quick and dirty" graphs with a minimum of code
LICENSE= jpgraph
LICENSE_NAME= JpGraph license
LICENSE_FILE= ${WRKSRC}/README
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
LICENSE= QPL
LICENSE_NAME= Q PUBLIC LICENSE version 1.0
LICENSE_TEXT= Please refer to: http://www.opensource.org/licenses/qtpl.php for details
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
BROKEN_powerpc64= Does not build
USES= tar:bzip2
USES= php tar:bzip2
USE_PHP= gd
NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_PHP= gd
NO_CDROM= The free version cannot be used in a commercial context
@ -32,14 +31,23 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
@${REINPLACE_CMD} '/TrueType/ s|// ||; \
s|/usr/share/fonts/TrueType|${LOCALBASE}/share/fonts/dejavu|' \
${WRKSRC}/src/jpg-config.inc.php
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${CP} ${WRKSRC}/src/*.php ${STAGEDIR}${DATADIR}
${CP} ${WRKSRC}/src/*.dat ${STAGEDIR}${DATADIR}
${CP} -R ${WRKSRC}/src/lang ${STAGEDIR}${DATADIR}
(cd ${WRKSRC}/src && ${COPYTREE_SHARE} "*.php *.dat lang themes" \
${STAGEDIR}${DATADIR})
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${CP} -R ${WRKSRC}/docportal/* ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} ${WRKSRC}/src/Examples/* ${STAGEDIR}${EXAMPLESDIR}
${RM} ${WRKSRC}/src/Examples/jpgraph
(cd ${WRKSRC}/src/Examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
SHA256 (jpgraph-3.0.7.tar.bz2) = 412a1aaf47c7d70c5a4350d1c571ebb88c77138d9b95afd51895c44f188a03b6
SIZE (jpgraph-3.0.7.tar.bz2) = 10541173
TIMESTAMP = 1470907503
SHA256 (jpgraph-4.0.1.tar.bz2) = 256ce5c5f9c111841fcafc2fd53d5042176c91f03724bc76cbca29f23ece3771
SIZE (jpgraph-4.0.1.tar.bz2) = 12710087

View file

@ -1,30 +0,0 @@
--- src/jpgraph.php.orig 2016-02-07 15:28:23 UTC
+++ src/jpgraph.php
@@ -1286,11 +1286,11 @@ class Graph {
while( list($key,$value) = each($_GET) ) {
if( is_array($value) ) {
foreach ( $value as $k => $v ) {
- $urlarg .= '&amp;'.$key.'%5B'.$k.'%5D='.urlencode($v);
+ $urlarg .= '&amp;'.urlencode($key).'%5B'.urlencode($k).'%5D='.urlencode($v);
}
}
else {
- $urlarg .= '&amp;'.$key.'='.urlencode($value);
+ $urlarg .= '&amp;'.urlencode($key).'='.urlencode($value);
}
}
@@ -1301,11 +1301,11 @@ class Graph {
while( list($key,$value) = each($_POST) ) {
if( is_array($value) ) {
foreach ( $value as $k => $v ) {
- $urlarg .= '&amp;'.$key.'%5B'.$k.'%5D='.urlencode($v);
+ $urlarg .= '&amp;'.urlencode($key).'%5B'.urlencode($k).'%5D='.urlencode($v);
}
}
else {
- $urlarg .= '&amp;'.$key.'='.urlencode($value);
+ $urlarg .= '&amp;'.urlencode($key).'='.urlencode($value);
}
}

View file

@ -4,4 +4,4 @@ professional looking graphs which requires a very fine grain of control.
The library assigns context sensitive default values for most parameters
which helps minimize the learning curve.
WWW: http://www.aditus.nu/jpgraph/
WWW: http://jpgraph.net/