[NEW PORT] security/openvas-server: A security scanner: a fork of Nessus

OpenVAS stands for Open Vulnerability Assessment System and
	is a network security scanner with associated tools like a
	graphical user fontend. The core is a server component with
	a set of network vulnerability tests (NVTs) to detect
	security problems in remote systems and applications.

	WWW: http://www.openvas.org/

PR:		ports/123128
Submitted by:	Tomoyuki Sakurai <cherry@trombik.org>
This commit is contained in:
Edwin Groothuis 2008-06-04 13:18:59 +00:00
parent cbc685fd82
commit b998e4e008
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=214314
10 changed files with 145 additions and 0 deletions

View file

@ -317,6 +317,7 @@
SUBDIR += openvas-libnasl
SUBDIR += openvas-libraries
SUBDIR += openvas-plugins
SUBDIR += openvas-server
SUBDIR += openvpn
SUBDIR += openvpn-admin
SUBDIR += openvpn-auth-ldap

View file

@ -0,0 +1,29 @@
# New ports collection makefile for: openvas-server
# Date created: 2008-04-26
# Whom: Tomoyuki Sakurai <cherry@trombik.org>
#
# $FreeBSD$
#
PORTNAME= openvas-server
PORTVERSION= 1.0.0
CATEGORIES= security
MASTER_SITES= http://wald.intevation.org/frs/download.php/407/
MAINTAINER= cherry@trombik.org
COMMENT= A security scanner: a fork of Nessus
LIB_DEPENDS= openvas.1:${PORTSDIR}/security/openvas-libraries \
openvasnasl.1:${PORTSDIR}/security/openvas-libnasl
GNU_CONFIGURE= yes
# XXX openvas-mkcert uses gettext
USE_GETTEXT= yes
USE_RC_SUBR= openvasd
MAN1= openvas-check-signature.1 openvas-mkrand.1
MAN8= openvasd.8 openvas-adduser.8 openvas-rmuser.8 openvas-mkcert.8
.include "${.CURDIR}/../../security/openvas-server/Makefile.common"
.include <bsd.port.mk>

View file

@ -0,0 +1,4 @@
CONFIGURE_ARGS+= --includedir=${LOCALBASE}/include \
--localstatedir=${PREFIX}/openvas \
--sharedstatedir=${PREFIX}/openvas/com \
--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}

View file

@ -0,0 +1,3 @@
MD5 (openvas-server-1.0.0.tar.gz) = fbea2077375a4dfc8e97cbdeec1cc0da
SHA256 (openvas-server-1.0.0.tar.gz) = 72ee788c0e79934d3a8220a2acff80851324227093f91fc37564097a2e44b68b
SIZE (openvas-server-1.0.0.tar.gz) = 289660

View file

@ -0,0 +1,34 @@
#!/bin/sh
# Start or stop openvasd
# $FreeBSD$
# PROVIDE: openvasd
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: shutdown
#
prefix=%%PREFIX%%
# Define these openvasd_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/openvasd
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
[ -z "$openvasd_enable" ] && openvasd_enable="NO" # Disable openvasd
#openvasd_program="${prefix}/sbin/openvasd" # Location of openvasd
openvasd_flags="-D -q" # Flags to openvasd program
. %%RC_SUBR%%
name="openvasd"
rcvar=`set_rcvar`
command="${prefix}/sbin/openvasd"
pidfile="/var/run/openvasd.pid"
required_files="${prefix}/etc/openvas/openvasd.conf"
load_rc_config $name
run_rc_command "$1"

View file

@ -0,0 +1,11 @@
--- configure.orig 2008-04-27 14:15:10.000000000 +0900
+++ configure 2008-04-27 14:15:27.000000000 +0900
@@ -12073,7 +12073,7 @@
OPENVASD_CONFDIR='${sysconfdir}'
OPENVASD_STATEDIR='${localstatedir}/lib/openvas'
-OPENVASD_PIDDIR='${localstatedir}/run'
+OPENVASD_PIDDIR='/var/run'
OPENVASD_SHAREDSTATEDIR='${sharedstatedir}/lib/openvas'
OPENVASD_DATADIR='${sysconfdir}/openvas'
OPENVASD_LIBDIR='${libdir}/openvas'

View file

@ -0,0 +1,11 @@
--- openvas.tmpl.in.orig 2008-04-27 00:54:18.000000000 +0900
+++ openvas.tmpl.in 2008-04-27 00:54:45.000000000 +0900
@@ -36,7 +36,7 @@
srcdir=${rootdir}/src
libsdir=${rootdir}/libs
top_builddir = @PWDD@
-include= -I. -I$(rootdir)/include
+include= -I. -I$(rootdir)/include -I$(includedir)
INSTALL=@INSTALL@
INSTALL_DIR=@INSTALL_DIR@
installuser=@installuser@

View file

@ -0,0 +1,11 @@
--- openvasd/openvas-check-signature.c.orig 2008-04-27 00:56:59.000000000 +0900
+++ openvasd/openvas-check-signature.c 2008-04-27 00:57:55.000000000 +0900
@@ -43,7 +43,7 @@
#include <includes.h>
#include <gnutls/gnutls.h>
#include <gnutls/x509.h>
-
+#include <getopt.h>
void
print_tls_error(char *txt, int err)

View file

@ -0,0 +1,6 @@
OpenVAS stands for Open Vulnerability Assessment System and is a network
security scanner with associated tools like a graphical user fontend. The core
is a server component with a set of network vulnerability tests (NVTs) to
detect security problems in remote systems and applications.
WWW: http://www.openvas.org/

View file

@ -0,0 +1,35 @@
@comment $FreeBSD$
bin/openvas-mkcert-client
bin/openvasd-config
bin/openvas-mkrand
sbin/openvasd
sbin/openvas-check-signature
sbin/openvas-adduser
sbin/openvas-rmuser
sbin/openvas-mkcert
openvas/lib/openvas/openvas-services
include/openvas/config.h
include/openvas/includes.h
include/openvas/nessusicmp.h
include/openvas/nessusip.h
include/openvas/nessusraw.h
include/openvas/nessustcp.h
include/openvas/nessusudp.h
include/openvas/openvas-devel.h
include/openvas/threadcompat.h
@dirrmtry openvas/run
@dirrmtry openvas/log/openvas
@dirrmtry openvas/log
@dirrmtry openvas/lib/openvas/users
@dirrmtry openvas/lib/openvas/tmp
@dirrmtry openvas/lib/openvas/logs
@dirrmtry openvas/lib/openvas/jobs
@dirrmtry openvas/lib/openvas/CA
@dirrmtry openvas/lib/openvas
@dirrmtry openvas/lib
@dirrmtry openvas/com/openvas/CA
@dirrmtry openvas/com/openvas
@dirrmtry openvas/com
@dirrmtry openvas
@dirrmtry etc/openvas/gnupg
@dirrmtry etc/openvas