NASA Open Source Parametric Geometry

OpenVSP allows the user to create a 3D model of an aircraft defined by
common engineering parameters. This model can be processed into
formats suitable for engineering analysis.

WWW: http://www.openvsp.org/

PR:		ports/166825
Submitted by:	Fernando Apesteguia <fernando.apesteguia@gmail.com>
This commit is contained in:
Pawel Pekala 2012-04-22 12:06:12 +00:00
parent 1ac8535d32
commit b9c8e3ecb7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=295250
5 changed files with 67 additions and 0 deletions

View file

@ -64,6 +64,7 @@
SUBDIR += opencascade
SUBDIR += opencascade-tutorial
SUBDIR += openscad
SUBDIR += openvsp
SUBDIR += p5-GDS2
SUBDIR += p5-Verilog-Perl
SUBDIR += pcb

46
cad/openvsp/Makefile Normal file
View file

@ -0,0 +1,46 @@
# Port makefile for: openvsp
# Date created: Apr 10 2012
# Whom: Fernando Apesteguia <fernando.apesteguia@gmail.com>
#
# $FreeBSD$
PORTNAME= openvsp
PORTVERSION= 2.0
CATEGORIES= cad
MASTER_SITES= https://nodeload.github.com/OpenVSP/OpenVSP/tarball/
DISTNAME= OpenVSP_${PORTVERSION}_Community
MAINTAINER= fernando.apesteguia@gmail.com
COMMENT= Create a 3D model of an aircraft defined by engineering parameters
BUILD_DEPENDS= ${LOCALBASE}/lib/libopenNURBS.a:${PORTSDIR}/graphics/opennurbs
LIB_DEPENDS+= fltk:${PORTSDIR}/x11-toolkits/fltk
LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
LIB_DEPENDS+= png:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/OpenVSP-OpenVSP-574d7c3/src
USE_CMAKE= yes
USE_DOS2UNIX= yes
USE_XORG= xinerama xft
USE_GNOME= libxml2
PORTEXAMPLES= *
INSTALL_PORTEXAMPLES= @(cd ${WRKSRC}/../examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
PLIST_FILES= bin/vsp
CFLAGS+= -I${LOCALBASE}/include/openNURBS
do-fetch:
${FETCH_BINARY} -o ${DISTDIR}/${DISTNAME}.tar.gz ${MASTER_SITES}${DISTNAME}
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/vsp/vsp ${PREFIX}/bin
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_PORTEXAMPLES}
.endif
.include <bsd.port.mk>

2
cad/openvsp/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (OpenVSP_2.0_Community.tar.gz) = 7086327a60d5952ef3e5780e99d4313f2a10a7f713b35470e104e07fccb6e856
SIZE (OpenVSP_2.0_Community.tar.gz) = 2876175

View file

@ -0,0 +1,11 @@
--- /home/fernape/porting/openvsp/original/OpenVSP_2.0_community_src/src/xmlvsp/CMakeLists.txt 2012-04-04 21:03:54.000000000 +0200
+++ xmlvsp/CMakeLists.txt 2012-04-04 20:29:08.000000000 +0200
@@ -2,7 +2,7 @@
FIND_PACKAGE(LibXml2 REQUIRED)
-INCLUDE_DIRECTORIES( ${LIBXML2_INCLUDE_DIR})
+INCLUDE_DIRECTORIES( ${LIBXML2_INCLUDE_DIR} /usr/local/include)
SET(XMLVSP_INCLUDE_DIR ${CMAKE_CURRENT_SOURCE_DIR} CACHE PATH "Path to XML wrapper header.")

7
cad/openvsp/pkg-descr Normal file
View file

@ -0,0 +1,7 @@
NASA Open Source Parametric Geometry
OpenVSP allows the user to create a 3D model of an aircraft defined by
common engineering parameters. This model can be processed into
formats suitable for engineering analysis.
WWW: http://www.openvsp.org/