New Port mail/twhttpd
Secure HTTP Proxy PR: ports/43356 Submitted by: opr@bsdaemon.be <opr@bsdaemon.be>
This commit is contained in:
parent
9864cd3f7c
commit
ba7d06e99b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72331
11 changed files with 101 additions and 0 deletions
|
@ -267,6 +267,7 @@
|
||||||
SUBDIR += tmda
|
SUBDIR += tmda
|
||||||
SUBDIR += tpop3d
|
SUBDIR += tpop3d
|
||||||
SUBDIR += turba
|
SUBDIR += turba
|
||||||
|
SUBDIR += twhttpd
|
||||||
SUBDIR += vbsfilter
|
SUBDIR += vbsfilter
|
||||||
SUBDIR += vm
|
SUBDIR += vm
|
||||||
SUBDIR += vm-pop3d
|
SUBDIR += vm-pop3d
|
||||||
|
|
27
mail/twhttpd/Makefile
Normal file
27
mail/twhttpd/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
||||||
|
# New ports collection makefile for: twhttpd-1.0
|
||||||
|
# Date created: 25 Sep 2002
|
||||||
|
# Whom: Pieter Danhieux <opr@bsdaemon.be>
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= twhttpd
|
||||||
|
PORTVERSION= 1.0
|
||||||
|
CATEGORIES= mail
|
||||||
|
MASTER_SITES= http://www.geocities.com/samngms/twhttpd/download/
|
||||||
|
DISTNAME= twhttpd-${PORTVERSION}
|
||||||
|
|
||||||
|
MAINTAINER= opr@bsdaemon.be
|
||||||
|
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
USE_GMAKE= yes
|
||||||
|
USE_AUTOCONF= yes
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
@${INSTALL_PROGRAM} -o root -g wheel -m 0755 ${WRKSRC}/twhttpd ${PREFIX}/sbin/twhttpd
|
||||||
|
@${INSTALL} -o root -g wheel -m 0755 ${WRKSRC}/rm_cache ${PREFIX}/sbin/rm_cache
|
||||||
|
@${INSTALL} -o root -g wheel -m 0700 ${WRKSRC}/twhttpd.cfg ${PREFIX}/etc/twhttpd.cfg.sample
|
||||||
|
|
||||||
|
post-install:
|
||||||
|
@${CAT} ${PKGMESSAGE}
|
||||||
|
.include <bsd.port.mk>
|
1
mail/twhttpd/distinfo
Normal file
1
mail/twhttpd/distinfo
Normal file
|
@ -0,0 +1 @@
|
||||||
|
MD5 (twhttpd-1.0.tar.gz) = 09b49b470e689fc1e5917b9503cea71d
|
11
mail/twhttpd/files/patch-aa
Normal file
11
mail/twhttpd/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- config.h.orig Sat Aug 31 05:40:23 2002
|
||||||
|
+++ config.h Wed Sep 25 12:01:58 2002
|
||||||
|
@@ -31,7 +31,7 @@
|
||||||
|
#define CURRENT_DIR "./"
|
||||||
|
#define DEFAULT_CACHE_DIR ".cache"
|
||||||
|
#define DEFAULT_COOKIE_DIR ".cookie"
|
||||||
|
-#define DEFAULT_CONFIG_FILE "/etc/twhttpd.cfg"
|
||||||
|
+#define DEFAULT_CONFIG_FILE "/usr/local/etc/twhttpd.cfg"
|
||||||
|
|
||||||
|
#define SOCKET_TIMEOUT 45 /* socket timeout value */
|
||||||
|
#define CONNECT_TIMEOUT 15 /* connect timeout value */
|
16
mail/twhttpd/files/patch-ab
Normal file
16
mail/twhttpd/files/patch-ab
Normal file
|
@ -0,0 +1,16 @@
|
||||||
|
--- httplog.c.orig Sat Dec 8 15:15:44 2001
|
||||||
|
+++ httplog.c Wed Sep 25 12:02:28 2002
|
||||||
|
@@ -40,6 +40,7 @@
|
||||||
|
#include <time.h>
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <syslog.h>
|
||||||
|
+#include <arpa/inet.h>
|
||||||
|
#include <netinet/in.h>
|
||||||
|
#include <sys/time.h>
|
||||||
|
#include <sys/socket.h>
|
||||||
|
@@ -151,4 +152,4 @@
|
||||||
|
}
|
||||||
|
}
|
||||||
|
}
|
||||||
|
-}
|
||||||
|
+}
|
11
mail/twhttpd/files/patch-ac
Normal file
11
mail/twhttpd/files/patch-ac
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- twhttpd.c.orig Sat Aug 31 05:16:35 2002
|
||||||
|
+++ twhttpd.c Wed Sep 25 12:02:49 2002
|
||||||
|
@@ -33,7 +33,7 @@
|
||||||
|
#include <signal.h>
|
||||||
|
#include <time.h>
|
||||||
|
#include <unistd.h>
|
||||||
|
-#include <wait.h>
|
||||||
|
+#include <sys/wait.h>
|
||||||
|
#include <netinet/in.h>
|
||||||
|
#include <sys/socket.h>
|
||||||
|
#include <sys/types.h>
|
11
mail/twhttpd/files/patch-ad
Normal file
11
mail/twhttpd/files/patch-ad
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- configure.in.orig Wed Sep 25 12:41:35 2002
|
||||||
|
+++ configure.in Wed Sep 25 12:41:44 2002
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
AC_PROG_LEX
|
||||||
|
|
||||||
|
dnl Checks for libraries.
|
||||||
|
-AC_CHECK_LIB(pwdb, crypt)
|
||||||
|
+AC_CHECK_LIB(crypt, crypt)
|
||||||
|
AC_CHECK_LIB(socket, bind)
|
||||||
|
AC_CHECK_LIB(nsl, gethostbyname)
|
||||||
|
|
1
mail/twhttpd/pkg-comment
Normal file
1
mail/twhttpd/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
||||||
|
Secure HTTP Proxy
|
14
mail/twhttpd/pkg-descr
Normal file
14
mail/twhttpd/pkg-descr
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
twhttpd is a powerful secure HTTP proxy.
|
||||||
|
twhttpd protects your internal Web server by acting as an inbound proxy
|
||||||
|
(like a reserve Squid proxy). It can also work as a secure outbound proxy
|
||||||
|
to protect your browser client. It allows you to inspect almost every
|
||||||
|
detail of the HTTP protocol headers, including the URL request line, the
|
||||||
|
server version, user-agent, referrer, cookie, query, etc., in a
|
||||||
|
easy-to-use script-like configuration file.
|
||||||
|
This program is generally considered an "Expert Tool"; you will need
|
||||||
|
knowledge of the HTTP protocol to configure the proxy properly.
|
||||||
|
|
||||||
|
WWW: http://www.geocities.com/samngms/twhttpd/
|
||||||
|
|
||||||
|
- Pieter
|
||||||
|
opr@bsdaemon.be
|
5
mail/twhttpd/pkg-message
Normal file
5
mail/twhttpd/pkg-message
Normal file
|
@ -0,0 +1,5 @@
|
||||||
|
***************************************************************************
|
||||||
|
twhttpd is installed in /usr/local/sbin/
|
||||||
|
Now copy /usr/local/etc/twhttpd.cfg.sample to twhttpd.cfg,
|
||||||
|
and edit it.
|
||||||
|
***************************************************************************
|
3
mail/twhttpd/pkg-plist
Normal file
3
mail/twhttpd/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
sbin/twhttpd
|
||||||
|
sbin/rm_cache
|
||||||
|
etc/twhttpd.cfg.sample
|
Loading…
Reference in a new issue