- fix ldap support

--with-ldap switches on LDAP library linking in apr-util
  --enable-ldap option switches on the LDAP caching module
  --enable-auth-ldap option switches on the LDAP authentication module
  also apply a custom patch to fix the linking
- add a missing quote to OPTIONS desc
- ldap is not in the default package, so no PORTREVISION bump

PR:             ports/128079
Reported by:    koitsu, skreuzer
With Hat:       apache@
This commit is contained in:
Philip M. Gollucci 2010-05-07 04:59:28 +00:00
parent cb88b0313e
commit bac9ac8d0a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=253880
2 changed files with 15 additions and 4 deletions

View file

@ -45,7 +45,7 @@ OPTIONS= \
DEBUG "Enable debugging" Off \
EXCEPTION_HOOK "Enable Exception Hook" On \
LDAP "Enable LDAP Support" Off \
THREADS "Enable threads in apr Off
THREADS "Enable threads in apr" Off
.if defined(WITH_KQUEUE_SUPPORT)
EXTRA_PATCHES+= ${FILESDIR}/exp-apr-kqueue.patch
@ -136,9 +136,9 @@ APACHEDIR= ${MASTERDIR}
.if defined (WITH_LDAP) || defined (WITH_LDAP_MODULES)
USE_OPENLDAP= YES
CONFIGURE_ARGS+= --with-ldap \
--with-ldap-lib="${LOCALBASE}/lib" \
--with-ldap-include="${LOCALBASE}/include"
CONFIGURE_ARGS+= --enable-ldap=shared --enable-auth-ldap --with-ldap \
--with-ldap-lib="${LOCALBASE}/lib" \
--with-ldap-include="${LOCALBASE}/include"
.endif
.include "${APACHEDIR}/Makefile.doc"

View file

@ -0,0 +1,11 @@
--- modules/experimental/config.m4.orig 2010-05-07 00:41:44.796911069 -0400
+++ modules/experimental/config.m4 2010-05-07 00:41:27.000000000 -0400
@@ -33,7 +33,7 @@
ldap_objects="util_ldap.lo util_ldap_cache.lo util_ldap_cache_mgr.lo"
APACHE_MODULE(ldap, LDAP caching and connection pooling services, $ldap_objects, , no)
-auth_ldap_objects="mod_auth_ldap.lo"
+auth_ldap_objects="mod_auth_ldap.lo $ldap_objects"
APACHE_MODULE(auth_ldap, LDAP based authentication, $auth_ldap_objects, , no)
APACHE_MODPATH_FINISH