o Fix build on -CURRENT.

o Use REINPLACE_CMD instead of a hard wired patch, which breaks this port
  on -CURRENT.
o Use tab instead of space, BTW.

Submitted by:	bento
This commit is contained in:
Clive Lin 2002-09-28 20:46:51 +00:00
parent 63eb0ebbbf
commit bb82744a29
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=67192
2 changed files with 4 additions and 15 deletions

View file

@ -13,11 +13,11 @@ MASTER_SITES= http://www.cc.ncu.edu.tw/~center5/product/qe/ \
MAINTAINER= statue@freebsd.sinica.edu.tw
HAS_CONFIGURE= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
post-configure:
@(cd ${WRKSRC} && \
${PATCH} < ${FILESDIR}/post-patch-Makefile )
@${REINPLACE_CMD} -e '49s,-s,,' ${WRKSRC}/src/Makefile
.include <bsd.port.mk>

View file

@ -1,11 +0,0 @@
--- src/Makefile.orig Tue Jun 26 16:33:00 2001
+++ src/Makefile Tue Jun 26 16:33:09 2001
@@ -46,7 +46,7 @@
AUTOHEADER = autoheader
INSTALL = /usr/bin/install -c -o root -g wheel
-INSTALL_PROGRAM = install -c -s -o root -g wheel -m 555 $(AM_INSTALL_PROGRAM_FLAGS)
+INSTALL_PROGRAM = install -c -o root -g wheel -m 555 $(AM_INSTALL_PROGRAM_FLAGS)
INSTALL_DATA = install -c -o root -g wheel -m 444
INSTALL_SCRIPT = install -c -o root -g wheel -m 555
transform = s,x,x,