Add harfbuzz. Harfbuzz is a OpenType text shaping engine.
The extra-src_hb-open-type-private.hh patch is from pkgsrc to fix the build with base gcc.
This commit is contained in:
parent
62166b29b3
commit
bb91f3fc11
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315531
7 changed files with 639 additions and 0 deletions
|
@ -102,6 +102,7 @@
|
|||
SUBDIR += gutenprint-foomatic
|
||||
SUBDIR += gutenprint-ijs
|
||||
SUBDIR += gv
|
||||
SUBDIR += harfbuzz
|
||||
SUBDIR += hp2xx
|
||||
SUBDIR += hpijs
|
||||
SUBDIR += hplip
|
||||
|
|
29
print/harfbuzz/Makefile
Normal file
29
print/harfbuzz/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# Created by: Koop Mast <kwm@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= harfbuzz
|
||||
PORTVERSION= 0.9.14
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://www.freedesktop.org/software/harfbuzz/release/
|
||||
|
||||
MAINTAINER= kwm@FreeBSD.org
|
||||
COMMENT= OpenType text shaping engine
|
||||
|
||||
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_PKGCONFIG= build
|
||||
USES= pathfix
|
||||
USE_GNOME= glib20
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-silent-rules
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 1000024
|
||||
EXTRA_PATCHES= ${PATCHDIR}/extra-src_hb-open-type-private.hh
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
print/harfbuzz/distinfo
Normal file
2
print/harfbuzz/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (harfbuzz-0.9.14.tar.bz2) = d07c0ffdbbbfdfbb6c65e73fe9c76466e87dbf04b094cbd0abf5fd7d571a4004
|
||||
SIZE (harfbuzz-0.9.14.tar.bz2) = 900959
|
25
print/harfbuzz/files/extra-src_hb-open-type-private.hh
Normal file
25
print/harfbuzz/files/extra-src_hb-open-type-private.hh
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-src_hb-open-type-private.hh,v 1.1 2013/02/03 05:13:26 ryoon Exp $
|
||||
|
||||
--- src/hb-open-type-private.hh.orig 2013-01-08 22:13:42.000000000 +0000
|
||||
+++ src/hb-open-type-private.hh
|
||||
@@ -941,6 +941,11 @@ struct HeadlessArrayOf
|
||||
DEFINE_SIZE_ARRAY (sizeof (USHORT), array);
|
||||
};
|
||||
|
||||
+#if __GNUC__ && (__GNUC__ < 4 || (__GNUC__ == 4 && __GNUC_MINOR__ < 4))
|
||||
+// work around GCC 4.3 bug where the search() function gets improperly
|
||||
+// optimized away from some instantiations of this template
|
||||
+#pragma GCC visibility push(default)
|
||||
+#endif
|
||||
|
||||
/* An array with sorted elements. Supports binary searching. */
|
||||
template <typename Type>
|
||||
@@ -968,5 +973,8 @@ struct SortedArrayOf : ArrayOf<Type> {
|
||||
|
||||
} /* namespace OT */
|
||||
|
||||
+#if __GNUC__ && (__GNUC__ < 4 || (__GNUC__ == 4 && __GNUC_MINOR__ < 4))
|
||||
+#pragma GCC visibility pop
|
||||
+#endif
|
||||
|
||||
#endif /* HB_OPEN_TYPE_PRIVATE_HH */
|
556
print/harfbuzz/files/patch-configure
Normal file
556
print/harfbuzz/files/patch-configure
Normal file
|
@ -0,0 +1,556 @@
|
|||
--- configure.orig 2013-03-28 14:35:03.000000000 +0000
|
||||
+++ configure 2013-03-28 14:35:49.000000000 +0000
|
||||
@@ -17114,553 +17114,20 @@
|
||||
|
||||
|
||||
|
||||
-pkg_failed=no
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for CAIRO" >&5
|
||||
-$as_echo_n "checking for CAIRO... " >&6; }
|
||||
-
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$CAIRO_CFLAGS"; then
|
||||
- pkg_cv_CAIRO_CFLAGS="$CAIRO_CFLAGS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"cairo >= 1.8.0\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "cairo >= 1.8.0") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_CAIRO_CFLAGS=`$PKG_CONFIG --cflags "cairo >= 1.8.0" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$CAIRO_LIBS"; then
|
||||
- pkg_cv_CAIRO_LIBS="$CAIRO_LIBS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"cairo >= 1.8.0\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "cairo >= 1.8.0") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_CAIRO_LIBS=`$PKG_CONFIG --libs "cairo >= 1.8.0" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-if test $pkg_failed = yes; then
|
||||
-
|
||||
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
||||
- _pkg_short_errors_supported=yes
|
||||
-else
|
||||
- _pkg_short_errors_supported=no
|
||||
-fi
|
||||
- if test $_pkg_short_errors_supported = yes; then
|
||||
- CAIRO_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "cairo >= 1.8.0"`
|
||||
- else
|
||||
- CAIRO_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "cairo >= 1.8.0"`
|
||||
- fi
|
||||
- # Put the nasty error message in config.log where it belongs
|
||||
- echo "$CAIRO_PKG_ERRORS" >&5
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- have_cairo=false
|
||||
-elif test $pkg_failed = untried; then
|
||||
- have_cairo=false
|
||||
-else
|
||||
- CAIRO_CFLAGS=$pkg_cv_CAIRO_CFLAGS
|
||||
- CAIRO_LIBS=$pkg_cv_CAIRO_LIBS
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
- have_cairo=true
|
||||
-fi
|
||||
-if $have_cairo; then
|
||||
-
|
||||
-$as_echo "#define HAVE_CAIRO 1" >>confdefs.h
|
||||
-
|
||||
-fi
|
||||
- if $have_cairo; then
|
||||
- HAVE_CAIRO_TRUE=
|
||||
- HAVE_CAIRO_FALSE='#'
|
||||
-else
|
||||
HAVE_CAIRO_TRUE='#'
|
||||
HAVE_CAIRO_FALSE=
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-pkg_failed=no
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for CAIRO_FT" >&5
|
||||
-$as_echo_n "checking for CAIRO_FT... " >&6; }
|
||||
-
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$CAIRO_FT_CFLAGS"; then
|
||||
- pkg_cv_CAIRO_FT_CFLAGS="$CAIRO_FT_CFLAGS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"cairo-ft\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "cairo-ft") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_CAIRO_FT_CFLAGS=`$PKG_CONFIG --cflags "cairo-ft" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$CAIRO_FT_LIBS"; then
|
||||
- pkg_cv_CAIRO_FT_LIBS="$CAIRO_FT_LIBS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"cairo-ft\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "cairo-ft") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_CAIRO_FT_LIBS=`$PKG_CONFIG --libs "cairo-ft" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-if test $pkg_failed = yes; then
|
||||
-
|
||||
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
||||
- _pkg_short_errors_supported=yes
|
||||
-else
|
||||
- _pkg_short_errors_supported=no
|
||||
-fi
|
||||
- if test $_pkg_short_errors_supported = yes; then
|
||||
- CAIRO_FT_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "cairo-ft"`
|
||||
- else
|
||||
- CAIRO_FT_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "cairo-ft"`
|
||||
- fi
|
||||
- # Put the nasty error message in config.log where it belongs
|
||||
- echo "$CAIRO_FT_PKG_ERRORS" >&5
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- have_cairo_ft=false
|
||||
-elif test $pkg_failed = untried; then
|
||||
- have_cairo_ft=false
|
||||
-else
|
||||
- CAIRO_FT_CFLAGS=$pkg_cv_CAIRO_FT_CFLAGS
|
||||
- CAIRO_FT_LIBS=$pkg_cv_CAIRO_FT_LIBS
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
- have_cairo_ft=true
|
||||
-fi
|
||||
-if $have_cairo_ft; then
|
||||
|
||||
-$as_echo "#define HAVE_CAIRO_FT 1" >>confdefs.h
|
||||
-
|
||||
-fi
|
||||
- if $have_cairo_ft; then
|
||||
- HAVE_CAIRO_FT_TRUE=
|
||||
- HAVE_CAIRO_FT_FALSE='#'
|
||||
-else
|
||||
HAVE_CAIRO_FT_TRUE='#'
|
||||
HAVE_CAIRO_FT_FALSE=
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-pkg_failed=no
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for ICU" >&5
|
||||
-$as_echo_n "checking for ICU... " >&6; }
|
||||
-
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$ICU_CFLAGS"; then
|
||||
- pkg_cv_ICU_CFLAGS="$ICU_CFLAGS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-uc\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "icu-uc") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_ICU_CFLAGS=`$PKG_CONFIG --cflags "icu-uc" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$ICU_LIBS"; then
|
||||
- pkg_cv_ICU_LIBS="$ICU_LIBS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-uc\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "icu-uc") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_ICU_LIBS=`$PKG_CONFIG --libs "icu-uc" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-if test $pkg_failed = yes; then
|
||||
-
|
||||
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
||||
- _pkg_short_errors_supported=yes
|
||||
-else
|
||||
- _pkg_short_errors_supported=no
|
||||
-fi
|
||||
- if test $_pkg_short_errors_supported = yes; then
|
||||
- ICU_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "icu-uc"`
|
||||
- else
|
||||
- ICU_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "icu-uc"`
|
||||
- fi
|
||||
- # Put the nasty error message in config.log where it belongs
|
||||
- echo "$ICU_PKG_ERRORS" >&5
|
||||
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- have_icu=false
|
||||
-elif test $pkg_failed = untried; then
|
||||
- have_icu=false
|
||||
-else
|
||||
- ICU_CFLAGS=$pkg_cv_ICU_CFLAGS
|
||||
- ICU_LIBS=$pkg_cv_ICU_LIBS
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
- have_icu=true
|
||||
-fi
|
||||
-if test "$have_icu" != "true"; then
|
||||
- # Extract the first word of "icu-config", so it can be a program name with args.
|
||||
-set dummy icu-config; ac_word=$2
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||
-$as_echo_n "checking for $ac_word... " >&6; }
|
||||
-if ${ac_cv_path_icu_config+:} false; then :
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- case $icu_config in
|
||||
- [\\/]* | ?:[\\/]*)
|
||||
- ac_cv_path_icu_config="$icu_config" # Let the user override the test with a path.
|
||||
- ;;
|
||||
- *)
|
||||
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||
-for as_dir in $PATH
|
||||
-do
|
||||
- IFS=$as_save_IFS
|
||||
- test -z "$as_dir" && as_dir=.
|
||||
- for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
|
||||
- ac_cv_path_icu_config="$as_dir/$ac_word$ac_exec_ext"
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
- break 2
|
||||
- fi
|
||||
-done
|
||||
- done
|
||||
-IFS=$as_save_IFS
|
||||
-
|
||||
- test -z "$ac_cv_path_icu_config" && ac_cv_path_icu_config="no"
|
||||
- ;;
|
||||
-esac
|
||||
-fi
|
||||
-icu_config=$ac_cv_path_icu_config
|
||||
-if test -n "$icu_config"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $icu_config" >&5
|
||||
-$as_echo "$icu_config" >&6; }
|
||||
-else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-fi
|
||||
-
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for ICU by using icu-config fallback" >&5
|
||||
-$as_echo_n "checking for ICU by using icu-config fallback... " >&6; }
|
||||
- if test "$icu_config" != "no" && "$icu_config" --version >/dev/null; then
|
||||
- have_icu=true
|
||||
- # We don't use --cflags as this gives us a lot of things that we don't
|
||||
- # necessarily want, like debugging and optimization flags
|
||||
- # See man (1) icu-config for more info.
|
||||
- ICU_CFLAGS=`$icu_config --cppflags`
|
||||
- ICU_LIBS=`$icu_config --ldflags-libsonly`
|
||||
-
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
- else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- fi
|
||||
-fi
|
||||
-
|
||||
-if $have_icu; then
|
||||
- CXXFLAGS="$CXXFLAGS `$PKG_CONFIG --variable=CXXFLAGS icu-uc`"
|
||||
-
|
||||
-$as_echo "#define HAVE_ICU 1" >>confdefs.h
|
||||
-
|
||||
-fi
|
||||
- if $have_icu; then
|
||||
- HAVE_ICU_TRUE=
|
||||
- HAVE_ICU_FALSE='#'
|
||||
-else
|
||||
HAVE_ICU_TRUE='#'
|
||||
HAVE_ICU_FALSE=
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-pkg_failed=no
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for ICU_LE" >&5
|
||||
-$as_echo_n "checking for ICU_LE... " >&6; }
|
||||
-
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$ICU_LE_CFLAGS"; then
|
||||
- pkg_cv_ICU_LE_CFLAGS="$ICU_LE_CFLAGS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-le icu-uc\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "icu-le icu-uc") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_ICU_LE_CFLAGS=`$PKG_CONFIG --cflags "icu-le icu-uc" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$ICU_LE_LIBS"; then
|
||||
- pkg_cv_ICU_LE_LIBS="$ICU_LE_LIBS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-le icu-uc\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "icu-le icu-uc") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_ICU_LE_LIBS=`$PKG_CONFIG --libs "icu-le icu-uc" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-if test $pkg_failed = yes; then
|
||||
|
||||
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
||||
- _pkg_short_errors_supported=yes
|
||||
-else
|
||||
- _pkg_short_errors_supported=no
|
||||
-fi
|
||||
- if test $_pkg_short_errors_supported = yes; then
|
||||
- ICU_LE_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "icu-le icu-uc"`
|
||||
- else
|
||||
- ICU_LE_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "icu-le icu-uc"`
|
||||
- fi
|
||||
- # Put the nasty error message in config.log where it belongs
|
||||
- echo "$ICU_LE_PKG_ERRORS" >&5
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- have_icu_le=false
|
||||
-elif test $pkg_failed = untried; then
|
||||
- have_icu_le=false
|
||||
-else
|
||||
- ICU_LE_CFLAGS=$pkg_cv_ICU_LE_CFLAGS
|
||||
- ICU_LE_LIBS=$pkg_cv_ICU_LE_LIBS
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
- have_icu_le=true
|
||||
-fi
|
||||
-if test "$have_icu_le" != "true"; then
|
||||
- # Extract the first word of "icu-config", so it can be a program name with args.
|
||||
-set dummy icu-config; ac_word=$2
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||
-$as_echo_n "checking for $ac_word... " >&6; }
|
||||
-if ${ac_cv_path_icu_config+:} false; then :
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- case $icu_config in
|
||||
- [\\/]* | ?:[\\/]*)
|
||||
- ac_cv_path_icu_config="$icu_config" # Let the user override the test with a path.
|
||||
- ;;
|
||||
- *)
|
||||
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||
-for as_dir in $PATH
|
||||
-do
|
||||
- IFS=$as_save_IFS
|
||||
- test -z "$as_dir" && as_dir=.
|
||||
- for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
|
||||
- ac_cv_path_icu_config="$as_dir/$ac_word$ac_exec_ext"
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
- break 2
|
||||
- fi
|
||||
-done
|
||||
- done
|
||||
-IFS=$as_save_IFS
|
||||
-
|
||||
- test -z "$ac_cv_path_icu_config" && ac_cv_path_icu_config="no"
|
||||
- ;;
|
||||
-esac
|
||||
-fi
|
||||
-icu_config=$ac_cv_path_icu_config
|
||||
-if test -n "$icu_config"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $icu_config" >&5
|
||||
-$as_echo "$icu_config" >&6; }
|
||||
-else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-fi
|
||||
-
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for ICU_LE by using icu-config fallback" >&5
|
||||
-$as_echo_n "checking for ICU_LE by using icu-config fallback... " >&6; }
|
||||
- if test "$icu_config" != "no" && "$icu_config" --version >/dev/null; then
|
||||
- have_icu_le=true
|
||||
- # We don't use --cflags as this gives us a lot of things that we don't
|
||||
- # necessarily want, like debugging and optimization flags
|
||||
- # See man (1) icu-config for more info.
|
||||
- ICU_LE_CFLAGS=`$icu_config --cppflags`
|
||||
- ICU_LE_LIBS=`$icu_config --ldflags-libsonly --ldflags-layout`
|
||||
-
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
- else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- fi
|
||||
-fi
|
||||
-if $have_icu_le; then
|
||||
-
|
||||
-$as_echo "#define HAVE_ICU_LE 1" >>confdefs.h
|
||||
-
|
||||
-fi
|
||||
- if $have_icu_le; then
|
||||
- HAVE_ICU_LE_TRUE=
|
||||
- HAVE_ICU_LE_FALSE='#'
|
||||
-else
|
||||
HAVE_ICU_LE_TRUE='#'
|
||||
HAVE_ICU_LE_FALSE=
|
||||
-fi
|
||||
-
|
||||
-
|
||||
|
||||
-
|
||||
-pkg_failed=no
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GRAPHITE2" >&5
|
||||
-$as_echo_n "checking for GRAPHITE2... " >&6; }
|
||||
-
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$GRAPHITE2_CFLAGS"; then
|
||||
- pkg_cv_GRAPHITE2_CFLAGS="$GRAPHITE2_CFLAGS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"graphite2\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "graphite2") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_GRAPHITE2_CFLAGS=`$PKG_CONFIG --cflags "graphite2" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-if test -n "$PKG_CONFIG"; then
|
||||
- if test -n "$GRAPHITE2_LIBS"; then
|
||||
- pkg_cv_GRAPHITE2_LIBS="$GRAPHITE2_LIBS"
|
||||
- else
|
||||
- if test -n "$PKG_CONFIG" && \
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"graphite2\""; } >&5
|
||||
- ($PKG_CONFIG --exists --print-errors "graphite2") 2>&5
|
||||
- ac_status=$?
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
||||
- test $ac_status = 0; }; then
|
||||
- pkg_cv_GRAPHITE2_LIBS=`$PKG_CONFIG --libs "graphite2" 2>/dev/null`
|
||||
-else
|
||||
- pkg_failed=yes
|
||||
-fi
|
||||
- fi
|
||||
-else
|
||||
- pkg_failed=untried
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-if test $pkg_failed = yes; then
|
||||
-
|
||||
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
||||
- _pkg_short_errors_supported=yes
|
||||
-else
|
||||
- _pkg_short_errors_supported=no
|
||||
-fi
|
||||
- if test $_pkg_short_errors_supported = yes; then
|
||||
- GRAPHITE2_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "graphite2"`
|
||||
- else
|
||||
- GRAPHITE2_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "graphite2"`
|
||||
- fi
|
||||
- # Put the nasty error message in config.log where it belongs
|
||||
- echo "$GRAPHITE2_PKG_ERRORS" >&5
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
- have_graphite=false
|
||||
-elif test $pkg_failed = untried; then
|
||||
- have_graphite=false
|
||||
-else
|
||||
- GRAPHITE2_CFLAGS=$pkg_cv_GRAPHITE2_CFLAGS
|
||||
- GRAPHITE2_LIBS=$pkg_cv_GRAPHITE2_LIBS
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
- have_graphite=true
|
||||
-fi
|
||||
-if $have_graphite; then
|
||||
-
|
||||
-$as_echo "#define HAVE_GRAPHITE2 1" >>confdefs.h
|
||||
-
|
||||
-fi
|
||||
- if $have_graphite; then
|
||||
- HAVE_GRAPHITE2_TRUE=
|
||||
- HAVE_GRAPHITE2_FALSE='#'
|
||||
-else
|
||||
HAVE_GRAPHITE2_TRUE='#'
|
||||
HAVE_GRAPHITE2_FALSE=
|
||||
-fi
|
||||
|
||||
|
||||
|
3
print/harfbuzz/pkg-descr
Normal file
3
print/harfbuzz/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
HarfBuzz is an OpenType text shaping engine.
|
||||
|
||||
WWW: http://www.freedesktop.org/wiki/Software/HarfBuzz
|
23
print/harfbuzz/pkg-plist
Normal file
23
print/harfbuzz/pkg-plist
Normal file
|
@ -0,0 +1,23 @@
|
|||
bin/hb-ot-shape-closure
|
||||
bin/hb-shape
|
||||
include/harfbuzz/hb-blob.h
|
||||
include/harfbuzz/hb-buffer.h
|
||||
include/harfbuzz/hb-common.h
|
||||
include/harfbuzz/hb-font.h
|
||||
include/harfbuzz/hb-ft.h
|
||||
include/harfbuzz/hb-glib.h
|
||||
include/harfbuzz/hb-gobject.h
|
||||
include/harfbuzz/hb-ot-layout.h
|
||||
include/harfbuzz/hb-ot-tag.h
|
||||
include/harfbuzz/hb-ot.h
|
||||
include/harfbuzz/hb-set.h
|
||||
include/harfbuzz/hb-shape-plan.h
|
||||
include/harfbuzz/hb-shape.h
|
||||
include/harfbuzz/hb-unicode.h
|
||||
include/harfbuzz/hb-version.h
|
||||
include/harfbuzz/hb.h
|
||||
lib/libharfbuzz.la
|
||||
lib/libharfbuzz.so
|
||||
lib/libharfbuzz.so.914
|
||||
libdata/pkgconfig/harfbuzz.pc
|
||||
@dirrm include/harfbuzz
|
Loading…
Reference in a new issue