Snap is a simple and fast web development framework and server written in
Haskell. For more information or to download the latest version, you can visit the Snap project website. The Snap HTTP server is a high performance, epoll-enabled, iteratee-based web server library written in Haskell. Together with the "snap-core" library upon which it depends, it provides a clean and efficient Haskell programming interface to the HTTP protocol. Higher-level facilities for building web applications (like user/session management, component interfaces, data modeling, etc.) are planned but not yet implemented, so this release will mostly be of interest for those who: * need a fast and minimal HTTP API at roughly the same level of abstraction as Java servlets, or * are interested in contributing to the Snap Framework project. WWW: http://snapframework.com/ Obtained from: FreeBSD Haskell
This commit is contained in:
parent
d1ec57291f
commit
bba2b6ca97
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=279650
6 changed files with 90 additions and 0 deletions
|
@ -150,6 +150,7 @@ SHA_port= security/hs-SHA
|
|||
show_port= devel/hs-show
|
||||
smallcheck_port= devel/hs-smallcheck
|
||||
snap-core_port= www/hs-snap-core
|
||||
snap-server_port= www/hs-snap-server # lib_depends
|
||||
soegtk_port= graphics/hs-soegtk
|
||||
split_port= devel/hs-split
|
||||
StateVar_port= devel/hs-StateVar
|
||||
|
|
|
@ -318,6 +318,7 @@
|
|||
SUBDIR += hs-oeis
|
||||
SUBDIR += hs-scgi
|
||||
SUBDIR += hs-snap-core
|
||||
SUBDIR += hs-snap-server
|
||||
SUBDIR += hs-url
|
||||
SUBDIR += hs-wai
|
||||
SUBDIR += hs-warp
|
||||
|
|
47
www/hs-snap-server/Makefile
Normal file
47
www/hs-snap-server/Makefile
Normal file
|
@ -0,0 +1,47 @@
|
|||
# New ports collection makefile for: hs-snap-server
|
||||
# Date created: September 19, 2010
|
||||
# Whom: haskell@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= snap-server
|
||||
PORTVERSION= 0.5.2
|
||||
CATEGORIES= www haskell
|
||||
|
||||
MAINTAINER= haskell@FreeBSD.org
|
||||
COMMENT= A fast, iteratee-based, epoll-enabled web server for the Snap Framework
|
||||
|
||||
LICENSE= BSD
|
||||
|
||||
CABAL_SETUP= Setup.hs
|
||||
USE_CABAL= attoparsec>=0.8.1 attoparsec-enumerator>=0.2.0.1 binary>=0.5 \
|
||||
blaze-builder>=0.2.1.4 blaze-builder-enumerator>=0.2 \
|
||||
bytestring-nums case-insensitive>=0.2 directory-tree \
|
||||
enumerator>=0.4.13.1 MonadCatchIO-transformers>=0.2.1 mtl>=2 \
|
||||
murmur-hash>=0.1 network>=2.3 PSQueue>=1.1 snap-core>=0.5.2 \
|
||||
text>=0.11 transformers unix-compat>=0.2 utf8-string \
|
||||
vector>=0.7 vector-algorithms>=0.4
|
||||
|
||||
OPTIONS= LIBEV "Use libev" off \
|
||||
GNUTLS "Enable https support using the libgnutls library" off
|
||||
|
||||
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if defined(WITH_LIBEV)
|
||||
CONFIGURE_ARGS+= --flags="libev"
|
||||
USE_CABAL+= hlibev
|
||||
.else
|
||||
CONFIGURE_ARGS+= --flags="-libev"
|
||||
.endif
|
||||
|
||||
.if defined(WITH_GNUTLS)
|
||||
CONFIGURE_ARGS+= --flags="gnutls"
|
||||
LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls
|
||||
.else
|
||||
CONFIGURE_ARGS+= --flags="-gnutls"
|
||||
.endif
|
||||
|
||||
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
|
||||
.include <bsd.port.mk>
|
2
www/hs-snap-server/distinfo
Normal file
2
www/hs-snap-server/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (cabal/snap-server-0.5.2.tar.gz) = 2e06bfdf6d0d19f18f4f0666feb691c003ee1faa52cb72a73e055728571ab142
|
||||
SIZE (cabal/snap-server-0.5.2.tar.gz) = 59328
|
20
www/hs-snap-server/files/patch-snap-server.cabal
Normal file
20
www/hs-snap-server/files/patch-snap-server.cabal
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- ./snap-server.cabal.orig 2011-07-20 22:05:26.000000000 +0200
|
||||
+++ ./snap-server.cabal 2011-08-13 10:58:29.000000000 +0200
|
||||
@@ -108,7 +108,7 @@
|
||||
blaze-builder-enumerator >= 0.2.0 && <0.3,
|
||||
bytestring,
|
||||
bytestring-nums,
|
||||
- case-insensitive >= 0.2 && < 0.3,
|
||||
+ case-insensitive >= 0.2,
|
||||
containers,
|
||||
directory-tree,
|
||||
enumerator >= 0.4.13.1 && <0.5,
|
||||
@@ -125,7 +125,7 @@
|
||||
transformers,
|
||||
unix-compat == 0.2.*,
|
||||
vector >= 0.7 && <0.8,
|
||||
- vector-algorithms >= 0.4 && <0.5,
|
||||
+ vector-algorithms >= 0.4,
|
||||
PSQueue >= 1.1 && <1.2
|
||||
|
||||
if flag(portable) || os(windows)
|
19
www/hs-snap-server/pkg-descr
Normal file
19
www/hs-snap-server/pkg-descr
Normal file
|
@ -0,0 +1,19 @@
|
|||
Snap is a simple and fast web development framework and server written in
|
||||
Haskell. For more information or to download the latest version, you can visit
|
||||
the Snap project website.
|
||||
|
||||
The Snap HTTP server is a high performance, epoll-enabled, iteratee-based web
|
||||
server library written in Haskell. Together with the "snap-core" library upon
|
||||
which it depends, it provides a clean and efficient Haskell programming
|
||||
interface to the HTTP protocol.
|
||||
|
||||
Higher-level facilities for building web applications (like user/session
|
||||
management, component interfaces, data modeling, etc.) are planned but not
|
||||
yet implemented, so this release will mostly be of interest for those who:
|
||||
|
||||
* need a fast and minimal HTTP API at roughly the same level of abstraction
|
||||
as Java servlets, or
|
||||
|
||||
* are interested in contributing to the Snap Framework project.
|
||||
|
||||
WWW: http://snapframework.com/
|
Loading…
Reference in a new issue