Add rubygem-train 3.3.6
Train lets you talk to your local or remote operating systems and APIs with a unified interface. It allows you to: - execute commands via run_command - interact with files via file - identify the target operating system via os - authenticate to API-based services and treat them like a platform Train supports: - Local execution - SSH - WinRM - Docker - Mock (for testing and debugging) - AWS as an API - Azure as an API - VMware via PowerCLI - Habitat WWW: https://github.com/inspec/train
This commit is contained in:
parent
636191937b
commit
bbba7909c3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=543733
5 changed files with 71 additions and 0 deletions
|
@ -1335,6 +1335,7 @@
|
|||
SUBDIR += rubygem-stackdriver-core
|
||||
SUBDIR += rubygem-stompserver
|
||||
SUBDIR += rubygem-t
|
||||
SUBDIR += rubygem-train
|
||||
SUBDIR += rubygem-tweetstream
|
||||
SUBDIR += rubygem-twitter
|
||||
SUBDIR += rubygem-twitter-stream
|
||||
|
|
33
net/rubygem-train/Makefile
Normal file
33
net/rubygem-train/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= train
|
||||
PORTVERSION= 3.3.6
|
||||
CATEGORIES= net rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Transport interface to talk to different backends
|
||||
|
||||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= rubygem-activesupport52>=5.2.4.3<6.0.0:devel/rubygem-activesupport52 \
|
||||
rubygem-azure_graph_rbac>=0.16<1:devel/rubygem-azure_graph_rbac \
|
||||
rubygem-azure_mgmt_key_vault>=0.17<1:devel/rubygem-azure_mgmt_key_vault \
|
||||
rubygem-azure_mgmt_resources>=0.15<1:devel/rubygem-azure_mgmt_resources \
|
||||
rubygem-azure_mgmt_security>=0.18<1:devel/rubygem-azure_mgmt_security \
|
||||
rubygem-azure_mgmt_storage>=0.18<1:devel/rubygem-azure_mgmt_storage \
|
||||
rubygem-docker-api>=1.26<2:net/rubygem-docker-api \
|
||||
rubygem-google-api-client>=0.23.9:devel/rubygem-google-api-client \
|
||||
rubygem-googleauth>=0.6.6:security/rubygem-googleauth \
|
||||
rubygem-inifile>=3.0<4:textproc/rubygem-inifile \
|
||||
rubygem-train-core>=${PORTVERSION}:net/rubygem-train-core \
|
||||
rubygem-train-winrm>=0.2<1:net/rubygem-train-winrm
|
||||
|
||||
USES= gem
|
||||
USE_RUBY= yes
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
.include <bsd.port.mk>
|
3
net/rubygem-train/distinfo
Normal file
3
net/rubygem-train/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1595865777
|
||||
SHA256 (rubygem/train-3.3.6.gem) = 567954ee3a58620488fab62f97b2fc44059dda7df3edcdbe1415b7daeb7588c4
|
||||
SIZE (rubygem/train-3.3.6.gem) = 14848
|
13
net/rubygem-train/files/patch-train.gemspec
Normal file
13
net/rubygem-train/files/patch-train.gemspec
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- train.gemspec.orig 2020-07-24 06:34:34 UTC
|
||||
+++ train.gemspec
|
||||
@@ -32,8 +32,8 @@ Gem::Specification.new do |s|
|
||||
s.add_runtime_dependency(%q<azure_mgmt_security>.freeze, ["~> 0.18"])
|
||||
s.add_runtime_dependency(%q<azure_mgmt_storage>.freeze, ["~> 0.18"])
|
||||
s.add_runtime_dependency(%q<docker-api>.freeze, ["~> 1.26"])
|
||||
- s.add_runtime_dependency(%q<google-api-client>.freeze, [">= 0.23.9", "< 0.35.0"])
|
||||
- s.add_runtime_dependency(%q<googleauth>.freeze, [">= 0.6.6", "< 0.11.0"])
|
||||
+ s.add_runtime_dependency(%q<google-api-client>.freeze, [">= 0.23.9"])
|
||||
+ s.add_runtime_dependency(%q<googleauth>.freeze, [">= 0.6.6"])
|
||||
else
|
||||
s.add_dependency(%q<train-core>.freeze, ["= 3.3.6"])
|
||||
s.add_dependency(%q<train-winrm>.freeze, ["~> 0.2"])
|
21
net/rubygem-train/pkg-descr
Normal file
21
net/rubygem-train/pkg-descr
Normal file
|
@ -0,0 +1,21 @@
|
|||
Train lets you talk to your local or remote operating systems and APIs with a
|
||||
unified interface.
|
||||
|
||||
It allows you to:
|
||||
- execute commands via run_command
|
||||
- interact with files via file
|
||||
- identify the target operating system via os
|
||||
- authenticate to API-based services and treat them like a platform
|
||||
|
||||
Train supports:
|
||||
- Local execution
|
||||
- SSH
|
||||
- WinRM
|
||||
- Docker
|
||||
- Mock (for testing and debugging)
|
||||
- AWS as an API
|
||||
- Azure as an API
|
||||
- VMware via PowerCLI
|
||||
- Habitat
|
||||
|
||||
WWW: https://github.com/inspec/train
|
Loading…
Reference in a new issue