Update to 3.6.0.

This commit is contained in:
Tijl Coosemans 2016-07-08 18:02:59 +00:00
parent 2b63294b99
commit bbc98c374d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=418238
6 changed files with 9 additions and 52 deletions

View file

@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= sdcc
PORTVERSION= 3.5.0
PORTVERSION= 3.6.0
DISTVERSIONPREFIX= src-
PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= SF
@ -62,6 +61,8 @@ post-patch:
@${REINPLACE_CMD} '/install:/s/:.*/:/' \
${WRKSRC}/Makefile.in \
${WRKSRC}/support/sdbinutils/libiberty/Makefile.in
@${REINPLACE_CMD} '/^SUBDIRS =/s/doc//' \
${WRKSRC}/support/sdbinutils/bfd/Makefile.in
@${REINPLACE_CMD} 's/[[:<:]]ARCH[[:>:]]/PICARCH/g' \
${WRKSRC}/device/lib/pic14/Makefile.common \
${WRKSRC}/device/lib/pic14/Makefile.in \

View file

@ -1,2 +1,3 @@
SHA256 (sdcc-src-3.5.0.tar.bz2) = f82978d1614244b22e093402c0a4de1f688a07c807b2980126c964eb3df85fa9
SIZE (sdcc-src-3.5.0.tar.bz2) = 10504517
TIMESTAMP = 1467992784
SHA256 (sdcc-src-3.6.0.tar.bz2) = e85dceb11e01ffefb545ec389da91265130c91953589392dddd2e5ec0b7ca374
SIZE (sdcc-src-3.6.0.tar.bz2) = 17993788

View file

@ -1,15 +0,0 @@
--- src/SDCClospre.hpp.orig 2014-01-03 17:18:45 UTC
+++ src/SDCClospre.hpp
@@ -19,6 +19,12 @@
//
// Lifetime-optimal speculative partial redundancy elimination.
+// Workaround for boost bug #11880
+#include <boost/version.hpp>
+#if BOOST_VERSION == 106000
+ #include <boost/type_traits/ice.hpp>
+#endif
+
#include <boost/graph/graphviz.hpp>
#include <boost/tuple/tuple.hpp>
#include <boost/tuple/tuple_comparison.hpp>

View file

@ -1,15 +0,0 @@
--- src/SDCCnaddr.hpp.orig 2015-04-01 13:50:35 UTC
+++ src/SDCCnaddr.hpp
@@ -37,6 +37,12 @@
#include <sstream>
#include <fstream>
+// Workaround for boost bug #11880
+#include <boost/version.hpp>
+#if BOOST_VERSION == 106000
+ #include <boost/type_traits/ice.hpp>
+#endif
+
#include <boost/graph/graphviz.hpp>
#include "SDCCtree_dec.hpp"

View file

@ -1,15 +0,0 @@
--- src/SDCCralloc.hpp.orig 2015-02-25 10:25:50 UTC
+++ src/SDCCralloc.hpp
@@ -51,6 +51,12 @@
#include <sstream>
#include <fstream>
+// Workaround for boost bug #11880
+#include <boost/version.hpp>
+#if BOOST_VERSION == 106000
+ #include <boost/type_traits/ice.hpp>
+#endif
+
#include <boost/graph/graphviz.hpp>
#include <boost/graph/adjacency_matrix.hpp>
#include <boost/graph/connected_components.hpp>

View file

@ -1,8 +1,8 @@
SDCC is a retargettable, optimizing ANSI C compiler suite that targets
the Intel MCS51 based microprocessors (8031, 8032, 8051, 8052, etc.),
Maxim (formerly Dallas) DS80C390 variants, Freescale (formerly Motorola)
HC08 based (hc08, s08) and Zilog Z80 based MCUs (z80, z180, gbz80,
Rabbit 2000/3000, Rabbit 3000A). Work is in progress on supporting the
Microchip PIC16 and PIC18 targets.
HC08 (hc08, s08), Zilog Z80 based MCUs (z80, z180, gbz80, Rabbit 2000/3000,
Rabbit 3000A, TLCS-90) and STMicroelectronics STM8. Work is in progress
to support Microchip PIC16 and PIC18 targets.
WWW: http://sdcc.sourceforge.net/