* Upgrade to 1.0.3

* Change MASTER_SITES
* Install nstreams-services without ".samples" suffix
* Remove the advice about 0.99 version in pkg-descr
* Pass maintainership to submitter

PR:		ports/42752
Submitted by:	Nicolas Jombart <Nicolas.Jombart@hsc-labs.com>
This commit is contained in:
Oliver Braun 2002-09-14 06:42:33 +00:00
parent 749aff3648
commit bbcbd692e4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=66292
10 changed files with 18 additions and 74 deletions

View file

@ -6,12 +6,11 @@
#
PORTNAME= nstreams
PORTVERSION= 1.0.0
PORTREVISION= 1
PORTVERSION= 1.0.3
CATEGORIES= net
MASTER_SITES= http://www.hsc.fr/ressources/outils/nstreams/download/
MASTER_SITES= ftp://ftp.nessus.org/pub/nstreams/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= Nicolas.Jombart@hsc-labs.com
WRKSRC= ${WRKDIR}/${PORTNAME}
@ -22,8 +21,8 @@ MAN1= nstreams.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/nstreams ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/docs/nstreams.1 ${MANPREFIX}/man/man1
.for file in nstreams-networks nstreams-services
${INSTALL_DATA} ${WRKSRC}/docs/${file} ${PREFIX}/etc/${file}.sample
.endfor
${INSTALL_DATA} ${WRKSRC}/docs/nstreams-networks \
${PREFIX}/etc/nstreams-networks.sample
${INSTALL_DATA} ${WRKSRC}/docs/nstreams-services ${PREFIX}/etc/nstreams-services
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (nstreams-1.0.0.tar.gz) = 2d4ed1be1938a1cc24fabade616f31d0
MD5 (nstreams-1.0.3.tar.gz) = 5cf390aedd285b047b1d28c7ecb88d5a

View file

@ -1,26 +0,0 @@
--- src/nstreams.c Thu Nov 11 22:13:14 1999
+++ src/nstreams.c Fri Dec 29 07:04:41 2000
@@ -179,6 +179,7 @@
char * output_name = NULL;
+ bzero(cache, sizeof(struct cache));
parser = parse_tcpdump_line;
--- src/output.c Thu Nov 11 22:13:15 1999
+++ src/output.c Fri Dec 29 07:20:51 2000
@@ -122,11 +122,11 @@
else {
ret->sports = malloc(10);
sprintf(ret->sports, "%d", ret->sport);
- realloc(ret->sports, strlen(ret->sports)+1);
+ ret->sports = realloc(ret->sports, strlen(ret->sports)+1);
ret->dports = malloc(10);
sprintf(ret->dports, "%d", ret->dport);
- realloc(ret->dports, strlen(ret->dports)+1);
+ ret->dports = realloc(ret->dports, strlen(ret->dports)+1);
}
ret->show_net = shownet;

View file

@ -6,8 +6,7 @@ is required for the users, and nothing more.
Nstreams can parse the tcpdump output, or the files generated with the -w
option of tcpdump. It can also directly sniff the data that occurs on the
network (the use of tcpdump is however recommanded as long as nstreams is in
version 0.99.x).
network.
This product was designed by HSC and coded by Renaud Deraison
(deraison@cvs.nessus.org), author of the Nessus software (www.nessus.org). It

View file

@ -1,3 +1,3 @@
bin/nstreams
etc/nstreams-networks.sample
etc/nstreams-services.sample
etc/nstreams-services

View file

@ -6,12 +6,11 @@
#
PORTNAME= nstreams
PORTVERSION= 1.0.0
PORTREVISION= 1
PORTVERSION= 1.0.3
CATEGORIES= net
MASTER_SITES= http://www.hsc.fr/ressources/outils/nstreams/download/
MASTER_SITES= ftp://ftp.nessus.org/pub/nstreams/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= Nicolas.Jombart@hsc-labs.com
WRKSRC= ${WRKDIR}/${PORTNAME}
@ -22,8 +21,8 @@ MAN1= nstreams.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/nstreams ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/docs/nstreams.1 ${MANPREFIX}/man/man1
.for file in nstreams-networks nstreams-services
${INSTALL_DATA} ${WRKSRC}/docs/${file} ${PREFIX}/etc/${file}.sample
.endfor
${INSTALL_DATA} ${WRKSRC}/docs/nstreams-networks \
${PREFIX}/etc/nstreams-networks.sample
${INSTALL_DATA} ${WRKSRC}/docs/nstreams-services ${PREFIX}/etc/nstreams-services
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (nstreams-1.0.0.tar.gz) = 2d4ed1be1938a1cc24fabade616f31d0
MD5 (nstreams-1.0.3.tar.gz) = 5cf390aedd285b047b1d28c7ecb88d5a

View file

@ -1,26 +0,0 @@
--- src/nstreams.c Thu Nov 11 22:13:14 1999
+++ src/nstreams.c Fri Dec 29 07:04:41 2000
@@ -179,6 +179,7 @@
char * output_name = NULL;
+ bzero(cache, sizeof(struct cache));
parser = parse_tcpdump_line;
--- src/output.c Thu Nov 11 22:13:15 1999
+++ src/output.c Fri Dec 29 07:20:51 2000
@@ -122,11 +122,11 @@
else {
ret->sports = malloc(10);
sprintf(ret->sports, "%d", ret->sport);
- realloc(ret->sports, strlen(ret->sports)+1);
+ ret->sports = realloc(ret->sports, strlen(ret->sports)+1);
ret->dports = malloc(10);
sprintf(ret->dports, "%d", ret->dport);
- realloc(ret->dports, strlen(ret->dports)+1);
+ ret->dports = realloc(ret->dports, strlen(ret->dports)+1);
}
ret->show_net = shownet;

View file

@ -6,8 +6,7 @@ is required for the users, and nothing more.
Nstreams can parse the tcpdump output, or the files generated with the -w
option of tcpdump. It can also directly sniff the data that occurs on the
network (the use of tcpdump is however recommanded as long as nstreams is in
version 0.99.x).
network.
This product was designed by HSC and coded by Renaud Deraison
(deraison@cvs.nessus.org), author of the Nessus software (www.nessus.org). It

View file

@ -1,3 +1,3 @@
bin/nstreams
etc/nstreams-networks.sample
etc/nstreams-services.sample
etc/nstreams-services