Create a port for kpsk, a PSK-31 radio package for amateur radio users
This commit is contained in:
parent
2063bea8a3
commit
bbf6d7f322
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=69312
9 changed files with 106 additions and 0 deletions
|
@ -21,6 +21,7 @@
|
|||
SUBDIR += java-commapi
|
||||
SUBDIR += java-commapi-freebsd
|
||||
SUBDIR += kermit
|
||||
SUBDIR += kpsk
|
||||
SUBDIR += lrzsz
|
||||
SUBDIR += ltmdm
|
||||
SUBDIR += mgetty+sendfax
|
||||
|
|
33
comms/kpsk/Makefile
Normal file
33
comms/kpsk/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# New ports collection makefile for: kpsk
|
||||
# Date created: 2002-06-12
|
||||
# Whom: Patrick Gardella <patrick@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= kpsk
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= comms kde
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
|
||||
MAINTAINER= patrick@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= db4:${PORTSDIR}/databases/db4
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_KDELIBS_VER=3
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-D_POSIX_C_SOURCE -I${LOCALBASE}/include" \
|
||||
USER_LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --enable-debug=full
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's/-ldb-4.0/-ldb4/g' ${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/en/HTML/handbook.html ${PREFIX}/share/doc/HTML/en/kpsk/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
comms/kpsk/distinfo
Normal file
1
comms/kpsk/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (kpsk-1.0.tar.bz2) = 16ce49f3c3124765dd58efc0ddf79230
|
11
comms/kpsk/files/patch-aa
Normal file
11
comms/kpsk/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig Thu Oct 24 11:17:10 2002
|
||||
+++ configure Thu Oct 24 11:17:32 2002
|
||||
@@ -8703,7 +8703,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="-ldb-4.0 $LIBS"
|
||||
+LIBS="-ldb-4.0 $USER_LDFLAGS $LIBS"
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 8709 "configure"
|
||||
#include "confdefs.h"
|
12
comms/kpsk/files/patch-ab
Normal file
12
comms/kpsk/files/patch-ab
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- kpsk/server/server-main.C.orig Mon Oct 21 22:07:45 2002
|
||||
+++ kpsk/server/server-main.C Wed Oct 23 07:11:02 2002
|
||||
@@ -18,6 +18,9 @@
|
||||
* mutex operations for accesing en-/decoder classes from en/decoding
|
||||
* thread and from user interface thread (==interface functions)
|
||||
*/
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <sys/types.h>
|
||||
+#endif
|
||||
|
||||
#include <sys/mman.h>
|
||||
|
14
comms/kpsk/files/patch-ac
Normal file
14
comms/kpsk/files/patch-ac
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- kpsk/modes/psk31-transmitter.C.orig Thu Oct 24 10:44:21 2002
|
||||
+++ kpsk/modes/psk31-transmitter.C Thu Oct 24 10:46:41 2002
|
||||
@@ -11,7 +11,11 @@
|
||||
#include <errno.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <machine/soundcard.h>
|
||||
+#else
|
||||
#include <linux/soundcard.h>
|
||||
+#endif
|
||||
#include <sys/ioctl.h>
|
||||
#include "psk31-coder.h"
|
||||
#include "psk31-transmitter.h"
|
1
comms/kpsk/pkg-comment
Normal file
1
comms/kpsk/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A PSK31 digital radio communications application for the KDE 3.x
|
20
comms/kpsk/pkg-descr
Normal file
20
comms/kpsk/pkg-descr
Normal file
|
@ -0,0 +1,20 @@
|
|||
KPSK is a PSK31 digital radio communications application for use by
|
||||
licensed amateur radio operators and designed specifically for the
|
||||
KDE 3.x desktop environment.
|
||||
|
||||
Features include:
|
||||
|
||||
* Simple, feature-filled user interface
|
||||
* Simultaneous monitoring of up to four PSK31 signals
|
||||
* User-configurable waterfall colors, fonts.
|
||||
* Auto-scaling waterfall
|
||||
* Optimization to provide IMD data only when the measurement is valid
|
||||
* Twelve user-defined fixedtexts (TX macros), available by mouse
|
||||
or F1-F12 keys
|
||||
* Integral BerkeleyDB-based QSO logbook
|
||||
* BPSK or QPSK operation
|
||||
* Automatic and manual modes for calling CQ
|
||||
* Ability to send an ASCII text file
|
||||
* Extensive application documentation
|
||||
|
||||
WWW: http://1409.org/projects/kpsk/
|
13
comms/kpsk/pkg-plist
Normal file
13
comms/kpsk/pkg-plist
Normal file
|
@ -0,0 +1,13 @@
|
|||
bin/kpsk
|
||||
share/applnk/Applications/HamRadio/kpsk.desktop
|
||||
share/icons/locolor/32x32/apps/kpsk.png
|
||||
share/icons/locolor/16x16/apps/kpsk.png
|
||||
share/locale/es/LC_MESSAGES/kpsk.mo
|
||||
share/doc/HTML/en/kpsk/index.docbook
|
||||
share/doc/HTML/en/kpsk/index.cache.bz2
|
||||
share/apps/kpsk/dxcc.db
|
||||
share/doc/HTML/en/kpsk/common
|
||||
%%PORTDOCS%%share/doc/HTML/en/kpsk/handbook.html
|
||||
@dirrm share/apps/kpsk
|
||||
@dirrm share/doc/HTML/en/kpsk
|
||||
@dirrm share/applnk/Applications/HamRadio
|
Loading…
Reference in a new issue