Update mesa based ports to 10.4.0.

This commit is contained in:
Koop Mast 2014-12-22 19:00:01 +00:00
parent ceec2a71d8
commit bc0438d6b1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=375260
8 changed files with 47 additions and 87 deletions

View file

@ -43,6 +43,10 @@ include/GL/internal/dri_interface.h
@comment lib/libglapi.so
@comment lib/libglapi.so.0
@comment lib/libglapi.so.0.0.0
%%VDPAU%%lib/vdpau/libvdpau_r300.so
%%VDPAU%%lib/vdpau/libvdpau_r300.so.1
%%VDPAU%%lib/vdpau/libvdpau_r300.so.1.0
%%VDPAU%%lib/vdpau/libvdpau_r300.so.1.0.0
%%VDPAU%%lib/vdpau/libvdpau_r600.so
%%VDPAU%%lib/vdpau/libvdpau_r600.so.1
%%VDPAU%%lib/vdpau/libvdpau_r600.so.1.0

View file

@ -9,7 +9,8 @@
# - graphics/libEGL
# - graphics/libGL
# - graphics/libglapi
# - grahpics/libglesv2
# - graphics/libglesv2
# - graphics/libosmesa
#
# $FreeBSD$
@ -28,16 +29,11 @@ MESAVERSION= ${MESABASEVERSION}${MESASUBVERSION:C/^(.)/.\1/}
MESADISTVERSION=${MESABASEVERSION}${MESASUBVERSION:C/^(.)/-\1/}
.if defined(WITH_NEW_MESA)
MESABASEVERSION= 10.3.4
MESABASEVERSION= 10.4.0
# if there is a subversion, don't include the '-' between 7.11-rc2.
MESASUBVERSION=
MESASUBVERSION=
.if ${MESASUBVERSION} == "" && ${MESABASEVERSION:E} != 0
MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/${MESABASEVERSION}/
.else
MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/${MESABASEVERSION:R}/
.endif
PLIST_SUB+= OLD="@comment " NEW=""
# work around libarchive bug?
EXTRACT_CMD= ${LOCALBASE}/bin/gtar

View file

@ -1,4 +1,4 @@
SHA256 (MesaLib-9.1.7.tar.bz2) = 30e6b878b457c716221a9730b179b2846c38cfd5aa1b02d54aff685f50b844a0
SIZE (MesaLib-9.1.7.tar.bz2) = 6134393
SHA256 (MesaLib-10.3.4.tar.bz2) = e6373913142338d10515daf619d659433bfd2989988198930c13b0945a15e98a
SIZE (MesaLib-10.3.4.tar.bz2) = 7282053
SHA256 (MesaLib-10.4.0.tar.bz2) = 98a7dff3a1a6708c79789de8b9a05d8042e867067f70e8f30387c15026233219
SIZE (MesaLib-10.4.0.tar.bz2) = 7479710

View file

@ -1,5 +1,5 @@
--- configure.ac.orig 2014-08-21 01:41:38.000000000 +0200
+++ configure.ac 2014-08-29 13:40:20.688548140 +0200
--- configure.ac.orig 2014-11-18 03:23:13.000000000 +0100
+++ configure.ac 2014-11-21 12:50:56.104986267 +0100
@@ -37,6 +37,7 @@
DRI3PROTO_REQUIRED=1.0
PRESENTPROTO_REQUIRED=1.0
@ -8,25 +8,16 @@
GLPROTO_REQUIRED=1.4.14
LIBOMXIL_BELLAGIO_REQUIRED=0.0
VDPAU_REQUIRED=0.4.1
@@ -53,7 +54,7 @@
@@ -54,7 +55,7 @@
AM_PROG_CC_C_O
AM_PROG_AS
AC_CHECK_PROGS([MAKE], [gmake make])
AX_CHECK_GNU_MAKE
-AC_CHECK_PROGS([PYTHON2], [python2 python])
+AC_CHECK_PROGS([PYTHON2], [python2.7 python2 python])
AC_PROG_SED
AC_PROG_MKDIR_P
@@ -152,7 +153,7 @@
DEFINES="-DUSE_EXTERNAL_DXTN_LIB=1"
AC_SUBST([DEFINES])
case "$host_os" in
-linux*|*-gnu*|gnu*)
+linux*|*-gnu*|gnu*|freebsd*)
DEFINES="$DEFINES -D_GNU_SOURCE -DHAVE_PTHREAD"
;;
solaris*)
@@ -581,7 +582,7 @@
@@ -617,7 +618,7 @@
[enable_dri=yes])
case "$host_os" in
@ -35,7 +26,7 @@
dri3_default=yes
;;
*)
@@ -855,6 +856,9 @@
@@ -883,6 +884,9 @@
PKG_CHECK_MODULES([LIBUDEV], [libudev >= $LIBUDEV_REQUIRED],
have_libudev=yes, have_libudev=no)
@ -45,7 +36,7 @@
AC_ARG_ENABLE([sysfs],
[AS_HELP_STRING([--enable-sysfs],
[enable /sys PCI identification @<:@default=disabled@:>@])],
@@ -949,6 +953,10 @@
@@ -979,6 +983,10 @@
DEFINES="$DEFINES -DHAVE_LIBUDEV"
have_pci_id=yes
fi
@ -56,9 +47,9 @@
if test "$have_sysfs" = yes; then
DEFINES="$DEFINES -DHAVE_SYSFS"
@@ -1069,6 +1077,23 @@
*freebsd* | dragonfly* | *netbsd* | openbsd*)
DEFINES="$DEFINES -DHAVE_PTHREAD"
@@ -1101,6 +1109,23 @@
;;
gnu*)
DEFINES="$DEFINES -DHAVE_ALIAS"
+dnl not sure about dri3 support, just enable it for now.
+ if test "x$enable_dri3" = xyes; then
@ -78,9 +69,9 @@
+ ;;
+ esac
;;
gnu*)
DEFINES="$DEFINES -DHAVE_ALIAS"
@@ -1252,6 +1277,8 @@
cygwin*)
if test "x$with_dri_drivers" = "xyes"; then
@@ -1278,6 +1303,8 @@
AM_CONDITIONAL(HAVE_GBM, test "x$enable_gbm" = xyes)
if test "x$need_pci_id$have_libudev" = xyesyes; then
GBM_PC_REQ_PRIV="libudev >= $LIBUDEV_REQUIRED"
@ -89,7 +80,7 @@
else
GBM_PC_REQ_PRIV=""
fi
@@ -1728,8 +1755,6 @@
@@ -1724,8 +1751,6 @@
CLANG_LIBDIR=${LLVM_LIBDIR}
fi
CLANG_RESOURCE_DIR=$CLANG_LIBDIR/clang/${LLVM_VERSION}

View file

@ -1,6 +1,6 @@
--- configure.orig 2014-08-29 13:42:21.635540273 +0200
+++ configure 2014-08-29 13:42:55.401537200 +0200
@@ -858,6 +858,8 @@
--- configure.orig 2014-11-21 12:54:55.273970976 +0100
+++ configure 2014-11-21 12:55:25.070967392 +0100
@@ -853,6 +853,8 @@
GLPROTO_CFLAGS
XLIBGL_LIBS
XLIBGL_CFLAGS
@ -9,7 +9,7 @@
LIBUDEV_LIBS
LIBUDEV_CFLAGS
LIBDRM_LIBS
@@ -1146,6 +1148,8 @@
@@ -1143,6 +1145,8 @@
LIBDRM_LIBS
LIBUDEV_CFLAGS
LIBUDEV_LIBS
@ -18,7 +18,7 @@
XLIBGL_CFLAGS
XLIBGL_LIBS
GLPROTO_CFLAGS
@@ -1945,6 +1949,10 @@
@@ -1942,6 +1946,10 @@
C compiler flags for LIBUDEV, overriding pkg-config
LIBUDEV_LIBS
linker flags for LIBUDEV, overriding pkg-config
@ -29,7 +29,7 @@
XLIBGL_CFLAGS
C compiler flags for XLIBGL, overriding pkg-config
XLIBGL_LIBS linker flags for XLIBGL, overriding pkg-config
@@ -5086,6 +5094,7 @@
@@ -5085,6 +5093,7 @@
DRI3PROTO_REQUIRED=1.0
PRESENTPROTO_REQUIRED=1.0
LIBUDEV_REQUIRED=151
@ -37,25 +37,16 @@
GLPROTO_REQUIRED=1.4.14
LIBOMXIL_BELLAGIO_REQUIRED=0.0
VDPAU_REQUIRED=0.4.1
@@ -6519,7 +6528,7 @@
test -n "$MAKE" && break
done
@@ -6503,7 +6512,7 @@
fi
-for ac_prog in python2 python
+for ac_prog in python2.7 python2 python
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
set dummy $ac_prog; ac_word=$2
@@ -17891,7 +17900,7 @@
DEFINES="-DUSE_EXTERNAL_DXTN_LIB=1"
case "$host_os" in
-linux*|*-gnu*|gnu*)
+linux*|*-gnu*|gnu*|freebsd*)
DEFINES="$DEFINES -D_GNU_SOURCE -DHAVE_PTHREAD"
;;
solaris*)
@@ -19147,7 +19156,7 @@
@@ -20025,7 +20034,7 @@
case "$host_os" in
@ -64,7 +55,7 @@
dri3_default=yes
;;
*)
@@ -19669,6 +19678,78 @@
@@ -20543,6 +20552,78 @@
have_libudev=yes
fi
@ -143,7 +134,7 @@
# Check whether --enable-sysfs was given.
if test "${enable_sysfs+set}" = set; then :
enableval=$enable_sysfs; have_sysfs="$enableval"
@@ -20373,6 +20454,10 @@
@@ -21258,6 +21339,10 @@
DEFINES="$DEFINES -DHAVE_LIBUDEV"
have_pci_id=yes
fi
@ -154,9 +145,9 @@
if test "$have_sysfs" = yes; then
DEFINES="$DEFINES -DHAVE_SYSFS"
@@ -20498,6 +20583,22 @@
*freebsd* | dragonfly* | *netbsd* | openbsd*)
DEFINES="$DEFINES -DHAVE_PTHREAD"
@@ -21385,6 +21470,22 @@
;;
gnu*)
DEFINES="$DEFINES -DHAVE_ALIAS"
+ if test "x$enable_dri3" = xyes; then
+ DEFINES="$DEFINES -DHAVE_DRI3"
@ -175,9 +166,9 @@
+ ;;
+ esac
;;
gnu*)
DEFINES="$DEFINES -DHAVE_ALIAS"
@@ -21226,6 +21327,8 @@
cygwin*)
if test "x$with_dri_drivers" = "xyes"; then
@@ -22205,6 +22306,8 @@
if test "x$need_pci_id$have_libudev" = xyesyes; then
GBM_PC_REQ_PRIV="libudev >= $LIBUDEV_REQUIRED"
@ -186,7 +177,7 @@
else
GBM_PC_REQ_PRIV=""
fi
@@ -22541,9 +22644,6 @@
@@ -23628,9 +23731,6 @@
CLANG_LIBDIR=${LLVM_LIBDIR}
fi
CLANG_RESOURCE_DIR=$CLANG_LIBDIR/clang/${LLVM_VERSION}

View file

@ -1,11 +0,0 @@
--- src/gallium/auxiliary/os/os_misc.c.orig 2014-09-19 18:23:33 UTC
+++ src/gallium/auxiliary/os/os_misc.c
@@ -128,6 +128,8 @@ os_get_total_physical_memory(uint64_t *s
mib[1] = HW_PHYSMEM64;
#elif defined(PIPE_OS_FREEBSD)
mib[1] = HW_REALMEM;
+#elif defined(PIPE_OS_DRAGONFLY)
+ mib[1] = HW_PHYSMEM;
#else
#error Unsupported *BSD
#endif

View file

@ -1,11 +1,11 @@
--- src/mapi/glapi/gen/gl_gentable.py.orig 2014-08-31 01:21:41.368693630 +0200
+++ src/mapi/glapi/gen/gl_gentable.py 2014-08-31 01:23:09.451686631 +0200
--- src/mapi/glapi/gen/gl_gentable.py.orig 2014-11-21 13:09:28.624910062 +0100
+++ src/mapi/glapi/gen/gl_gentable.py 2014-11-21 13:10:48.294268333 +0100
@@ -42,7 +42,7 @@
#endif
#if (defined(GLXEXT) && defined(HAVE_BACKTRACE)) \\
- || (!defined(GLXEXT) && defined(DEBUG) && !defined(_WIN32_WCE) && !defined(__CYGWIN__) && !defined(__MINGW32__) && !defined(__OpenBSD__) && !defined(__NetBSD__) && !defined(__DragonFly__))
+ || (!defined(GLXEXT) && defined(DEBUG) && !defined(_WIN32_WCE) && !defined(__CYGWIN__) && !defined(__MINGW32__) && !defined(__OpenBSD__) && !defined(__NetBSD__) && !defined(__FreeBSD__) && !defined(__DragonFly__))
- || (!defined(GLXEXT) && defined(DEBUG) && !defined(__CYGWIN__) && !defined(__MINGW32__) && !defined(__OpenBSD__) && !defined(__NetBSD__) && !defined(__DragonFly__))
+ || (!defined(GLXEXT) && defined(DEBUG) && !defined(__CYGWIN__) && !defined(__MINGW32__) && !defined(__OpenBSD__) && !defined(__NetBSD__) && !defined(__FreeBSD__) && !defined(__DragonFly__))
#define USE_BACKTRACE
#endif

View file

@ -1,11 +0,0 @@
--- src/mesa/main/imports.c.orig 2014-05-28 09:50:40.000000000 +0200
+++ src/mesa/main/imports.c 2014-05-28 09:50:56.000000000 +0200
@@ -571,7 +571,7 @@
{
#if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && \
!defined(ANDROID) && !defined(__HAIKU__) && !defined(__UCLIBC__) && \
- !defined(__NetBSD__)
+ !defined(__DragonFly__) && !defined(__NetBSD__)
static locale_t loc = NULL;
if (!loc) {
loc = newlocale(LC_CTYPE_MASK, "C", NULL);