Install lensfun-update-database and l.-add-adapter.
This is masked by a default-enabled PYHELPERS option. While here, add gettext-runtime to USES to appease stage-qa. Approved by: danfe@ Differential Revision: D8993
This commit is contained in:
parent
4c90331c83
commit
bc0a22e485
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=431560
3 changed files with 28 additions and 4 deletions
|
@ -3,6 +3,7 @@
|
|||
|
||||
PORTNAME= lensfun
|
||||
PORTVERSION= 0.3.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
|
||||
|
||||
|
@ -13,14 +14,22 @@ LICENSE= LGPL3
|
|||
|
||||
LIB_DEPENDS= libpng.so:graphics/png
|
||||
|
||||
USES= cmake pathfix pkgconfig
|
||||
USES= cmake gettext-runtime pathfix pkgconfig
|
||||
USE_GNOME= glib20
|
||||
USE_LDCONFIG= yes
|
||||
CMAKE_ARGS= -DBUILD_AUXFUN:BOOL=ON -DINSTALL_HELPER_SCRIPTS:BOOL=OFF
|
||||
CMAKE_ARGS= -DBUILD_AUXFUN:BOOL=ON
|
||||
MAKE_ENV+= PYTHONDONTWRITEBYTECODE= PYTHONOPTIMIZE=
|
||||
PLIST_SUB+= PYTHON_SUFFIX=${PYTHON_SUFFIX}
|
||||
|
||||
OPTIONS_DEFINE= SIMD
|
||||
OPTIONS_DEFAULT= SIMD
|
||||
OPTIONS_DEFINE= SIMD PYHELPERS
|
||||
OPTIONS_DEFAULT= SIMD PYHELPERS
|
||||
OPTIONS_SUB= yes
|
||||
PYHELPERS_DESC= Install database helper scripts (need Python 3)
|
||||
|
||||
SIMD_CMAKE_OFF= -DBUILD_FOR_SSE:BOOL=OFF -DBUILD_FOR_SSE2:BOOL=OFF
|
||||
|
||||
PYHELPERS_CMAKE_ON= -DSTAGEDIR:STRING=${STAGEDIR}
|
||||
PYHELPERS_CMAKE_OFF= -DINSTALL_HELPER_SCRIPTS:BOOL=OFF -DPYTHON:STRING=IGNORE
|
||||
PYHELPERS_USES= python:3
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
9
graphics/lensfun/files/patch-apps_CMakeLists.txt
Normal file
9
graphics/lensfun/files/patch-apps_CMakeLists.txt
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- apps/CMakeLists.txt.orig 2016-12-30 11:49:15 UTC
|
||||
+++ apps/CMakeLists.txt
|
||||
@@ -42,5 +42,5 @@ IF(PYTHON)
|
||||
IF(NOT DEFINED SETUP_PY_INSTALL_PREFIX)
|
||||
SET(SETUP_PY_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}")
|
||||
ENDIF()
|
||||
- INSTALL(CODE "execute_process(COMMAND ${PYTHON} ${SETUP_PY} install --prefix=${SETUP_PY_INSTALL_PREFIX})")
|
||||
+ INSTALL(CODE "execute_process(COMMAND ${PYTHON} ${SETUP_PY} install --prefix=${SETUP_PY_INSTALL_PREFIX} --root=${STAGEDIR})")
|
||||
ENDIF(PYTHON)
|
|
@ -1,3 +1,6 @@
|
|||
%%PYHELPERS%%bin/g-lensfun-update-data
|
||||
%%PYHELPERS%%bin/lensfun-add-adapter
|
||||
%%PYHELPERS%%bin/lensfun-update-data
|
||||
include/lensfun/lensfun.h
|
||||
lib/liblensfun.so
|
||||
lib/liblensfun.so.1
|
||||
|
@ -56,3 +59,6 @@ libdata/pkgconfig/lensfun.pc
|
|||
%%DATADIR%%/version_1/slr-vivitar.xml
|
||||
%%DATADIR%%/version_1/slr-zeiss.xml
|
||||
%%DATADIR%%/version_1/timestamp.txt
|
||||
%%PYHELPERS%%%%PYTHON_SITELIBDIR%%/lensfun-0.3.2-py%%PYTHON_VER%%.egg-info
|
||||
%%PYHELPERS%%%%PYTHON_SITELIBDIR%%/lensfun/__init__.py
|
||||
%%PYHELPERS%%%%PYTHON_SITELIBDIR%%/lensfun/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
|
||||
|
|
Loading…
Reference in a new issue