Use USE_LOCALE instead of patch file

This commit is contained in:
Sunpoet Po-Chuan Hsieh 2018-03-26 16:35:31 +00:00
parent a0ad3e0d05
commit bc2e5f3f91
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=465611
2 changed files with 1 additions and 13 deletions

View file

@ -16,6 +16,7 @@ LICENSE= LGPL21
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${FLAVOR}
NO_ARCH= yes
USE_LOCALE= en_US.UTF-8
USE_PYTHON= autoplist concurrent distutils
USES= python

View file

@ -1,13 +0,0 @@
Obtained from: https://github.com/arskom/spyne/commit/4b89a21f9af72f07628d2ecd114c308987acc0e1
--- setup.py.orig 2016-10-28 11:15:20 UTC
+++ setup.py
@@ -48,7 +48,7 @@ protocols and transports.
try:
os.stat('CHANGELOG.rst')
- LONG_DESC += "\n\n" + open('CHANGELOG.rst', 'r').read()
+ LONG_DESC += u"\n\n" + open('CHANGELOG.rst', 'rb').read().decode('utf8')
except OSError:
pass