misc/edfbrowser: New port: Viewer, annotator, toolbox for timeseries files EEG, EMG, ECG, etc

This commit is contained in:
Yuri Victorovich 2022-06-20 00:17:51 -07:00
parent 2b6a2dabd1
commit bc2e7b0962
8 changed files with 121 additions and 0 deletions

View file

@ -82,6 +82,7 @@
SUBDIR += dynomite
SUBDIR += e2fsprogs-libblkid
SUBDIR += e2fsprogs-libuuid
SUBDIR += edfbrowser
SUBDIR += edflib
SUBDIR += elixir-mime
SUBDIR += elixir-uuid

22
misc/edfbrowser/Makefile Normal file
View file

@ -0,0 +1,22 @@
PORTNAME= edfbrowser
DISTVERSION= 1.94
CATEGORIES= misc
MASTER_SITES= https://www.teuniz.net/${PORTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION:S/.//}_source
MAINTAINER= yuri@FreeBSD.org
COMMENT= Viewer, annotator, toolbox for timeseries files EEG, EMG, ECG, etc
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= desktop-file-utils gl qmake qt:5 shared-mime-info
USE_QT= core gui network printsupport widgets buildtools_build
USE_GL= gl
OPTIONS_DEFINE= DOCS
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/edfbrowser
.include <bsd.port.mk>

3
misc/edfbrowser/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1655707084
SHA256 (edfbrowser_194_source.tar.gz) = f2aea90a761b73532ee96cd433a97d78d9080d44a9c0b25d3a81c4fe41f8fbe7
SIZE (edfbrowser_194_source.tar.gz) = 677103

View file

@ -0,0 +1,59 @@
--- edfbrowser.pro.orig 2022-06-20 06:49:59 UTC
+++ edfbrowser.pro
@@ -284,35 +284,35 @@ win32 {
QMAKE_CXXFLAGS += -Wextra -Wshadow -Wformat -Wformat-nonliteral -Wformat-security -Wtype-limits -Wfatal-errors -Wdeprecated-declarations
unix {
-target.path = /usr/bin
+target.path = $$PREFIX/bin/
target.files = edfbrowser
INSTALLS += target
-documentation.path = /usr/share/doc/edfbrowser
+documentation.path = $$PREFIX/share/doc/edfbrowser
documentation.files = doc/*
INSTALLS += documentation
-icon_a.path = /usr/share/icons
+icon_a.path = $$PREFIX/share/icons
icon_a.files = images/edf.png
INSTALLS += icon_a
-icon_b.path += /usr/share/pixmaps
+icon_b.path += $$PREFIX/share/pixmaps
icon_b.files = images/edf.png
INSTALLS += icon_b
-icon_c.path += /usr/share/icons/hicolor/48x48/apps
+icon_c.path += $$PREFIX/share/icons/hicolor/48x48/apps
icon_c.files = images/edf.png
INSTALLS += icon_c
-icon_d.path += /usr/share/icons/hicolor/48x48/mimetypes
+icon_d.path += $$PREFIX/share/icons/hicolor/48x48/mimetypes
icon_d.files = images/edf.png
INSTALLS += icon_d
-desktop_link.path += /usr/share/applications
+desktop_link.path += $$PREFIX/share/applications
desktop_link.files += install/edfbrowser.desktop
INSTALLS += desktop_link
-mime.path += /usr/share/mime/packages
+mime.path += $$PREFIX/share/mime/packages
mime.files += install/edfbrowser.xml
INSTALLS += mime
}
@@ -323,10 +323,10 @@ mac {
QMAKE_APPLICATION_BUNDLE_NAME = EDFbrowser
QMAKE_TARGET_BUNDLE_PREFIX = net.teuniz
icns.target = edf.icns
- icns.commands = /usr/bin/env bash $$_PRO_FILE_PWD_/images/macos-icns-create.command "$$(PWD)"
+ icns.commands = $$PREFIX/bin/env bash $$_PRO_FILE_PWD_/images/macos-icns-create.command "$$(PWD)"
QMAKE_EXTRA_TARGETS += icns
ICON = $$(PWD)/edf.icns
- QMAKE_POST_LINK = /usr/bin/env bash $$_PRO_FILE_PWD_/install/macos-dmg-create.command "$$(PWD)"
+ QMAKE_POST_LINK = $$PREFIX/bin/env bash $$_PRO_FILE_PWD_/install/macos-dmg-create.command "$$(PWD)"
QMAKE_CLEAN += edf.iconset EDFbrowser-*-temp.dmg
QMAKE_DISTCLEAN += edf.icns EDFbrowser-*.dmg
}

View file

@ -0,0 +1,11 @@
--- edflib.c.orig 2022-06-20 06:42:24 UTC
+++ edflib.c
@@ -38,7 +38,7 @@
#define EDFLIB_VERSION (121)
#define EDFLIB_MAXFILES (64)
-#if defined(__APPLE__) || defined(__MACH__) || defined(__APPLE_CC__) || defined(__HAIKU__)
+#if defined(__APPLE__) || defined(__MACH__) || defined(__APPLE_CC__) || defined(__HAIKU__) || defined(__FreeBSD__)
#define fopeno fopen

View file

@ -0,0 +1,11 @@
--- global.h.orig 2022-06-20 06:40:34 UTC
+++ global.h
@@ -54,7 +54,7 @@
#include <stdio.h>
-#if defined(__APPLE__) || defined(__MACH__) || defined(__APPLE_CC__) || defined(__HAIKU__)
+#if defined(__APPLE__) || defined(__MACH__) || defined(__APPLE_CC__) || defined(__HAIKU__) || defined(__FreeBSD__)
#define fopeno fopen

View file

@ -0,0 +1,5 @@
EDFbrowser is a free, opensource, multiplatform, universal viewer,
annotator and toolbox intended for, but not limited to, timeseries
storage files like EEG, EMG, ECG, BioImpedance, etc.
WWW: https://www.teuniz.net/edfbrowser/

View file

@ -0,0 +1,9 @@
bin/edfbrowser
share/applications/edfbrowser.desktop
%%PORTDOCS%%%%DOCSDIR%%/manual.html
%%PORTDOCS%%%%DOCSDIR%%/montage_file_format.txt
share/icons/edf.png
share/icons/hicolor/48x48/apps/edf.png
share/icons/hicolor/48x48/mimetypes/edf.png
share/mime/packages/edfbrowser.xml
share/pixmaps/edf.png