Fix build by updating to 1.46

Approved by:	makc (co-mentor)
This commit is contained in:
Brendan Fabeny 2010-08-28 12:55:19 +00:00
parent 1dda96a480
commit bc36efa3a2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=260134
3 changed files with 35 additions and 37 deletions

View file

@ -6,11 +6,11 @@
#
PORTNAME= msieve
PORTVERSION= 1.38
PORTREVISION= 2
PORTVERSION= 1.46
CATEGORIES= math
MASTER_SITES= http://www.boo.net/~jasonp/ \
http://mirror.roe.ch/dist/msieve/
MASTER_SITES= SF
MASTER_SITE_SUBDIR= \
${PORTNAME}/${PORTNAME}/${PORTNAME:C/^m/M/}%20v${PORTVERSION}/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
MAINTAINER= bf@FreeBSD.org
@ -18,8 +18,6 @@ COMMENT= Fast factorization of big integers using MPQS and GNFS
BUILD_DEPENDS= ${LOCALBASE}/lib/libecm.a:${PORTSDIR}/math/gmp-ecm
BROKEN= does not build
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
@ -37,7 +35,7 @@ OPTIONS= OCFLAGS "Enable optimized CFLAGS" On
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_OCFLAGS)
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer -DNDEBUG -D_FILE_OFFSET_BITS=64
.else
CFLAGS+= -D_FILE_OFFSET_BITS=64
.endif

View file

@ -1,3 +1,3 @@
MD5 (msieve138.tar.gz) = e6d296466f01f0ae261219f8ee2d3277
SHA256 (msieve138.tar.gz) = f3856abd5280b1d911569bba438b5ce8a4bfe215df71e85d495a27f77fb3aedb
SIZE (msieve138.tar.gz) = 305807
MD5 (msieve146.tar.gz) = d54ef004aedeef9ee4994a44137f9b43
SHA256 (msieve146.tar.gz) = 227295fd2f87658b48fe10bbc30bc86c985c871a95c38b12892acd40db86d026
SIZE (msieve146.tar.gz) = 409970

View file

@ -1,27 +1,27 @@
--- Makefile.orig 2008-03-23 05:32:08.000000000 +0100
+++ Makefile 2008-03-28 13:15:14.000000000 +0100
@@ -26,12 +26,12 @@
# gcc with basic optimization (-march flag could
# get overridden by architecture-specific builds)
-CC = gcc
+#CC = gcc
WARN_FLAGS = -Wall -W -Wconversion
-OPT_FLAGS = -O3 -fomit-frame-pointer -march=athlon-xp -D_FILE_OFFSET_BITS=64
+#OPT_FLAGS = -O3 -fomit-frame-pointer -march=athlon-xp -D_FILE_OFFSET_BITS=64
#OPT_FLAGS = -O3 -fomit-frame-pointer -march=k8
-CFLAGS = $(OPT_FLAGS) $(MACHINE_FLAGS) $(WARN_FLAGS) -Iinclude -Ignfs/poly
+CFLAGS += $(WARN_FLAGS) -Iinclude -Ignfs/poly $(CPPFLAGS)
LIBS = -lm
@@ -50,7 +50,7 @@
endif
# Note to MinGW users: comment out the next line, you don't need it
-LIBS += -lpthread
+LIBS += $(PTHREAD_LIBS)
#---------------------------------- Generic file lists -------------------
--- Makefile.orig 2010-08-28 03:28:32.000000000 -0400
+++ Makefile 2010-08-28 03:39:28.000000000 -0400
@@ -14,12 +14,12 @@
# gcc with basic optimization (-march flag could
# get overridden by architecture-specific builds)
-CC = gcc -D_FILE_OFFSET_BITS=64
+#CC = gcc -D_FILE_OFFSET_BITS=64
WARN_FLAGS = -Wall -W
-OPT_FLAGS = -O3 -fomit-frame-pointer -march=athlon-xp -DNDEBUG
+#OPT_FLAGS = -O3 -fomit-frame-pointer -march=athlon-xp -DNDEBUG
#OPT_FLAGS = -O3 -fomit-frame-pointer -march=k8 -DNDEBUG
-CFLAGS = $(OPT_FLAGS) $(MACHINE_FLAGS) $(WARN_FLAGS) \
+CFLAGS += $(OPT_FLAGS) $(MACHINE_FLAGS) $(WARN_FLAGS) \
-I. -Iinclude -Ignfs -Ignfs/poly -Ignfs/poly/stage1
# tweak the compile flags
@@ -60,7 +60,7 @@
# win32 or win64, so it's safe to pull libpthread into the link line.
# Of course this does mean you have to install the minGW pthreads bundle...
-LIBS += -lgmp -lm -lpthread
+LIBS += -lgmp -lm $(PTHREAD_LIBS)
#---------------------------------- Generic file lists -------------------