Fix autoconf detection of pthread_setschedparam() -- the test program

needs to be linked against -lpthread.

Regenerate patches by 'make makepatch'

Take maintainership

PR:		212823
Approved by:	brd
This commit is contained in:
Matthew Seaman 2016-09-19 13:52:34 +00:00
parent 60d85394bc
commit bc987eb569
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=422442
5 changed files with 23 additions and 4 deletions

View file

@ -2,10 +2,11 @@
PORTNAME= rsyslog
PORTVERSION= 8.19.0
PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.rsyslog.com/files/download/rsyslog/
MAINTAINER= brd@FreeBSD.org
MAINTAINER= matthew@FreeBSD.org
COMMENT= Syslogd supporting SQL, TCP, and TLS
BUILD_DEPENDS= libgcrypt-config:security/libgcrypt \

View file

@ -0,0 +1,18 @@
--- configure.ac.orig 2016-05-30 10:40:49 UTC
+++ configure.ac
@@ -294,10 +294,14 @@ AC_CHECK_LIB(
[1],
[Can set thread-name.])])
-AC_CHECK_FUNCS(
+AC_SEARCH_LIBS(
[pthread_setschedparam],
+ [pthread],
[
rsyslog_have_pthread_setschedparam=yes
+ AC_DEFINE([HAVE_PTHREAD_SETSCHEDPARAM],
+ [1],
+ [Can set thread scheduling parameters])
],
[
rsyslog_have_pthread_setschedparam=no

View file

@ -1,4 +1,4 @@
--- grammar/rainerscript.c.orig 2015-06-30 12:26:24 UTC
--- grammar/rainerscript.c.orig 2016-05-30 10:40:35 UTC
+++ grammar/rainerscript.c
@@ -35,6 +35,7 @@
#include <sys/stat.h>

View file

@ -1,4 +1,4 @@
--- plugins/impstats/impstats.c.orig 2015-04-30 08:50:15 UTC
--- plugins/impstats/impstats.c.orig 2016-05-30 10:40:35 UTC
+++ plugins/impstats/impstats.c
@@ -36,6 +36,7 @@
#include <errno.h>

View file

@ -1,4 +1,4 @@
--- runtime/nsd_ptcp.c.orig 2015-04-30 08:50:16 UTC
--- runtime/nsd_ptcp.c.orig 2016-05-02 13:37:05 UTC
+++ runtime/nsd_ptcp.c
@@ -656,7 +656,11 @@ EnableKeepAlive(nsd_t *pNsd)
if(pThis->iKeepAliveProbes > 0) {