multimedia/aom: expose Butteraugli tuning
This commit is contained in:
parent
bca68db28b
commit
bd359cba9a
2 changed files with 23 additions and 1 deletions
|
@ -22,9 +22,14 @@ GH_ACCOUNT= jbeich # mirror
|
|||
CMAKE_ON= BUILD_SHARED_LIBS
|
||||
CMAKE_OFF= ENABLE_DOCS ENABLE_TESTS
|
||||
|
||||
OPTIONS_DEFINE= VMAF
|
||||
OPTIONS_DEFINE= JXL VMAF
|
||||
OPTIONS_DEFAULT=VMAF
|
||||
|
||||
JXL_DESC= Encoding tuning for Butteraugli
|
||||
JXL_LIB_DEPENDS= libjxl.so:graphics/libjxl
|
||||
JXL_USES= pkgconfig
|
||||
JXL_CMAKE_ON= -DCONFIG_TUNE_BUTTERAUGLI:STRING=1
|
||||
|
||||
VMAF_DESC= Encoding tuning for VMAF
|
||||
VMAF_LIB_DEPENDS= libvmaf.so:multimedia/vmaf
|
||||
VMAF_USES= pkgconfig
|
||||
|
|
17
multimedia/aom/files/patch-CMakeLists.txt
Normal file
17
multimedia/aom/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,17 @@
|
|||
- Drop unused static libhwy dependency when using shared libjxl
|
||||
|
||||
--- CMakeLists.txt.orig 2021-10-13 17:24:39 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -525,12 +525,6 @@ if(CONFIG_AV1_ENCODER)
|
||||
if(LIBJXL_CFLAGS)
|
||||
append_compiler_flag("${LIBJXL_CFLAGS}")
|
||||
endif()
|
||||
- pkg_check_modules(LIBHWY REQUIRED libhwy)
|
||||
- target_link_libraries(aom PRIVATE ${LIBHWY_LDFLAGS} ${LIBHWY_LIBRARIES})
|
||||
- target_include_directories(aom PRIVATE ${LIBLIBHWY_INCLUDE_DIRS})
|
||||
- if(LIBHWY_CFLAGS)
|
||||
- append_compiler_flag("${LIBHWY_CFLAGS}")
|
||||
- endif()
|
||||
endif()
|
||||
|
||||
set_target_properties(aom PROPERTIES LINKER_LANGUAGE CXX)
|
Loading…
Reference in a new issue